Community discussions

MikroTik App
 
s0ll3kr4m
newbie
Topic Author
Posts: 44
Joined: Tue Sep 24, 2019 11:34 am

Port forwarding online game

Sat Nov 23, 2019 1:43 pm

Hello!!
I know this asked like thousand times, but I can't really find a proper way of doing it.

Let's say I want to port forward modern warfare 3 in mikrotik so the nat type would be opened.
Here are the ports 3074, 27014-27050 TCP
UDP 3074, 27014-27030.
What the proper command should I write in terminal.

Also when I'm connecting my PC straight to the modem/router the nat is opened.

It's moderate only if the pc is connected to the router mikrotik.

Thank you for any answer regarding to my problem!!
 
User avatar
jvanhambelgium
Member
Member
Posts: 385
Joined: Thu Jul 14, 2016 9:29 pm
Location: Belgium

Re: Port forwarding online game

Sat Nov 23, 2019 2:07 pm

Remember that you will have to ALSO adapt your ISP modem/router.
The reason why it works when you connect your PC directly to the ISP-router/modem is because of UPNP. Basically your PC gives instruction to "open" the required ports on the ISP-router/modem.
By default I don't think Mikrotiks have this enabled. You CAN enable it, but I'm not in favor of this and have disabled all that over here.

BUT this means when you manually adapt Mikrotik, you will also have to login the ISP-modem/router and perform the same PORT-MAPPING ! I don't know exactly what model ISPmodem/router but
Also, do you use static IP ? Does your PC always maintain the same internal IP ? What about the interface of your Mikrotik that connect to the ISP-modem/router ?


For the Mikrotik part, port-mapping (=DNAT) should be done with something like this (1 rule for TCP, 1 rule for UDP)

/ip firewall nat add chain=dstnat action=dst-nat to-addresses=ip.of.your.PC protocol=tcp dst-address=ip.of.interface.connected.to.ISP.modem in-interface=interface.to.ISP-modem dst-port=3074,27014-27050
/ip firewall nat add chain=dstnat action=dst-nat to-addresses=ip.of.your.PC protocol=udp dst-address=ip.of.interface.connected.to.ISP.modem in-interface=interface.to.ISP-modem dst-port=3074,27014-27050

...then make sure the traffic is allowed "through" the Mikrotik, so ADD these on the FORWARD chain.

/ip firewall filter add chain=forward action=accept connection-nat-state=dstnat protocol=tcp dst-address=ip.of.your.PC dst-port=3074,27014-27050
/ip firewall filter add chain=forward action=accept connection-nat-state=dstnat protocol=udp dst-address=ip.of.your.PC dst-port=3074,27014-27050
 
s0ll3kr4m
newbie
Topic Author
Posts: 44
Joined: Tue Sep 24, 2019 11:34 am

Re: Port forwarding online game

Sat Nov 23, 2019 3:03 pm

Thank you for your detailed reply, I will try it!
my PC is connected to the mikrotik In subnet 10.10.3.0 with an open 10.10.3.231
And the router/modem is the subnet 192.168.1.0.
Will I have to port forward the mikrotiks IP with the specific ports in the router/modem?
 
User avatar
jvanhambelgium
Member
Member
Posts: 385
Joined: Thu Jul 14, 2016 9:29 pm
Location: Belgium

Re: Port forwarding online game

Sat Nov 23, 2019 3:09 pm

Thank you for your detailed reply, I will try it!
my PC is connected to the mikrotik In subnet 10.10.3.0 with an open 10.10.3.231
And the router/modem is the subnet 192.168.1.0.
Will I have to port forward the mikrotiks IP with the specific ports in the router/modem?
Yes, from the ISP-router/modem perspective, you have to "port forward" the same towards to some 192.168.1.x address that the Mikrotik has.
Some ISPmodem-router allow some "DMZ" type of forward (meaning : ALL ports forwarded to a specific internal IP, in this case the Mikrotik which will be the "second router" behind the ISP device.
What IP does the Mikrotik have on the interface facing the ISProuter ? It will be also a 192.168.1.x

<<Internet>>-----<<<ISPmodem-router>>192.168.1.x ======================192.168.1.y<<Mikrotik>>10.10.3.254??==================<<PC @ 10.10.3.231>>
 
MASTER89
just joined
Posts: 1
Joined: Mon Dec 28, 2020 5:29 am

Re: Port forwarding online game

Mon Dec 28, 2020 5:32 am

HI BRO
YOU COULD SOLVE THE PROBLEM, I STILL HAVE THE SAME

Who is online

Users browsing this forum: gkoleff, Google [Bot], memelchenkov and 65 guests