Community discussions

MikroTik App
just joined
Topic Author
Posts: 7
Joined: Tue Dec 10, 2019 3:19 am

need help on bridged mikrotik router firm 6.46

Thu Dec 19, 2019 10:33 am


I am newbie to mikrotik environment.

I have two RB962UiGS wireless router. But router is using 6.46 release. I am using them for wireless capability and for switch. I do not need or want to use routing capabilities. I have used quikset menu available on the winbox menu with wisp ap mode on for both routers. I live in a two floor apartment and each router is being used as an access point in one of the floors. I selected bridge mode in quitset menu for both routers. All ports are bridged. Unique ip adresses have been given to the bridged created. Address acquisition is static. Gateway and dns addresses are provided which is a opnsense firewall in the network. Dhcp server or NAT are not activated.

Routers themselves can not reach to my gateway (I opened a terminal and pinged to the gateway) or attached wired devices to the switched ports (via a pc that is directly attached to the switched ports) but wireless clients can reach gateway/internet.

Mikrotik does not forward packets attached to wired bridged ports to the gateway somehow.

I really appreciate any help.

Thanks in advance.
User avatar
Forum Guru
Forum Guru
Posts: 1700
Joined: Sun Jan 06, 2013 11:19 pm
Location: Poland

Re: need help on bridged mikrotik router firm 6.46

Thu Dec 19, 2019 12:08 pm

If I understand you correctly, both RB must work as AccessPoint(AP) and of course all interface are one big bridge. One subnet, without vlans.
Then just run dhcp-client on bridge-lan interface, who should receive all data from PfSence.
If you configure manually IP then be sure you do it at bridge-lan, not a particular etherX etc. You should ping, arping the host's in network.

This should work for wired/wireless because all are in one big switch.
Please give us export of one device. I not use QuickSet then I don't know what he done.
Please use pastbin or use this button:
You do not have the required permissions to view the files attached to this post.
MTCNA + MTCRE + MTCINE | ~800 users at ~150 RouterBoards in EMEA
Knowledge Base about LTE by SiB | Buy me a caffe | Telegram:
just joined
Topic Author
Posts: 7
Joined: Tue Dec 10, 2019 3:19 am

Re: need help on bridged mikrotik router firm 6.46

Thu Dec 19, 2019 1:21 pm

To debug situation, I downgraded one of my routerts to 6.44 lts release with netinstall. I made the same configuration and the problem persists.

I give following information to help you understand the my environment.

Currently one of my router has the ip address and the lan gateway/firewall (opnsense) is They are connected to the same unmanaged switch. I have not added any specific configuration other than what is available mikrotik wisp ap quickset menu. I selected bridge mode (no router mode) under wisp ap mode configuration. Mikrotik router is connected to the unmanaged switch with single ethernet cable on port-1.

I can not simply ping from the mikrotik router by opening a terminal. How is this possible?

Dhcp client, which I added later, by your suggessiton can not access default gateway. It is always in search mode. My computer is attached to the same unmanaged switch which the mikrotik router and firewall connected. I can ping both from my pc, login to miktorik via winbox/webfig etc. My computer and all other devices, which are attached to unmanaged switch can reach gateway/firewall but mikrotik router can not.

However wireless connection works and forwards wireless clients properly to the gateway/firewall.

I will go crazy and rip my hair off.. I really do not understand what is wrong in such a basic configuration and what and why else must be done. Even though I am newbie in mikrotik, I am not in networking even though it is not my profession.

I exported configuration via /export and it is below. It is interesting that even though all ports are supposed to be bridged ether1 port is still marked as WAN. I made it LAN, the problem still persists.
# jan/02/1970 01:28:43 by RouterOS 6.44.6
# software id = 35BK-EUXW
# model = RouterBOARD 962UiGS-5HacT2HnT
/interface bridge
add name=bridge1
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-onlyn disabled=no frequency-mode=\
    superchannel mode=ap-bridge ssid=XXX
set [ find default-name=wlan2 ] band=5ghz-a/n/ac disabled=no frequency=5220 \
    frequency-mode=superchannel mode=ap-bridge ssid=XXX2 wireless-protocol=\
/interface list
add name=WAN
add name=LAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk mode=dynamic-keys \
    supplicant-identity=MikroTik wpa-pre-shared-key="xxxxxxxxxxxxx" \
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
add bridge=bridge1 interface=sfp1
add bridge=bridge1 interface=wlan2
add bridge=bridge1 interface=wlan1
/interface list member
add interface=ether1 list=WAN
add interface=ether2 list=LAN
add interface=ether3 list=LAN
add interface=ether4 list=LAN
add interface=ether5 list=LAN
add interface=sfp1 list=LAN
add interface=wlan2 list=LAN
add interface=wlan1 list=LAN
/ip address
add address= interface=bridge1 network=
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=bridge1
/ip dns
set servers=
/ip route
add distance=1 gateway=
/system identity
set name=ABCA
just joined
Topic Author
Posts: 7
Joined: Tue Dec 10, 2019 3:19 am

Re: need help on bridged mikrotik router firm 6.46  [SOLVED]

Thu Dec 19, 2019 3:15 pm

After hours of digging, changing cables even the switch, I reliazed that it is firewall problem. I switch from mikrotik dhcp server recently to opnsense dhcp server, I configured opnsense dhcp server to allow static leases preconfigured previously. The static leases did not have mikrotik switch which was entered statically.

This is funny and strange. Dhcp server is supposed to lease ip addresses to preconfigured or listed mac address that is asking. Somehow, even though there is no explicit rule, and there is an allow icmp packets rule in firewall rules, even if an allowed ip address is manually configured in the device (which is not asking for the lease), firewall blocks it, if not explicitly stated in dhcp static leases. I entered the bridged ports mac address in the dhcp lease table and the problem has been solved.

Undocumented feautere or bug I do not know.

Thank you again for the response.

Who is online

Users browsing this forum: Baidu [Spider], Bing [Bot] and 69 guests