Community discussions

MikroTik App
 
breizyann
just joined
Topic Author
Posts: 7
Joined: Wed Jul 24, 2019 5:11 pm

IPV6 dhcp client remain searching...

Mon Jan 27, 2020 1:34 pm

Hello @all,

Below is my router product - version 6.46.2 (stable):
https://mikrotik.com/product/hex_s
Fiber module in SFP port is: sercom fgs202 (optical fiber)
- -
Everything work/run perfectly with IPV4 (ipv4 dhcp client get a wan/public adress very quickly across a vlan over the sfp1 module).
Also all my lan devices are running like a charm behind the router.
- -
Now i'm trying to setup IPV6 dhcp client but it still remain in searching... status
i have activated the "ipv6" package in package list then rebooted the router.

Below is my IPV6 setup configuration trying to get a wan/ipv6 adress from my internet provider.
(i also confim that with my internet provider box i can get a wan ipv6 adress easily).


1. /ipv6 firewall filter add chain=input action=accept (ipv6 firewall IN opened for testing)
2. /ipv6 firewall filter add chain=output action=accept (ipv6 firewall OUT opened for testing)
3. /ipv6 settings set accept-router-advertisements=yes
4. /interface vlan add interface=Sfp1 loop-protect-disable-time=00:05:00 loop-protect-send-interval=00:00:05 name=VLAN123 vlan-id=123 (vlan anonymised) real work fine with ipv4.
5. /ipv6 dhcp-client option add code=16 name=class-identifier value=0x123456789abcdef (anonymised) real value work on ipv4
/ipv6 dhcp-client option add code=15 name=userclass value=0x123456789abcdef (anonymised) real value work on ipv4
6. /ipv6 dhcp-client option add code=11 name=authsend value=0x123456789abcdef (anonymised) real value work on ipv4
7. /ipv6 dhcp-client add interface=VLAN123 dhcp-options=authsend,userclass,class-identifier request=prefix pool-name=pool_FT_6 pool-prefix-length=64 add-default-route=yes

Then i check IPV6 dhcp client but it still remain in searching... status
Also it seems that no packets go out from the router IPV6 dhcp client

I also have a SFP/RJ45 module, i swaped the optical fiber module with it.
Then i directly connected a cable between the router (sfp/rj45 module installed) to my linux laptop computer running wireshark.
No traffic come to my laptop no UDP packets reached my wireshark laptop !!
(when i make similar test with IPV4 i can see the dhcp request reaching my wireshark laptop computer).

I don't know if i'm missing a main point of configuration? as no traffic go out from my IPV6 dhcp client.
Also it's why it always remain in searching... status

Any help will be appreciated.

Regards.
 
nowinskit
just joined
Posts: 9
Joined: Fri Jan 31, 2020 12:00 am

Re: IPV6 dhcp client remain searching...

Fri Jan 31, 2020 5:10 am

I have similar issue, but if i put dhcp-client to receive address instead, then fe80::1 server provide an public IP address(2804:xxx) to my mikrotik. In prefix mode it dont receive nothing, keep searching.

I searching for an solution aswell. Any help in this would be useful.

Thanks
 
breizyann
just joined
Topic Author
Posts: 7
Joined: Wed Jul 24, 2019 5:11 pm

Re: IPV6 dhcp client remain searching...

Tue Feb 04, 2020 1:35 pm

Hello @all,

Below is my router product - version 6.46.2 (stable):
https://mikrotik.com/product/hex_s
Fiber module in SFP port is: sercom fgs202 (optical fiber)
- -
Everything work/run perfectly with IPV4 (ipv4 dhcp client get a wan/public adress very quickly across a vlan over the sfp1 module).
Also all my lan devices are running like a charm behind the router.
- -
Now i'm trying to setup IPV6 dhcp client but it still remain in searching... status
i have activated the "ipv6" package in package list then rebooted the router.

Below is my IPV6 setup configuration trying to get a wan/ipv6 adress from my internet provider.
(i also confim that with my internet provider box i can get a wan ipv6 adress easily).


1. /ipv6 firewall filter add chain=input action=accept (ipv6 firewall IN opened for testing)
2. /ipv6 firewall filter add chain=output action=accept (ipv6 firewall OUT opened for testing)
3. /ipv6 settings set accept-router-advertisements=yes
4. /interface vlan add interface=Sfp1 loop-protect-disable-time=00:05:00 loop-protect-send-interval=00:00:05 name=VLAN123 vlan-id=123 (vlan anonymised) real work fine with ipv4.
5. /ipv6 dhcp-client option add code=16 name=class-identifier value=0x123456789abcdef (anonymised) real value work on ipv4
/ipv6 dhcp-client option add code=15 name=userclass value=0x123456789abcdef (anonymised) real value work on ipv4
6. /ipv6 dhcp-client option add code=11 name=authsend value=0x123456789abcdef (anonymised) real value work on ipv4
7. /ipv6 dhcp-client add interface=VLAN123 dhcp-options=authsend,userclass,class-identifier request=prefix pool-name=pool_FT_6 pool-prefix-length=64 add-default-route=yes

Then i check IPV6 dhcp client but it still remain in searching... status
Also it seems that no packets go out from the router IPV6 dhcp client

I also have a SFP/RJ45 module, i swaped the optical fiber module with it.
Then i directly connected a cable between the router (sfp/rj45 module installed) to my linux laptop computer running wireshark.
No traffic come to my laptop no UDP packets reached my wireshark laptop !!
(when i make similar test with IPV4 i can see the dhcp request reaching my wireshark laptop computer).

I don't know if i'm missing a main point of configuration? as no traffic go out from my IPV6 dhcp client.
Also it's why it always remain in searching... status

Any help will be appreciated.

Regards.

Hello @all,

I finally succeded to get the "bound" status on the ipv6 dhcp-client and also got a prefix from my ISP.
The main issue was related to a specific dhcp config needed for "dhcp sollicit" packets sent by the router.
I first made a capture from my ISP box/router to see what information was sent to the ISP server.
To do that i setup the dibbler dhcpv6 server on a linux box and captured the traffic on wireshark.

I then reconfigured my mikrotik router from scratch (removed all vlan, dhcp client (ipv4 & ipv6).
I also removed all dhcp options already registred in the router (for ipv4 as well as for ipv6).

With the ISP requested options well configured i got a bound status on the dhcpv6 client.
The ipv6 prefix is also available.

Kind regards,
Yann
 
stricky
just joined
Posts: 11
Joined: Tue Aug 19, 2014 2:46 pm

Re: IPV6 dhcp client remain searching...

Mon May 18, 2020 11:30 pm

Can you show me your config ....

Thx
Chris
 
breizyann
just joined
Topic Author
Posts: 7
Joined: Wed Jul 24, 2019 5:11 pm

Re: IPV6 dhcp client remain searching...

Sat Jun 06, 2020 10:56 am

Can you show me your config ....

Thx
Chris
Hello Chris,

What part of the config are you looking for ? dhcpv6 client settings ?
Also be aware that each config must match ISP server side expectation.
(may be my config will not match with your ISP server needs?)

Yann
 
kathampy
just joined
Posts: 10
Joined: Tue Apr 05, 2016 7:59 am

Re: IPV6 dhcp client remain searching...

Mon Dec 28, 2020 3:04 am

I finally succeded to get the "bound" status on the ipv6 dhcp-client and also got a prefix from my ISP.
The main issue was related to a specific dhcp config needed for "dhcp sollicit" packets sent by the router.
I have the same issue of DHCPv6 Client packets not being sent by the router. When connecting my PC with Wireshark directly to ether2 (or SFP with bridge & VLAN), there are no DHCPv6 packets captured. However IPv4 DHCP requests are captured.

How does setting client options solve the issue if no packets are being sent at all? I've posted more details here where it actually works on an incorrect configuration by using the slave interface instead of the bridge or VLAN interfaces. It does not work when using the bridge or VLAN interfaces.
viewtopic.php?f=2&t=154624
 
breizyann
just joined
Topic Author
Posts: 7
Joined: Wed Jul 24, 2019 5:11 pm

Re: IPV6 dhcp client remain searching...

Wed Jan 20, 2021 8:20 pm

@Kathampy

Hello my friend,

Please may you have a look at the following post if it can help you ?
viewtopic.php?f=2&t=154624&p=840143#p840143
 
kathampy
just joined
Posts: 10
Joined: Tue Apr 05, 2016 7:59 am

Re: IPV6 dhcp client remain searching...

Wed Jan 20, 2021 8:34 pm

I found that DHCPv6 works with the ISP, but the request packets are unable to be captured by Wireshark.

Who is online

Users browsing this forum: Baidu [Spider] and 70 guests