Community discussions

MikroTik App
 
User avatar
Paul9cf22ad1
newbie
Topic Author
Posts: 37
Joined: Sun Mar 12, 2017 11:40 pm
Location: Seattle, WA

No IP Address Acquired

Mon Feb 24, 2020 8:41 pm

I woke up the other day and found I didn't have any internet connection in the house. After doing a bit of trouble shooting I decided it was the MikroTik RB3011. It was setup as the gateway on 192.168.88.1 connected to the cable modem but it would not respond to a ping. However, I could log into it with the MAC via WinBox. On the WinBox Neighbors tab it said the address was 192.168.88.1

I noticed on Quick Set, under Internet > Address Acquisition it was set to Automatic, but had no IP Address listed. Releasing and renewing didn't do anything. I eventually messed things up so bad that I couldn't WinBox in. So I pulled the RB3011 out of the network and dropped in an old Netgear router which was able to get an IP Address. I ran the network that way for a few days.

Fast forward to now. I tried did a factory reset. Eventually I found on TIKDIS some reset instructions talking about a 3 sec: RouterOS reinstall and 5 sec: Reset configuration reset. Neither worked until I held down the reset button before I turned the power off. According to those instructions this uses a backup boot loader.

I restored from an older saved backup ... about two updates ago and now have version 6.46.1 running. However, I seem back to my original problem;
- No internet connection
- The RB3011 has no network IP address listed.
- WinBox can not connect to 192.168.88.1 but can connect with the MAC
- I can Ping 192.168.88.1 with no losses.
 
User avatar
anav
Forum Guru
Forum Guru
Posts: 5689
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada
Contact:

Re: No IP Address Acquired

Mon Feb 24, 2020 8:53 pm

Weird, as far as I know cable modems give out public IPs, you seem to be connecting your MT to another router (not a modem) and getting a LANIP as a WANIP.?????????????
I'd rather manage rats than software. Follow my advice at your own risk! (Sob & mkx forced me to write that!)
MTUNA Certified, by the Ascerbic Llama!
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 1079
Joined: Mon Apr 08, 2019 1:16 am

Re: No IP Address Acquired

Mon Feb 24, 2020 10:40 pm

If you cannot connect to 192.168.88.1 , how could you connect to the internet? This in the assumption of a gateway setup (route+NAT)
Unless you have the RB3011 set up as a bridge. In that case the 192.168.88.0/24 should not be used at all.

Please explain some more about your setup. Do you want to connect to to the ISP modem as a gateway (all your LAN devices get a 192.168.88.0/24 address from the RB3011) or just as a bridge.(all your devices and the RB3011 get an IP address from the ISP modem)

As a gateway the fact of not reaching 192.168.88.1 has nothing to do with internet access or not getting an IP address from the ISP modem. Check your LAN side first. Does the LAN side have the IP address 192.168.88.1 and Is the DHCP server on the RB3011 giving the right IP address in that subnet to your PC?
 
User avatar
Paul9cf22ad1
newbie
Topic Author
Posts: 37
Joined: Sun Mar 12, 2017 11:40 pm
Location: Seattle, WA

Re: No IP Address Acquired

Tue Feb 25, 2020 6:44 am

If you cannot connect to 192.168.88.1 , how could you connect to the internet? This in the assumption of a gateway setup (route+NAT)
With the RB3011 in the loop I am unable to connect to the internet. Only after I switched in the Netgear router does everything work. To me, that means that the cable modem is providing an IP address to the router (Netgear or RB3011).
Please explain some more about your setup. Do you want to connect to to the ISP modem as a gateway (all your LAN devices get a 192.168.88.0/24 address from the RB3011) or just as a bridge.(all your devices and the RB3011 get an IP address from the ISP modem)
The setup is pretty simple, Cloud > Cable Modem > then to 3 devices; switch, 2 wireless AC.
 
User avatar
Paul9cf22ad1
newbie
Topic Author
Posts: 37
Joined: Sun Mar 12, 2017 11:40 pm
Location: Seattle, WA

Re: No IP Address Acquired

Tue Feb 25, 2020 6:48 am

Weird, as far as I know cable modems give out public IPs, you seem to be connecting your MT to another router (not a modem) and getting a LANIP as a WANIP.?????????????
Yes, the cable modem provides an IP to two different access points I've added below it. For whatever reason the RB3011 either isn't asking for one, or isn't accepting it.

A bit about my setup. I have a cable modem in the front end and that cable goes into the first (Eth1) port. From there I connect to a switch and two wireless access points (that used to have vlans on them).
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 1079
Joined: Mon Apr 08, 2019 1:16 am

Re: No IP Address Acquired

Tue Feb 25, 2020 11:10 am

With the RB3011 in the loop I am unable to connect to the internet. Only after I switched in the Netgear router does everything work. To me, that means that the cable modem is providing an IP address to the router (Netgear or RB3011).
OK. But lets not jump to conclusions. If you cannot connect to the internet then something is broken in the path. Follow the path.

- IP address at the computer is correct: did the computer get one in the correct range? (192.168.88.2-192.168.88.254)
- Your MAC Winbox showed 192.168.88.1 for thr RB3011. So I assume the LAN side has that address.(on the bridge)
- The LAN side Bridge is in the LAN "interface list" for the default configuration.
- Bridge for the LAN side has DHCP server set
- The LAN interfaces are ports to the LAN bridge
- the ethernet to the modem is in the WAN "interface list"
- the WAN ethernet port is NOT a port to the LAN bridge
- the WAN ethernet port has a DHCP client
- the WAN interface has an IP address from the ISP. (Your subscription is not limited to one IP address)
- the other AP has NO DHCP server on the WAN side (DHCP servers will conflict)

You cannot WinBOX connect with the IP address to the RB3011, so I assume line 1 is broken.
 
User avatar
Paul9cf22ad1
newbie
Topic Author
Posts: 37
Joined: Sun Mar 12, 2017 11:40 pm
Location: Seattle, WA

Re: No IP Address Acquired

Tue Feb 25, 2020 8:49 pm

I don't think I understand some of your questions well enough to answer them. But here I go;
OK. But lets not jump to conclusions. If you cannot connect to the internet then something is broken in the path. Follow the path.
- IP address at the computer is correct: did the computer get one in the correct range? (192.168.88.2-192.168.88.254)
Yes, the RB3011 both assigns the correct static addresses to my servers and printers and gives the desktop computers one from the DHCP Server Range: 192.168.88.10 - 192.168.88.254. But none of the connected devices have access to the internet.
- Your MAC Winbox showed 192.168.88.1 for thr RB3011. So I assume the LAN side has that address.(on the bridge)
Yes, the Local Network IP address is set to 192.168.88.1
- The LAN side Bridge is in the LAN "interface list" for the default configuration.
On the Interface List there are 2 (?) entries;
;;;defconf
LAN bridge
;;;defconf
WAN ether1
- Bridge for the LAN side has DHCP server set
??? I'm not sure what you are asking for. The DHCP server has a single entry;
Name InterfaceRelay Lease Time Address_Pool Add ARP for Leases
defconf bridge DHCP no
- The LAN interfaces are ports to the LAN bridge
??? On the Bridge window, on Ports, I have ether2 through ether 10, plus sfp1
- the ethernet to the modem is in the WAN "interface list"
In the Interface List, there is an entry that states;
;;;WAN
ether1 ethernet
- the WAN ethernet port is NOT a port to the LAN bridge
I do not see ether1 listed on the Bridge Ports.
- the WAN ethernet port has a DHCP client
If you are asking if the cable modem has a DHCP client, then yes. It has no problem giving one when I swap in the Netgear router.
- the WAN interface has an IP address from the ISP. (Your subscription is not limited to one IP address)
I'm guessing I only get one IP from the ISP. There is only a single port on the cable modem. The cable modem has an IP address from my ISP, and when the Netgear router is connected to the cable modem it generally assigns one from 73.118.220.1/24 (Comcast). When I swap routers and the RB3011 in in the loop, on the Quick Set panel my Internet settings are;
- Port: Eth1
- Address Acquition: Automatic
- IP Address: [blank]
- Netmask: [blank]
- Gateway: [blank]
- the other AP has NO DHCP server on the WAN side (DHCP servers will conflict)
Correct, neither of the two wireless access points have DHCP enabled.
You cannot WinBOX connect with the IP address to the RB3011, so I assume line 1 is broken.
By line 1, do you mean the patch cable between the Eth1 on RB3011 and the Cable Modem? I've used several different cables, but all of them work when the Netgear router is swapped in.

I'll post a copy of the current script file in a reply.
 
User avatar
Paul9cf22ad1
newbie
Topic Author
Posts: 37
Joined: Sun Mar 12, 2017 11:40 pm
Location: Seattle, WA

Re: No IP Address Acquired

Tue Feb 25, 2020 8:51 pm

From my .src file generated today;

# jul/01/2019 08:56:46 by RouterOS 6.46.1
# software id = QSEQ-N8CZ
#
# model = RouterBOARD 3011UiAS
# serial number = 71A0065DE59E
/interface bridge
add admin-mac=6C:3B:6B:1C:E9:DC auto-mac=no comment=defconf name=bridge
/interface ethernet
set [ find default-name=ether1 ] comment=WAN
set [ find default-name=ether2 ] comment=Switch
set [ find default-name=ether5 ] comment=hAP
set [ find default-name=ether10 ] comment=wAP
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp ranges=192.168.88.10-192.168.88.254
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge name=defconf
/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=ether5
add bridge=bridge comment=defconf interface=ether6
add bridge=bridge comment=defconf interface=ether7
add bridge=bridge comment=defconf interface=ether8
add bridge=bridge comment=defconf interface=ether9
add bridge=bridge comment=defconf interface=ether10
add bridge=bridge comment=defconf interface=sfp1
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=ether1 list=WAN
/ip address
add address=192.168.88.1/24 comment=defconf interface=ether2 network=\
192.168.88.0
/ip dhcp-client
add comment=defconf disabled=no interface=ether1
/ip dhcp-server lease
add address=192.168.88.9 client-id=1:3c:2a:f4:27:87:88 comment=\
"Brother Printer" mac-address=3C:2A:F4:27:87:88 server=defconf
add address=192.168.88.3 client-id=1:e4:8d:8c:be:14:e1 comment=server \
mac-address=E4:8D:8C:BE:14:E1 server=defconf
add address=192.168.88.2 client-id=1:b8:69:f4:f0:52:eb comment="Iot Router" \
mac-address=B8:69:F4:F0:52:EB server=defconf
add address=192.168.88.4 client-id=1:44:94:fc:3c:ee:8e comment="Shire Router"\
mac-address=44:94:FC:3C:EE:8E server=defconf
/ip dhcp-server network
add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 name=router.lan
/ip firewall filter
add action=accept chain=input comment=\
"defconf: accept established,related,untracked" connection-state=\
established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
connection-state=established,related
add action=accept chain=forward comment=\
"defconf: accept established,related, untracked" connection-state=\
established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
connection-state=invalid
add action=drop chain=forward comment=\
"defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
ipsec-policy=out,none out-interface-list=WAN
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set ssh port=2200
set api disabled=yes
set api-ssl disabled=yes
/ip ssh
set forwarding-enabled=remote
/system clock
set time-zone-name=America/Los_Angeles
/system identity
set name="MikroTik RB3011"
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
/tool sniffer
set streaming-server=192.168.88.3
 
User avatar
anav
Forum Guru
Forum Guru
Posts: 5689
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada
Contact:

Re: No IP Address Acquired

Tue Feb 25, 2020 9:29 pm

I see nothing identifying your WANIP if indeed a static IP???? address??
I'd rather manage rats than software. Follow my advice at your own risk! (Sob & mkx forced me to write that!)
MTUNA Certified, by the Ascerbic Llama!
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 1079
Joined: Mon Apr 08, 2019 1:16 am

Re: No IP Address Acquired

Wed Feb 26, 2020 1:17 am

Ok , that's a lot of usefull information. My questions where not (are never) clear or easy to understand but I'll handle the answers where you understood something else.
I'm not very used in reading CLI lines in detail, lazy as I am in using the GUI whenever possible. But the CLI is the purest and easiest way to share the configuration.

Bridge for the LAN side has DHCP server set? Your DHCP server seems OK

/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge name=defconf
/interface bridge port

the WAN ethernet port has a DHCP client? The WAN port is ether1, looking for /IP DHCP-client in the config. Seems OK.

/ip dhcp-client
add comment=defconf disabled=no interface=ether1

Your MAC Winbox showed 192.168.88.1 for thr RB3011. So I assume the LAN side has that address.(on the bridge)? Oooops that's not the case. The IP address is on the (slave interface) ether2 !

/ip address
add address=192.168.88.1/24 comment=defconf interface=ether2 network=\
192.168.88.0

---> it has to be on interface =bridge


I'm not sure those 2 lines below do disable WinBOX over IP or not ...

set api disabled=yes
set api-ssl disabled=yes

This does enable WinBOX via MAC

/tool mac-server mac-winbox
set allowed-interface-list=LAN

the WAN interface has an IP address from the ISP. (Your subscription is not limited to one IP address)
I'm guessing I only get one IP from the ISP. There is only a single port on the cable modem. The cable modem has an IP address from my ISP, and when the Netgear router is connected to the cable modem it generally assigns one from 73.118.220.1/24 (Comcast). When I swap routers and the RB3011 in in the loop, on the Quick Set panel my Internet settings are;
- Port: Eth1


This looks OK as setting, and the DHCP-client on the ether1 interface on the RB3011 should pick it up. But sometimes the ISP has a very long lease time for the DHCP lease from their DHCP server, and will limit it to ONE MAC address only for the duration of the lease. (Can easily be 2 hours). So this is tricky (simple test, connect your PC directly to the cable modem, and check if it gets an IP address or not. If not, the DHCP IP address limitation by the ISP is active )

(How to bypass the one IP address limitation? You either release the DHCP lease for the IP address from the Netgear router, or copy the MAC address of the Netgear router on the ether1 interface of the RB3011, or just wait long enough ....)
 
User avatar
Paul9cf22ad1
newbie
Topic Author
Posts: 37
Joined: Sun Mar 12, 2017 11:40 pm
Location: Seattle, WA

Re: No IP Address Acquired

Wed Feb 26, 2020 7:15 pm

I see nothing identifying your WANIP if indeed a static IP???? address??
My cable modem dynamically receives an IP address from Comcast. I can log into it (192.168.100.1) and see my external address.
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 1079
Joined: Mon Apr 08, 2019 1:16 am

Re: No IP Address Acquired

Wed Feb 26, 2020 7:57 pm

" I can log into it (192.168.100.1) and see my external address."
In that case: Your RB3011 should get one in that 192.168.100.0 range as well, as the Netgear, just as your PC.

The information: "when the Netgear router is connected to the cable modem it generally assigns one from 73.118.220.1/24 (Comcast)." confused me, in thinking the cable modem was transparent. But it seems to do NAT for your LAN. The RB3011 is doing a second NAT towards your devices.

"ISP - 73.118.220.1/24 - cable modem - 192.168.100.0/24 - RB3011 - 192.168.88.0/24 - LAN en WLAN devices" is what I understand now.
DHCPserver (ISP network) DHCPclient (cable modem with NAT) DHCPserver (modem local network) DHCPclient (RB3011 with NAT) DHCPserver (RB3011 local network) DHCPclient (user device)
 
User avatar
Paul9cf22ad1
newbie
Topic Author
Posts: 37
Joined: Sun Mar 12, 2017 11:40 pm
Location: Seattle, WA

Re: No IP Address Acquired

Wed Feb 26, 2020 9:59 pm

I tried your two suggestions; Changing the interface to bridge, and cloning the MAC of the Netgear. Neither seemed to make any difference.

I did notice that ether1 is getting traffic, about Tx 512 bps and Rx is spiky from 720 bps to 4.3 kbps. But the darned thing isn't getting an IP address. I've added a third router to the mix (only one at a time), an ancient WRT54. Even it works and gets an IP.

So is the RB3011 toast? Or maybe just ether1 on it?
Ok , that's a lot of usefull information. [snip]

/ip address
add address=192.168.88.1/24 comment=defconf interface=ether2 network=\
192.168.88.0

---> it has to be on interface =bridge

(How to bypass the one IP address limitation? You either release the DHCP lease for the IP address from the Netgear router, or copy the MAC address of the Netgear router on the ether1 interface of the RB3011, or just wait long enough ....)
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 1079
Joined: Mon Apr 08, 2019 1:16 am

Re: No IP Address Acquired

Thu Feb 27, 2020 12:16 am

I did notice that ether1 is getting traffic, about Tx 512 bps and Rx is spiky from 720 bps to 4.3 kbps. But the darned thing isn't getting an IP address. I've added a third router to the mix (only one at a time), an ancient WRT54. Even it works and gets an IP.

So is the RB3011 toast? Or maybe just ether1 on it?
Getting an IP address is about ether1 only. The rest of the ports or bridges are not involved.
Ether1 and its DHCP client are the items that must be able to get an IP address lease from the cable/modem.
Using TORCH or even better SNIFFER one can see what those 512 bps and 4.3 kbps are about. Port 68 is about DHCP.

You know the information the Netgear was getting. You can set it manually in the RB3011. Something like IP address 192.168.100.100 on ether1 , IP route 0.0.0.0/0 to Gateway 192.168.100.1, IP DNS 192.168.100.1 or 8.8.8.8
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 1079
Joined: Mon Apr 08, 2019 1:16 am

Re: No IP Address Acquired

Thu Feb 27, 2020 12:21 am

Add logging for DHCP.

System-> Logging -> add rule
Topics: DHCP
Prefix: debug
Action: memory

What comes in the Log ?
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 1079
Joined: Mon Apr 08, 2019 1:16 am

Re: No IP Address Acquired

Thu Feb 27, 2020 12:35 am

Related or even same topic ???? viewtopic.php?t=153873


the DHCPDISCOVER leaves with no 802.1Q tag, the DHCPOFFER arrives with an 802.1Q tag with VID bits set to 0, which is a legal way to say "treat this frame as if it was tagless, but use the priority information" . Your case ?
Last edited by bpwl on Thu Feb 27, 2020 2:11 am, edited 1 time in total.
 
User avatar
rooted
Member Candidate
Member Candidate
Posts: 122
Joined: Tue Feb 04, 2020 5:58 pm

Re: No IP Address Acquired

Thu Feb 27, 2020 12:54 am


confused me, in thinking the cable modem was transparent. But it seems to do NAT for your LAN. The RB3011 is doing a second NAT towards your devices.
You should have to manually set your IP in the 192.x.x.x range to connect to the modem and the only IP it serves is your external unless it's a gateway and not simply a cable modem.
 
User avatar
Paul9cf22ad1
newbie
Topic Author
Posts: 37
Joined: Sun Mar 12, 2017 11:40 pm
Location: Seattle, WA

Re: No IP Address Acquired

Mon Mar 02, 2020 7:05 pm

Add logging for DHCP.

System-> Logging -> add rule
Topics: DHCP
Prefix: debug
Action: memory

What comes in the Log ?
Sorry it took me so long, I was out of town for a bit.
I've never played with the logs so I put the rule you suggested in, and watched the router try unsuccessfully to get an address from the cable modem. I changed memory to disk and captured a short segment. I know that the RB3011 was receiving something because the interface traffic shows it. But nothing showed up in the log.
Jul/01/2019 08:43:37 dhcp,debug,packet debug: dhcp-client on ether1 sending discover with id 3650806978 to 255.255.255.255
Jul/01/2019 08:43:37 dhcp,debug,packet debug: secs = 43
Jul/01/2019 08:43:37 dhcp,debug,packet debug: flags = broadcast
Jul/01/2019 08:43:37 dhcp,debug,packet debug: ciaddr = 0.0.0.0
Jul/01/2019 08:43:37 dhcp,debug,packet debug: chaddr = 6C:3B:6B:1C:E9:DB
Jul/01/2019 08:43:37 dhcp,debug,packet debug: Msg-Type = discover
Jul/01/2019 08:43:37 dhcp,debug,packet debug: Parameter-List = Subnet-Mask,Classless-Route,Router,Static-Route,Domain-Server,NTP-Server,CAPWAP-Server,Vendor-Specific
Jul/01/2019 08:43:37 dhcp,debug,packet debug: Host-Name = "MikroTik RB3011"
Jul/01/2019 08:43:37 dhcp,debug,packet debug: Client-Id = 01-6C-3B-6B-1C-E9-DB
Jul/01/2019 08:43:41 dhcp,debug,packet debug: dhcp-client on ether1 sending discover with id 3650806978 to 255.255.255.255
Jul/01/2019 08:43:41 dhcp,debug,packet debug: secs = 47
Jul/01/2019 08:43:41 dhcp,debug,packet debug: flags = broadcast
Jul/01/2019 08:43:41 dhcp,debug,packet debug: ciaddr = 0.0.0.0
Jul/01/2019 08:43:41 dhcp,debug,packet debug: chaddr = 6C:3B:6B:1C:E9:DB
Jul/01/2019 08:43:41 dhcp,debug,packet debug: Msg-Type = discover
Jul/01/2019 08:43:41 dhcp,debug,packet debug: Parameter-List = Subnet-Mask,Classless-Route,Router,Static-Route,Domain-Server,NTP-Server,CAPWAP-Server,Vendor-Specific
Jul/01/2019 08:43:41 dhcp,debug,packet debug: Host-Name = "MikroTik RB3011"
Jul/01/2019 08:43:41 dhcp,debug,packet debug: Client-Id = 01-6C-3B-6B-1C-E9-DB
Then I tried something different. I connected the Netgear router to the cable modem and the RB3011 downstream of the Netgear and turned off the DHCP server on the RB3011. The RB3011 got an address. Since this was a one shot deal, I didn't get it on disk, but here is what I saw;
dhcp,debug,packet debug: dhcp-client on ether1 received ack with id 27007199628 from 192.168.88.1
dhcp,debug,packet debug: ciaddr = 0.0.0.0
dhcp,debug,packet debug: yiaddr = 192.168.88.14
dhcp,debug,packet debug: chaddr = 6C:3B:6B:1C:E9:D8
dhcp,debug,packet debug: Msg-Type = Ack
dhcp,debug,packet debug: Server-Id = 192.168.88.1
dhcp,debug,packet debug: Address-Time = 86400
dhcp,debug,packet debug: Subnet-Mask = 255.255.255.0
dhcp,debug,packet debug: Router = 192.168.88.1
dhcp,debug,packet debug: Domaine-Server = 192.168.88.1
dhcp, info dhcp-client on ether1 got IP address 192.168.88.14
dhcp, debug,state debug: dhcp-client on ether1 entering <bound> state
interface, info ether1 detect INTERNET
It seems, that when the RB3011 asks the cable modem for an address it doesn't get one (it gets some traffic but I don't know what). However, when I connect either the Netgear or the ancient WRT they have no issue getting an IP from the cable modem.
 
User avatar
Paul9cf22ad1
newbie
Topic Author
Posts: 37
Joined: Sun Mar 12, 2017 11:40 pm
Location: Seattle, WA

Re: No IP Address Acquired

Mon Mar 02, 2020 7:09 pm

Related or even same topic ???? viewtopic.php?t=153873

the DHCPDISCOVER leaves with no 802.1Q tag, the DHCPOFFER arrives with an 802.1Q tag with VID bits set to 0, which is a legal way to say "treat this frame as if it was tagless, but use the priority information" . Your case ?
@bpwl This certainly sounds similar to my problem. But the discussion is way over my head.
 
User avatar
Paul9cf22ad1
newbie
Topic Author
Posts: 37
Joined: Sun Mar 12, 2017 11:40 pm
Location: Seattle, WA

Re: No IP Address Acquired

Mon Mar 02, 2020 7:20 pm

Just for grins I went into the Cable Modem and pulled up its log. That's about all I can do with it since it is locked up by the cable company. I don't see anything happening in it when my problems started on Feb 16.
Thu Feb 06 00:24:08 2020 Critical (3) REG RSP not received;CM-MAC=20:3d:66:9d:16:60;CMTS-MAC=00:59:dc:79:3f:21;CM-QOS=1.1;CM-VER=3.0;
Thu Feb 06 00:24:11 2020 Critical (3) Started Unicast Maintenance Ranging - No Response received - T3 time-out;CM-MAC=20:3d:66:9d:16:60;CMTS-MAC=00:59:dc:79:3f:21;CM-QOS=1.1;CM-VER=3.0;
Thu Feb 06 00:31:59 2020 Critical (3) SYNC Timing Synchronization failure - Loss of Sync;CM-MAC=20:3d:66:9d:16:60;CMTS-MAC=00:59:dc:79:3f:21;CM-QOS=1.1;CM-VER=3.0;
Thu Feb 06 00:32:52 2020 Critical (3) Started Unicast Maintenance Ranging - No Response received - T3 time-out;CM-MAC=20:3d:66:9d:16:60;CMTS-MAC=00:59:dc:79:3f:21;CM-QOS=1.1;CM-VER=3.0;
Thu Feb 06 00:35:02 2020 Critical (3) Received Response to Broadcast Maintenance Request, But no Unicast Maintenance opportunities received - T4 time out;CM-MAC=20:3d:66:9d:16:60;CMTS-MAC=00:59:dc:79:3f:21;CM-QOS=1.1;CM-VER=3.0;
Time Not Established Critical (3) No Ranging Response received - T3 time-out
Time Not Established Notice (6) Honoring MDD; IP provisioning mode = IPv6
Thu Feb 06 00:36:15 2020 Warning (5) Unicast DSID PSN startup error
Tue Feb 25 10:11:53 2020 Critical (3) Started Unicast Maintenance Ranging - No Response received - T3 time-out;CM-MAC=20:3d:66:9d:16:60;CMTS-MAC=00:59:dc:79:3f:21;CM-QOS=1.1;CM-VER=3.0;
Tue Feb 25 10:16:59 2020 Warning (5) MDD message timeout;CM-MAC=20:3d:66:9d:16:60;CMTS-MAC=00:59:dc:79:3f:21;CM-QOS=1.1;CM-VER=3.0;
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 1079
Joined: Mon Apr 08, 2019 1:16 am

Re: No IP Address Acquired

Mon Mar 02, 2020 9:13 pm

Related or even same topic ???? viewtopic.php?t=153873

the DHCPDISCOVER leaves with no 802.1Q tag, the DHCPOFFER arrives with an 802.1Q tag with VID bits set to 0, which is a legal way to say "treat this frame as if it was tagless, but use the priority information" . Your case ?
@bpwl This certainly sounds similar to my problem. But the discussion is way over my head.
I'm also thinking it really is very close to your problem. The modem answering via a "VLAN 0" what is not expected, but no problem to most simple routers. This is beyond my experience, and there are other threads in this forum about the same story. It al depends on your VLAN setting or not and the switch chip in the router. It would not harm to try this workaround from that related thread, i.e. allow VLAN 0 traffic to pass into the router to the cpu. "Fallback" is not well explained in the wiki (I personally see no difference with "disabled" for the handling of an unknown VLAN, but that will be lack of knowledge) , but if it works for others, why not try it.

Setting the vlan-mode to "fallback" in the switch menu for that port. It can be done with the GUI as well.

# allow ingress packets with VLAN ID 0, to not get dropped
/interface ethernet switch port
set ether1 vlan-mode=fallback
 
User avatar
Paul9cf22ad1
newbie
Topic Author
Posts: 37
Joined: Sun Mar 12, 2017 11:40 pm
Location: Seattle, WA

Re: No IP Address Acquired

Tue Mar 03, 2020 11:06 pm

Related or even same topic ???? viewtopic.php?t=153873

Setting the vlan-mode to "fallback" in the switch menu for that port. It can be done with the GUI as well.

# allow ingress packets with VLAN ID 0, to not get dropped
/interface ethernet switch port
set ether1 vlan-mode=fallback
Unfortunately, that didn't do the trick :(
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 1079
Joined: Mon Apr 08, 2019 1:16 am

Re: No IP Address Acquired

Wed Mar 04, 2020 1:28 am

Sorry, a have no more hints. I hope the people at "Bypassing AT&T Residential Gateways with MikroTik" will have more information for you. They go very deep using Wireshark packet inspection. That is the normal next step, but goes deep into the details.
Good luck!
 
User avatar
Paul9cf22ad1
newbie
Topic Author
Posts: 37
Joined: Sun Mar 12, 2017 11:40 pm
Location: Seattle, WA

Re: No IP Address Acquired

Thu Apr 16, 2020 5:47 am

Anyone got any ideas?
 
User avatar
anav
Forum Guru
Forum Guru
Posts: 5689
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada
Contact:

Re: No IP Address Acquired

Thu Apr 16, 2020 6:09 pm

Yup try the suggestion in the other forum about using some switch chip tricks.........

# allow ingress packets with VLAN ID 0, to not get dropped
/interface ethernet switch port
set ether1 vlan-mode=fallback

Now that is probably in concert with other settings not stand alone!
I'd rather manage rats than software. Follow my advice at your own risk! (Sob & mkx forced me to write that!)
MTUNA Certified, by the Ascerbic Llama!
 
User avatar
pcunite
Forum Guru
Forum Guru
Posts: 1127
Joined: Sat May 25, 2013 5:13 am
Location: USA

Re: No IP Address Acquired

Fri Apr 17, 2020 4:16 pm

If upstream hardware requires 802.1p, then that ability is not configurable with MikroTik, yet. Instead, you'll need to place a Cisco switch in front of the MikroTik and have it set the bits on the outgoing packets.
 
User avatar
Paul9cf22ad1
newbie
Topic Author
Posts: 37
Joined: Sun Mar 12, 2017 11:40 pm
Location: Seattle, WA

Re: No IP Address Acquired

Sat Apr 18, 2020 4:09 am

I thought I'd give this old post a ping. I still have this problem. I hate to toss the RB3011 but it is a brick right now. Hope someone can lend a hand before I have to move on.
 
SEJohnsen
newbie
Posts: 39
Joined: Wed Aug 26, 2020 11:50 pm

Re: No IP Address Acquired

Sat Sep 05, 2020 9:40 pm

Paul, for what it's worth, it's not your imagination. I'm having nearly the exact same issue. The Comcast cable modem failed to provide an IP address to the Mikrotik RB, so the automatic WAN IP address got changed to a static IP 0.0.0.0 in Quick Set. If I change it back to automatic, or set it to a valid static IP, the WebFig stops working properly. It shouldn't do that, but it does.
 
SEJohnsen
newbie
Posts: 39
Joined: Wed Aug 26, 2020 11:50 pm

Re: No IP Address Acquired

Sat Sep 05, 2020 10:18 pm

Paul, someone told me that I should NOT use Quick Set to make changes unless this is a first boot situation. So you should use WebFig to edit.

I found this here. This may be your solution.
https://help.mikrotik.com/docs/display/ ... figuration
 
DarkNate
Member Candidate
Member Candidate
Posts: 200
Joined: Fri Jun 26, 2020 4:37 pm

Re: No IP Address Acquired

Sat Sep 05, 2020 11:58 pm

Good news is I've already opened a bug report support ticket with MikroTik on this very issue.

About two days ago I was able to catch the bug (logs and everything right) right after a clean reboot, which I then immediately generated a supout file and that should give MikroTik sufficient information to patch the bug.

What happens is, the interface itself gets an IP successfully from the upstream, but it fails to assign in IP>Address automatically/dynamically.
 
SEJohnsen
newbie
Posts: 39
Joined: Wed Aug 26, 2020 11:50 pm

Re: No IP Address Acquired

Sun Sep 06, 2020 12:29 am

Good news is I've already opened a bug report support ticket with MikroTik on this very issue.

About two days ago I was able to catch the bug (logs and everything right) right after a clean reboot, which I then immediately generated a supout file and that should give MikroTik sufficient information to patch the bug.

What happens is, the interface itself gets an IP successfully from the upstream, but it fails to assign in IP>Address automatically/dynamically.
That's great! Thanks for sharing.

Who is online

Users browsing this forum: cyon and 34 guests