Community discussions

MikroTik App
 
Matthiastik
just joined
Topic Author
Posts: 12
Joined: Wed Apr 25, 2018 1:31 am

Winbox connection behind DSL modem of ISP2

Wed Mar 25, 2020 5:20 pm

Good morning,

i have 2 ISP and main ISP with IP public is failing quite often and ISP2 with DSL modem have dynamic IP and question is how can i connect using
winbox? i have currently port knocking for access to router tht works on ISP1 with public IP.

I assume that i need to create an VPN and hope DSL modem does not block that kind of traffic ...

Thank you
 
Sob
Forum Guru
Forum Guru
Posts: 5416
Joined: Mon Apr 20, 2009 9:11 pm

Re: Winbox connection behind DSL modem of ISP2

Wed Mar 25, 2020 11:00 pm

VPN is generally good thing, but you don't have to use it, you can keep using WinBox directly, if you like it that way. You just need to make sure that when request comes from ISP2, router sends response there. So mark new incoming connections from internet based on interface and then mark routing for response packet, to go back the same way.

If you have no idea how, then check https://wiki.mikrotik.com/wiki/Manual:PCC. It's primarily about load balancing, so don't blindly copy it, but focus on that I wrote. Important for you are these parts:
/ip firewall mangle
...
add chain=prerouting in-interface=ISP1 connection-mark=no-mark action=mark-connection new-connection-mark=ISP1_conn
add chain=prerouting in-interface=ISP2 connection-mark=no-mark action=mark-connection new-connection-mark=ISP2_conn
...
add chain=output connection-mark=ISP1_conn action=mark-routing new-routing-mark=to_ISP1     
add chain=output connection-mark=ISP2_conn action=mark-routing new-routing-mark=to_ISP2

/ip route
add dst-address=0.0.0.0/0 gateway=10.111.0.1 routing-mark=to_ISP1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=10.112.0.1 routing-mark=to_ISP2 check-gateway=ping
People who quote full posts should be spanked with ethernet cable. Some exceptions for multi-topic threads may apply. Not intended as incentive for masochists.
 
Matthiastik
just joined
Topic Author
Posts: 12
Joined: Wed Apr 25, 2018 1:31 am

Re: Winbox connection behind DSL modem of ISP2

Thu Mar 26, 2020 12:01 am

Sorry i forget, DSL modem have nat so mikrotik is behind nat and getting an Local IP 192.168.x.x .

cheers,
 
Sob
Forum Guru
Forum Guru
Posts: 5416
Joined: Mon Apr 20, 2009 9:11 pm

Re: Winbox connection behind DSL modem of ISP2

Thu Mar 26, 2020 12:47 am

If DSL modem has public address and can forward ports to RB, it's no problem. If not, you're out of luck.
People who quote full posts should be spanked with ethernet cable. Some exceptions for multi-topic threads may apply. Not intended as incentive for masochists.

Who is online

Users browsing this forum: ballefjant and 111 guests