Community discussions

MikroTik App
 
riodavinci1
just joined
Topic Author
Posts: 5
Joined: Mon Mar 23, 2020 5:57 pm

limited download

Thu Jul 02, 2020 1:14 am

hello guys,
my client have gaming internet cafe and i would like to prioritizing gaming packets and limit download speed he have 1GB download and 300MB upload. i tried this one but its give each pc 50MB instead of 500 mbs. and its slow download but give high upload.
this is the full script.
# jul/01/2020 18:48:52 by RouterOS 6.47

# model = CCR1036-12G-4S

/ip firewall address-list
add address=120.10.0.2-120.10.0.254 list=allowed_to_router
add address=0.0.0.0/8 comment=RFC6890 list=not_in_internet
add address=172.16.0.0/12 comment=RFC6890 list=not_in_internet
add address=192.168.0.0/16 comment=RFC6890 list=not_in_internet
add address=10.0.0.0/8 comment=RFC6890 list=not_in_internet
add address=169.254.0.0/16 comment=RFC6890 list=not_in_internet
add address=127.0.0.0/8 comment=RFC6890 list=not_in_internet
add address=224.0.0.0/4 comment=Multicast list=not_in_internet
add address=198.18.0.0/15 comment=RFC6890 list=not_in_internet
add address=192.0.2.0/24 comment=RFC6890 list=not_in_internet
add address=198.51.100.0/24 comment=RFC6890 list=not_in_internet
add address=203.0.113.0/24 comment=RFC6890 list=not_in_internet
add address=100.64.0.0/10 comment=RFC6890 list=not_in_internet
add address=240.0.0.0/4 comment=RFC6890 list=not_in_internet
add address=192.88.99.0/24 comment="6to4 relay Anycast [RFC 3068]" list=\
not_in_internet

/ip firewall mangle
add action=mark-connection chain=prerouting disabled=yes new-connection-mark=\
games passthrough=yes port=5222,5795-5847 protocol=tcp
add action=mark-packet chain=prerouting connection-mark=games disabled=yes \
new-packet-mark=games_packets passthrough=no
add action=mark-connection chain=input in-interface=pppoe-out1 \
new-connection-mark=WAN1_conn passthrough=yes
add action=mark-connection chain=input in-interface=pppoe-out2 \
new-connection-mark=WAN2_conn passthrough=yes
add action=mark-connection chain=input in-interface=pppoe-out3 \
new-connection-mark=WAN3_conn passthrough=yes
add action=mark-connection chain=input in-interface=pppoe-out4 \
new-connection-mark=WAN4_conn passthrough=yes
add action=mark-connection chain=input in-interface=pppoe-out5 \
new-connection-mark=WAN5_conn passthrough=yes
add action=mark-connection chain=input in-interface=pppoe-out6 \
new-connection-mark=WAN6_conn passthrough=yes
add action=mark-connection chain=input in-interface=pppoe-out7 \
new-connection-mark=WAN7_conn passthrough=yes
add action=mark-routing chain=output connection-mark=WAN1_conn \
new-routing-mark=to_WAN1
add action=mark-routing chain=output connection-mark=WAN2_conn \
new-routing-mark=to_WAN2
add action=mark-routing chain=output connection-mark=WAN3_conn \
new-routing-mark=to_WAN3
add action=mark-routing chain=output connection-mark=WAN4_conn \
new-routing-mark=to_WAN4
add action=mark-routing chain=output connection-mark=WAN5_conn \
new-routing-mark=to_WAN5
add action=mark-routing chain=output connection-mark=WAN6_conn \
new-routing-mark=to_WAN6
add action=mark-routing chain=output connection-mark=WAN7_conn \
new-routing-mark=to_WAN7
add action=mark-connection chain=prerouting dst-address-type=!local \
in-interface=sfp1-LAN new-connection-mark=WAN1_conn passthrough=yes \
per-connection-classifier=both-addresses-and-ports:7/0
add action=mark-connection chain=prerouting dst-address-type=!local \
in-interface=sfp1-LAN new-connection-mark=WAN2_conn passthrough=yes \
per-connection-classifier=both-addresses-and-ports:7/1
add action=mark-connection chain=prerouting dst-address-type=!local \
in-interface=sfp1-LAN new-connection-mark=WAN3_conn passthrough=yes \
per-connection-classifier=both-addresses-and-ports:7/2
add action=mark-connection chain=prerouting dst-address-type=!local \
in-interface=sfp1-LAN new-connection-mark=WAN4_conn passthrough=yes \
per-connection-classifier=both-addresses-and-ports:7/3
add action=mark-connection chain=prerouting dst-address-type=!local \
in-interface=sfp1-LAN new-connection-mark=WAN5_conn passthrough=yes \
per-connection-classifier=both-addresses-and-ports:7/4
add action=mark-connection chain=prerouting dst-address-type=!local \
in-interface=sfp1-LAN new-connection-mark=WAN6_conn passthrough=yes \
per-connection-classifier=both-addresses-and-ports:7/5
add action=mark-connection chain=prerouting dst-address-type=!local \
in-interface=sfp1-LAN new-connection-mark=WAN7_conn passthrough=yes \
per-connection-classifier=both-addresses-and-ports:7/6
add action=mark-routing chain=prerouting connection-mark=WAN1_conn \
in-interface=sfp1-LAN new-routing-mark=to_WAN1
add action=mark-routing chain=prerouting connection-mark=WAN2_conn \
in-interface=sfp1-LAN new-routing-mark=to_WAN2
add action=mark-routing chain=prerouting connection-mark=WAN3_conn \
in-interface=sfp1-LAN new-routing-mark=to_WAN3
add action=mark-routing chain=prerouting connection-mark=WAN4_conn \
in-interface=sfp1-LAN new-routing-mark=to_WAN4
add action=mark-routing chain=prerouting connection-mark=WAN5_conn \
in-interface=sfp1-LAN new-routing-mark=to_WAN5
add action=mark-routing chain=prerouting connection-mark=WAN6_conn \
in-interface=sfp1-LAN new-routing-mark=to_WAN6
add action=mark-routing chain=prerouting connection-mark=WAN7_conn \
in-interface=sfp1-LAN new-routing-mark=to_WAN7
add action=mark-connection chain=prerouting comment=tcp new-connection-mark=\
tcp passthrough=yes protocol=tcp
add action=mark-packet chain=prerouting connection-mark=tcp new-packet-mark=\
tcp passthrough=no
add action=mark-connection chain=prerouting comment=udp new-connection-mark=\
udp passthrough=yes port=443 protocol=udp
add action=mark-packet chain=prerouting connection-mark=udp new-packet-mark=\
udp passthrough=no
add action=mark-connection chain=prerouting comment=valorant disabled=yes \
new-connection-mark=games passthrough=yes port=\
2099,5222-5223,8088,8393-8400 protocol=tcp
add action=mark-packet chain=prerouting connection-mark=games disabled=yes \
new-packet-mark=games_packets passthrough=no
/ip firewall nat
add action=masquerade chain=srcnat out-interface=pppoe-out1 src-address=\
120.10.0.0/24
add action=masquerade chain=srcnat out-interface=pppoe-out2 src-address=\
120.10.0.0/24
add action=masquerade chain=srcnat out-interface=pppoe-out3 src-address=\
120.10.0.0/24
add action=masquerade chain=srcnat out-interface=pppoe-out4 src-address=\
120.10.0.0/24
add action=masquerade chain=srcnat out-interface=pppoe-out5 src-address=\
120.10.0.0/24
add action=masquerade chain=srcnat out-interface=pppoe-out6 src-address=\
120.10.0.0/24
add action=masquerade chain=srcnat out-interface=pppoe-out7 src-address=\
120.10.0.0/24
/queue tree
add name=TotalBW parent=sfp1-LAN priority=1 queue=PCQ_download
add burst-limit=850M burst-threshold=820M burst-time=2s limit-at=512M \
max-limit=790M name=download1 packet-mark=tcp parent=TotalBW priority=3 \
queue=PCQ_download
add burst-limit=1G burst-threshold=980M burst-time=2s limit-at=999M \
max-limit=999M name=game packet-mark=no-mark parent=TotalBW priority=1 \
queue=default
add burst-limit=800M burst-threshold=790M burst-time=2s limit-at=512M \
max-limit=780M name=queue1 packet-mark=udp parent=TotalBW priority=7 \
queue=PCQ_download

Who is online

Users browsing this forum: No registered users and 15 guests