Community discussions

MikroTik App
 
eong
just joined
Topic Author
Posts: 1
Joined: Sun Nov 08, 2020 2:05 pm

Slow upload performance with CCR2004-1G-12S+2XS

Sun Nov 08, 2020 2:38 pm

Recently I upgrade to 4Gbps broadband and I used the CCR2004-1G-12S+2XS as router.
Here is the network architecture.
ONT-----CCR2004-----Mellanox 6012------PC(Windows 10, 1Gbps Intel 212 on motherboard and Mellanox MCX454A-FCAT at 40Gbps)、Mac(Hacintosh, Intel 10Gbps)、NAS (Linux, 40Gbps Mellanox CX354A FCCT)

By testing via Speedtest, downloading was around 3000Mbps, but uploading was weird.
It was only 120Mbps on my PC and 600Mbps on my Linux NAS, while it could reach 2800Mbps on Mac.

I also tested the Intel 212 adapter on PC. It reached 900Mbps on uploading without any issue. The file transfer from Windows 10 to NAS was 20Gbps.

I tried to remove the CCR2004 and use the ONT as the gateway(router), the uploading speed on PC and NAS are more than 2000Mbps.

It seems to be something wrong between CCR2004 and mellanox adapters? Please advise.

Here is my export.
# nov/09/2020 01:15:01 by RouterOS 6.47.7
# software id = D4N6-4W3Q
#
# model = CCR2004-1G-12S+2XS
# serial number = D4F00CCB288D
/interface bridge
add name=bridge1 priority=0x1000
/interface ethernet
set [ find default-name=sfp-sfpplus1 ] advertise=10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full,10000M-full auto-negotiation=no rx-flow-control=on speed=10Gbps tx-flow-control=on
set [ find default-name=sfp-sfpplus2 ] advertise=10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full,10000M-full auto-negotiation=no rx-flow-control=on speed=10Gbps tx-flow-control=on
/interface vlan
add interface=sfp-sfpplus1 name=vlan10 vlan-id=10
/interface list
add name=WAN
add name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp ranges=192.168.1.100-192.168.1.200
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge1 name=dhcp1
/user group
set full policy=local,telnet,ssh,ftp,reboot,read,write,policy,test,winbox,password,web,sniff,sensitive,api,romon,dude,tikapp
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=sfp-sfpplus2
add bridge=bridge1 interface=sfp-sfpplus3
add bridge=bridge1 interface=sfp-sfpplus4
add bridge=bridge1 interface=sfp-sfpplus5
add bridge=bridge1 interface=sfp-sfpplus6
add bridge=bridge1 interface=sfp-sfpplus7
add bridge=bridge1 interface=sfp-sfpplus8
add bridge=bridge1 interface=sfp-sfpplus9
add bridge=bridge1 interface=sfp-sfpplus10
add bridge=bridge1 interface=sfp-sfpplus11
add bridge=bridge1 interface=sfp-sfpplus12
/ip neighbor discovery-settings
set discover-interface-list=!dynamic
/interface list member
add interface=bridge1 list=LAN
add interface=vlan10 list=WAN
/ip address
add address=192.168.1.1/24 interface=ether1 network=192.168.1.0
/ip dhcp-client
add disabled=no interface=vlan10
/ip dhcp-server lease
add address=192.168.1.7 client-id=ff:b9:12:28:f3:0:2:0:0:ab:11:5c:77:65:cc:4b:84:1a:10 mac-address=00:02:C9:ED:4C:72 server=dhcp1
add address=192.168.1.6 mac-address=00:02:C9:ED:4C:71 server=dhcp1
add address=192.168.1.5 client-id=ff:5d:e2:6c:15:0:2:0:0:ab:11:6e:64:62:27:9e:5e:14:73 mac-address=4C:CC:6A:44:DF:79 server=dhcp1
add address=192.168.1.8 mac-address=30:9C:23:A5:02:5E server=dhcp1
/ip dhcp-server network
add address=192.168.1.0/24 gateway=192.168.1.1 netmask=24
/ip dns
set allow-remote-requests=yes
/ip firewall nat
add action=masquerade chain=srcnat out-interface-list=WAN
/ip firewall service-port
set ftp disabled=yes
set tftp disabled=yes
set irc disabled=yes
/ip service
set telnet disabled=yes
set ftp disabled=yes
/ip upnp
set enabled=yes
/ip upnp interfaces
add interface=vlan10 type=external
add interface=bridge1 type=internal
/system clock
set time-zone-name=Pacific/Auckland
/system identity
set name=MikroTik2004

Who is online

Users browsing this forum: aesmith, Baidu [Spider], rolands022, yreks and 56 guests