Community discussions

MikroTik App
 
dbrgn
just joined
Topic Author
Posts: 1
Joined: Sat Nov 14, 2020 8:05 pm

IPv6 address not persistent

Sat Nov 14, 2020 8:10 pm

My internet provider provides IPv6 via prefix delegation (DHCPv6). I'm getting a /60 network.

I successfully set up an address pool (prefix size /64). From that address pool, I want to create two /64 networks.

First, I created a network for all devices that use SLAAC:

/ipv6 address add address=::1 from-pool=isp-v6-pool interface=bridge advertise=yes comment="Main IPv6 net"

Then I added a network for devices that will be configured using a static IPv6:

/ipv6 address add address=::1 from-pool=isp-v6-pool interface=bridge advertise=no comment="Server IPv6 net"

This works, both /64 networks are created. However, when I reboot the router, only the first address is still around, the second is gone. On the device with the static IP, routing stops working when rebooting the router.

The only difference is that the second net uses advertise=no. Is that the reason? Or could it be a bug? (Note that I'm still quite an IPv6 beginner, so this might be some kind of conceptual misunderstanding on my side.)

RouterOS version is v6.47.2.

Who is online

Users browsing this forum: Google [Bot] and 69 guests