Community discussions

MikroTik App
 
Marogo
just joined
Topic Author
Posts: 1
Joined: Thu Nov 19, 2020 12:16 pm

Minecraft server

Thu Nov 19, 2020 6:57 pm

Ok I setup my server and port forward I did it with the browser app so no idea of code
My port is 25566(changed it bc second server)(first used with vpn(slow))
chain = dstnat
protocol = tcp
dst.port = 25566
in.interface = ether1
action = dstnat
to addresses = 192.168.88.241(my local ip)
to ports = 25566

when I check the server in https://mcsrvstat.us/ it says it works , but it won't work when I try to connect from Minecraft
 
User avatar
anav
Forum Guru
Forum Guru
Posts: 5705
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada
Contact:

Re: Minecraft server

Sat Nov 21, 2020 2:49 pm

/export hide-sensitive file=anynameyouwish
I'd rather manage rats than software. Follow my advice at your own risk! (Sob & mkx forced me to write that!)
MTUNA Certified, by the Ascerbic Llama!
 
mkx
Forum Guru
Forum Guru
Posts: 5015
Joined: Thu Mar 03, 2016 10:23 pm

Re: Minecraft server

Sat Nov 21, 2020 3:11 pm

... but it won't work when I try to connect from Minecraft
If you're trying to use <wanIP>:25566 from within your own LAN, then you have to implement hairpin NAT. And that's true for just any port.
BR,
Metod
 
trx314
just joined
Posts: 10
Joined: Mon Oct 26, 2020 8:36 pm

Re: Minecraft server

Sat Nov 21, 2020 9:09 pm

Marogo,
you would need a UDP as well for the same port. As mkx stated you can do hairpin NAT, or a quick split DNS:
/ip dns static
add address=192.168.88.241 name=servername
add address=192.168.88.241 name=servername.yourdoamin.com
where servername.yourdoamin.com is the public address for your minecraft server. ( Yes you need domain name, it would not work with IP )
Also make sure your internal port is same as external ( which I see it is), otherwise the split DNS will not work.
 
User avatar
anav
Forum Guru
Forum Guru
Posts: 5705
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada
Contact:

Re: Minecraft server

Sun Nov 22, 2020 1:35 am

You can avoid hairpin nat issues by putting the minecraft server on a different subnet or vlan from your LAN users.
Then standard rules will work.
I'd rather manage rats than software. Follow my advice at your own risk! (Sob & mkx forced me to write that!)
MTUNA Certified, by the Ascerbic Llama!

Who is online

Users browsing this forum: aesmith, Google [Bot] and 37 guests