Community discussions

MikroTik App
 
vasilevdim
newbie
Topic Author
Posts: 47
Joined: Fri Oct 16, 2020 7:50 pm

Modbus and MikroTik

Sun Nov 22, 2020 3:56 pm

Hi,

I have mAP Lite connected to Ethernet device on ether1 and to PC on wlan1. The communication PC- Ethernet device is possible only by using Modbus protocol (driver) of OPC server, installed on the same PC.
I have faced two issues:
1. Every 12 seconds approximately the connection is interrupted, and then in a second, is restored.
2. Only system parameters are read by the OPC server (for example, Hostname, Port, IP address, etc.), but not holding registers.
Any ideas how these problems can be solved?
 
vasilevdim
newbie
Topic Author
Posts: 47
Joined: Fri Oct 16, 2020 7:50 pm

Re: Modbus and MikroTik

Mon Nov 23, 2020 7:17 pm

It is specific issue, indeed, but ...anyone?
 
robertkjonesjr
Frequent Visitor
Frequent Visitor
Posts: 51
Joined: Tue Jul 03, 2012 1:39 am

Re: Modbus and MikroTik

Tue Nov 24, 2020 1:36 am

No reason to think your OPC server or even your plc could be the problem based on the description.
 
mkx
Forum Guru
Forum Guru
Posts: 5056
Joined: Thu Mar 03, 2016 10:23 pm

Re: Modbus and MikroTik

Tue Nov 24, 2020 9:17 am

First verify logs on mAP lite ... could be that wireless disconnects PC due to some reason (there are many possible reasons, log might give a clue).
BR,
Metod
 
vasilevdim
newbie
Topic Author
Posts: 47
Joined: Fri Oct 16, 2020 7:50 pm

Re: Modbus and MikroTik

Tue Nov 24, 2020 7:54 pm

Problem solved. No connection interruptions, all data read properly by OPC server now. I changed the port number in the server configuration to 502. The funny thing is I have more than year running project where all connections are ethernet, no WIFI, and I use different port - 20256 with no issues. At the same time port 502 was not working there. Obviously MikroTik wanted port 502...

Who is online

Users browsing this forum: Baidu [Spider] and 56 guests