Community discussions

MikroTik App
just joined
Topic Author
Posts: 2
Joined: Mon Dec 21, 2020 4:36 pm

L2TP vpn on mikrotik

Mon Dec 21, 2020 4:47 pm

Hello. I live in a country with very restricted internet.
I have tried running l2tp in mikrotik device running routerOS 6.47.8
At the top of the interface it says it is connected (attached picture). Using whatsmyip and others it shows that my ip has changed to the connected vpn server. But i cant access blocked websites and get a connection timed out error.
I have run these commands to route the traffic through vpn interface:

/ip firewall nat
/add action=masquerade out-interface=l2tp-out1 chain=srcnat

/ip firewall mangle
/add chain=prerouting action=mark-routing new-routing-mark=l2tp passthrough=no \

/ip route
/add dst-address= gateway=l2tp-out1 routing-mark=l2tp

My router is connected to a 4g modem directly.
Does it have to do with DNS settings? I tried setting it to google dns from ip>DNS servers but it didn't help.
You do not have the required permissions to view the files attached to this post.
just joined
Topic Author
Posts: 2
Joined: Mon Dec 21, 2020 4:36 pm

Re: L2TP vpn on mikrotik

Tue Dec 22, 2020 11:36 am

When i set the DNS settings on my pc ( or google) then I can load blocked websites. But setting it in the router, while does show up in ipconfig, does not work.
My Ipconfig when DNS set in router:
DNS Servers . . . . . . . . . . . :
When loading websites that are not blocked I can see the traffic going through the l2tp interface. But blocked websites won't load. Somehow although the DNS setting from the router does show up in ipconfig, but it has no effect.
just joined
Posts: 1
Joined: Fri Dec 25, 2020 10:43 pm

Re: L2TP vpn on mikrotik

Fri Dec 25, 2020 10:45 pm

Maybe you have to restart it for DNS change to apply or flush DNS on your PC after changing it on the router?

Who is online

Users browsing this forum: No registered users and 49 guests