Community discussions

MikroTik App
just joined
Topic Author
Posts: 2
Joined: Thu Dec 31, 2020 7:39 pm

noob needs help

Thu Dec 31, 2020 8:03 pm

I have purchased a CRS309-1G-8S+IN for my home lab for nas/server access and testing 10 gig connections with my companies networking equipment.

For the life of me i have not been able to get this thing to work properly. I have tried router os and switch os. I am not afraid of the terminal. It gets hard to use that when the switch decides to go offline and quit communicating so i am mostly stuck using the winbox app with wine on linux as it is easier to put this laptop on the same vlan as the switch ether1 port. I have been at this for over a week so i have tried googling all of the things. I have read through multiple articles/configs/examples. So before you post a simple link remember i probably tried it and failed. I am not normally one to ask for help but i just need a push in the right direction i think. I have LACP working between multiple other switches so it should be good. The lacp link on this switch does come up and appear to work but i don't know how to configure this thing for my project.

What i am trying to accomplish is:

1. set ether1 to isolated/non-forwarding management port only (dhcp preffered but happy to use static)
2. set sfp1-2 as lacp uplink (with passing vlan traffic, lacp trunk port i guess)
3. set sfp 7-8 as trunk ports for hyper-v (esxi 6.5 with web interface only, cant do actuall link agg without some other app. has a vswitch to handle assigning vm's to different vlans based on what i am trying to test)
4. set sfp 6 as accessport (maybe trunk in the future if this nas is to do any vlan shenanigans) (NAS server)

When i try to put the management port on one bridge and all sfp on another bridge the switch goes into router only mode. only way to fix it is a reboot with reset buton being held. i can reproduce this by simply deleting all of the sfp ports from the initial bridge. When in this stage the switch refuses to go back to bridge mode or even acquire an address. This thing network loops really easy despite rstp or any other spanning settings. When trying to set port isolation in the terminal it just doesn't do anything. I am not sure if i have to set port isolation for all other ports maybe so i can isolate this one port?

Isolating a port is stupid easy
Everything works except for trunking the hyper-v ports
NAS server takes a long time to get a dhcp address over sfp, it is a nightmare to get hyper-v vm's to get dhcp addresses sometimes
For some reason the sfp ports go into port paused for like no reason and it gets buggy

Any help is greatly appreciated.
just joined
Topic Author
Posts: 2
Joined: Thu Dec 31, 2020 7:39 pm

Re: noob needs help  [SOLVED]

Fri Jan 01, 2021 3:47 am

I knew once i took the time to register and post it would work but we will see for how long.

Using a bridge to isolate the mgmt port you need to also move hardware offloading as it is only available to one bridge (or i guess make a new bridge for management and move eth1 to that one?). So that probably makes sense with the lag issues. things are getting ip addresses even across vlans.... with no vlan config done... so im going to leave that alone.

Also to note disabling all sfp ports when moving config around seemed to help a lot and setting mac addresses of the bridges manually. made it so if i took down sfp1 to make a bond interface, the config would break and not leave router mode. So i was able to use 7/8 for lcap now without the config going haywire. running openspeedtest on freenas i can hit over a gb with vm's on the hypervisor. so awesome. and i can run multiple speed tests across devices on gig without loss of throughput to the nas.

Who is online

Users browsing this forum: Baidu [Spider], CZFan, tdw and 72 guests