Community discussions

MikroTik App
 
Relubine
just joined
Topic Author
Posts: 1
Joined: Sat Jan 02, 2021 2:36 pm

MikroTik HAP AC Lite - Connect to home router AP

Sat Jan 02, 2021 3:09 pm

Hello,

First things first - Happy New Year to everybody!

Secondly, I am by no means a "network guy" and I apologize in advance if I am not clear of what I am trying to do or if I am using wrong terms.

I have:
* Mikrotik HAP AC Lite (RB952Ui-5AC2ND)
* My ISP router/AP at home (Sagemcom F@ST 3890V3 WU)

What I want to do:
* Keep the Sagemcom as the main router/AP of the house.
* Connect Mikrotik to Sagemcom's 5GHz AP
* Make all Mikrotik Ethernet ports and the 2.4GHz radio as a path to the Sagemcom network.

Use case:
* My laptop is connected to Sagemcom WiFi
* Some of my appliances are connected to Mikrotik (Raspberry, IO module, whatever...)
* While connected to Sagemcom, I can then interact with those devices, such as connect to their HTTP server over browser or SSH.

So far, I have managed to set up a separate network on Mikrotik wlan1 and Ethernet ports so that if you are connected to the bridge (wlan1+all Ethernets), then you have Internet access through the wlan2 (5GHz). But this only worked while I connect my laptop via cable to Mikrotik or access the wlan1. From here I had no access to devices on Sagemcom already and neither was I able to connect to devices on Mikrotik while being on Sagemcoms network. The threads I have used so far are:
* viewtopic.php?t=121127
* viewtopic.php?t=124067
* viewtopic.php?f=13&t=163602&p=834039&hi ... ge#p834039
* http://maict-consult.com/mikrotik-labs/

I think my problem lies somehow with DHCP but I am not sure and would like some assistance/guidance on how to address this problem. Any links are appreciated.

Here is my current configuration - restored with no settings, scrapped away DHCP servers and anything else. How do I go forward from this configuration?

/interface bridge
add name=bridge
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa2-psk eap-methods="" mode=dynamic-keys name=\
    HomeWiFi supplicant-identity="" wpa2-pre-shared-key=__REMOVED__
/interface wireless
set [ find default-name=wlan2 ] band=5ghz-a/n/ac disabled=no frequency=auto \
    name=HomeWiFi security-profile=HomeWiFi ssid=__REMOVED__
set [ find default-name=wlan1 ] band=2ghz-b/g/n disabled=no frequency=auto \
    mode=ap-bridge name=MikroTik security-profile=HomeWiFi ssid=MikroTik
/interface bridge port
add bridge=bridge interface=ether1
add bridge=bridge interface=ether2
add bridge=bridge interface=ether3
add bridge=bridge interface=ether4
add bridge=bridge interface=ether5
add bridge=bridge interface=MikroTik
/ip dhcp-client
add disabled=no interface=HomeWiFi
/ip firewall nat
add action=masquerade chain=srcnat out-interface=HomeWiFi
/system clock
set time-zone-name=Europe/Copenhagen

Thank you!

Who is online

Users browsing this forum: H3ronimous, noam and 106 guests