Community discussions

MikroTik App
 
km4lin
just joined
Topic Author
Posts: 1
Joined: Mon Jan 04, 2021 2:55 pm

hAP ac2 slow speed between wlan and ethernet

Mon Jan 04, 2021 3:11 pm

Hello
I've just bought Mikrotik hAP ac2 and installed Router OS 7.1beta3 (i need wireguard)
Everything is working great but I have a problem with the transfer speed between wlan <-> ethernet device (nas with SMB)
If I copy a file from ether2 to ether3 port I have around 60 MB/s
But from ether2 to wlan2 device (5GHz, link speed is 520Mb/s) I have around 26 MB/s
I spotted that wlan1 and wlan2 port in bridge have no Hw. Offload - it is a problem here? Or it is something else?
I would be grateful for any help
Regards
 
StuartUSA
just joined
Posts: 4
Joined: Tue Nov 13, 2012 4:28 pm

Re: hAP ac2 slow speed between wlan and ethernet

Tue Jan 05, 2021 11:53 pm

Sorry I've no answer to your issue, but I have a similar problem using the same hAP ac2 when I have wireguard running. I am only testing using the wired interface and it works fine without using wireguard, but if I stream, in my case over wireguard, I see a slowdown to where it is unusable.

I have validated the same configuration and far end server using an RB2011 and an RB493 without issue, it seems to be a problem withe the firmware and the hAP.
 
mkx
Forum Guru
Forum Guru
Posts: 5266
Joined: Thu Mar 03, 2016 10:23 pm

Re: hAP ac2 slow speed between wlan and ethernet

Wed Jan 06, 2021 12:29 am

But from ether2 to wlan2 device (5GHz, link speed is 520Mb/s) I have around 26 MB/s
26MB/s is around 200Mbps net throughput. Which is not too bad for 520Mbps link rate: wifi has pretty high overhead (duplex overhead as well) and getting around half of theoretical throughput is a decent achievement.
The other thing is that wireless is quite hard on CPU (particularly Tx) ... you may want to observe CPU load while file transfer - run CPU profiler to see how much CPU is used and which process is consuming it. But I guess this shouldn't be a problem on hAP ac2.
BR,
Metod
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 1250
Joined: Mon Apr 08, 2019 1:16 am

Re: hAP ac2 slow speed between wlan and ethernet

Wed Jan 06, 2021 1:12 am

Well OP might need to do a wifi RF check, and do a better channel selection or even physical placement.(Freq usage & Snooper tool)

520Mbps does not indicate a clean connection. A lot of distortion and interference is suspected to make the PHY step down 4 times from MCS9 till MCS5. MCS step down occurs when all HW retransmits (standard =7 times) repeatedly fail. So I expect quite low CCQ. (% of successful transmissions), that also reduces with the same % the useable throughput of MCS5 (520Mbps). Overhead is between 25% and 60% depending on many variables. There might be others on the used channels as well, with whom one has to share the airtime.

208 Mbps as @MKX says, is no surprise at all, with a 520Mbps half-duplex PHY speed.


Klembord-1.jpg
You do not have the required permissions to view the files attached to this post.

Who is online

Users browsing this forum: No registered users and 79 guests