Community discussions

MikroTik App
 
Bassman100
just joined
Topic Author
Posts: 1
Joined: Sun Oct 04, 2020 11:38 am

RBwAPG-5HacT2HnD Configuration

Thu Jan 07, 2021 5:26 am

Hi there, I'm a complete novice re configuring this type of device so am looking for help to get the best use out of this thing.
Long story:

I was looking for a device that would extend WIFI from house to remote studio - about 20mtrs from existing router (TP-Link VR2800 modem/router). I can get fairly decent wifi in the studio via an ASUS PCI-E pc card, but I have to keep the PC/antenna next to the window in the studio. I came across this Mikrotik unit, explained to the Mikrotik sales people that I wanted to connect via the ethernet cable to the PC (then could move the PC), access internet and most importantly access the LAN in the house. No worries I was told - easy. So I purchased it. For a month I read up on configuring it to no avail - sent it back - faulty RS OS, they fixed it and sent it back.

Their tech department eventually gave me some help in configuration and yes, their config worked - but only to the internet - could not access LAN. This because they said that it couldn't use the existing lan range of the VR2800 (192.168.1.XX) so gave it an IP of 192.168.2.XX.

Anyhow, I gave it a go and managed to work out a config that works, but not as stable as theirs - sometimes have to reboot VR2800.

What I'm after is a config like theirs but able to connect with existing lan. Both configs are attached - p2plink is theirs and configAPWapAC is mine.
p2plink
# nov/02/2020 14:03:35 by RouterOS 6.47.4
# software id = DZDI-BCB1
#
# model = RBwAPG-5HacT2HnD
# serial number = D8F70C229447
/interface bridge
add admin-mac=48:8F:5A:33:F3:1F auto-mac=no name=bridge1
/interface wireless
set [ find default-name=wlan1 ] ssid=MikroTik
set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=\
20/40/80mhz-Ceee comment="Backhaul link" disabled=no ssid=shiloh50
/interface wireless manual-tx-power-table
set wlan2 comment="Backhaul link"
/interface wireless nstreme
set wlan2 comment="Backhaul link"
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" mode=\
dynamic-keys supplicant-identity=MikroTik wpa2-pre-shared-key=XXXXXXXXX
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/ip pool
add name=dhcp_pool0 ranges=192.168.2.2-192.168.2.254
/ip dhcp-server
add address-pool=dhcp_pool0 disabled=no interface=bridge1 name=dhcp1
/interface bridge port
add bridge=bridge1 interface=ether1
/ip address
add address=192.168.2.1/24 interface=bridge1 network=192.168.2.0
/ip dhcp-client
add disabled=no interface=wlan2
/ip dhcp-server network
add address=192.168.2.0/24 gateway=192.168.2.1
/ip dns
set servers=1.1.1.1,8.8.8.8
/ip firewall nat
add action=masquerade chain=srcnat out-interface=wlan2
/system clock
set time-zone-name=Australia/Sydney

And mine:
# jan/02/1970 00:39:41 by RouterOS 6.47.7
# software id = DZDI-BCB1
#
# model = RBwAPG-5HacT2HnD
# serial number = D8F70C229447
/interface bridge
add name=bridge1
/interface wireless
set [ find default-name=wlan1 ] ssid=MikroTik
/interface list
add name=WAN
add name=LAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" \
group-ciphers=tkip,aes-ccm mode=dynamic-keys supplicant-identity=MikroTik \
unicast-ciphers=tkip,aes-ccm wpa-pre-shared-key=XXXXXXXXX \
wpa2-pre-shared-key=15hanna49
add authentication-types=wpa2-psk mode=dynamic-keys name=\
wlan2-shiloh50-repeater supplicant-identity=MikroTik wpa2-pre-shared-key=\
XXXXXXXXX
/interface wireless
set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=\
20/40/80mhz-Ceee country=australia disabled=no mode=station-pseudobridge \
security-profile=wlan2-shiloh50-repeater ssid=shiloh50
add disabled=no mac-address=4A:8F:5A:33:F3:20 master-interface=wlan2 name=\
wlan3 security-profile=wlan2-shiloh50-repeater ssid=shiloh50mk
/interface bridge nat
add action=accept chain=srcnat
/interface bridge port
add bridge=bridge1 interface=wlan2
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=wlan1
add bridge=bridge1 interface=wlan3
/interface list member
add interface=wlan2 list=WAN
add interface=ether1 list=LAN
add interface=wlan1 list=LAN
/ip dhcp-client
add disabled=no interface=bridge1
Thanks in advance for any help, ideas etc. Cheers - Paul

Who is online

Users browsing this forum: mpuria, Sob and 61 guests