Community discussions

MikroTik App
 
chribonn
newbie
Topic Author
Posts: 38
Joined: Tue Mar 13, 2018 9:41 am
Location: Malta
Contact:

Can I share the same DHCP server with two sources

Sat Jan 09, 2021 10:48 pm

Hello,

It is possible (and functional) to have a single Mikrotik DHCP server issuing addresses to clients coming in from the network as well as as an OpenVPN server? Have others who have tried this experienced any negative side-effects.

My current configuration reads as follows:
/ip pool
add name=SOHO_POOL ranges=192.168.16.20-192.168.16.99
add name=GUEST_POOL ranges=10.0.20.2-10.0.20.254
add comment="IP Range Assigned to VPN Clients" name=VPN_POOL ranges=\
    192.168.89.10-192.168.89.20
/ip dhcp-server
add address-pool=SOHO_POOL disabled=no interface=SOHO_VLAN name=SOHO_DHCP
add address-pool=GUEST_POOL disabled=no interface=GUEST_VLAN name=GUEST_DHCP
/ppp profile
set *0 use-upnp=no
add local-address=192.168.89.1 name=VPN_PROFILE remote-address=VPN_POOL
set *FFFFFFFE use-upnp=no
/ip address
add address=192.168.0.1/24 interface=BASE_VLAN network=192.168.0.0
add address=192.168.16.1/24 interface=SOHO_VLAN network=192.168.16.0
add address=10.0.20.1/24 interface=GUEST_VLAN network=10.0.20.0
add address=192.168.89.1/24 comment="OpenVPN Network" interface=SOHO_VLAN \
    network=192.168.89.0
/ip dhcp-server network
add address=10.0.20.0/24 comment="Guest Subnet" dns-server=192.168.0.1 \
    gateway=10.0.20.1
add address=192.168.16.0/24 comment="SOHO Subnet" dns-server=192.168.0.1 \
    gateway=192.168.16.1
add address=192.168.89.0/24 comment="VPN Subnet" dns-server=192.168.0.1 \
    gateway=192.168.89.1
What I would like to do is shown below:
/ip pool
add name=SOHO_POOL ranges=192.168.16.20-192.168.16.99
add name=GUEST_POOL ranges=10.0.20.2-10.0.20.254

[i]# commented line
# add comment="IP Range Assigned to VPN Clients" name=VPN_POOL ranges=\
#   192.168.89.10-192.168.89.20[/i]

/ip dhcp-server
add address-pool=SOHO_POOL disabled=no interface=SOHO_VLAN name=SOHO_DHCP
add address-pool=GUEST_POOL disabled=no interface=GUEST_VLAN name=GUEST_DHCP
/ppp profile
set *0 use-upnp=no

[b]# This is a proposed change. local-address is outside the DHCP range, the pool is from the shared SOHO_POOL
add local-address=192.168.16.254 name=VPN_PROFILE remote-address=SOHO_POOL[/b]

set *FFFFFFFE use-upnp=no
/ip address
add address=192.168.0.1/24 interface=BASE_VLAN network=192.168.0.0
add address=192.168.16.1/24 interface=SOHO_VLAN network=192.168.16.0
add address=10.0.20.1/24 interface=GUEST_VLAN network=10.0.20.0

[i]# commented out
# add address=192.168.89.1/24 comment="OpenVPN Network" interface=SOHO_VLAN \
#    network=192.168.89.0[/i]

/ip dhcp-server network
add address=10.0.20.0/24 comment="Guest Subnet" dns-server=192.168.0.1 \
    gateway=10.0.20.1
add address=192.168.16.0/24 comment="SOHO Subnet" dns-server=192.168.0.1 \
    gateway=192.168.16.1

[i]# commented out
# add address=192.168.89.0/24 comment="VPN Subnet" dns-server=192.168.0.1 \
#    gateway=192.168.89.1[/i]

Thank you as always.

Who is online

Users browsing this forum: Bing [Bot] and 54 guests