Community discussions

MikroTik App
 
mkrz
just joined
Topic Author
Posts: 9
Joined: Fri Jan 17, 2020 10:53 am

RB760IGS ignores VLAN settings

Sun Jan 10, 2021 4:32 pm

Hello, for some reason my router refuses to send packets to VLAN interfaces even though vlan filtering is on, PVIDs are set correctly, I can see Bridge/VLANs winbox menu reporting VLANs as being correctly tagged/untagged etc. But in interfaces menu I see traffic present only on a given ethernet interface and a bridge, but 0 bps on both VLANs

Configuration included below, it's pretty basic (just tag some ports with 1 and accept tagged with 1000). What exactly am I missing?
# jan/10/2021 16:03:29 by RouterOS 6.48
# software id = 9TK9-UEIM
#
# model = RB760iGS
# serial number = SECRET
/interface bridge
add admin-mac=48:8F:5A:B5:5C:77 auto-mac=no comment=defconf name=bridge \
    protocol-mode=none vlan-filtering=yes
/interface vlan
add interface=bridge name=vlan1 vlan-id=1
add interface=bridge name=vlan1000 vlan-id=1000
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=greyPool ranges=10.10.100.21-10.10.100.254
add name=mainPool ranges=192.168.100.100-192.168.100.200
/ip dhcp-server
add address-pool=greyPool disabled=no interface=vlan1000 name=greyDHCP
add address-pool=mainPool disabled=no interface=bridge name=mainDHCP
/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf ingress-filtering=yes interface=ether3
add bridge=bridge comment=GPON1 interface=ether4 pvid=1000
add bridge=bridge comment=GPON2 interface=ether5 pvid=1000
add bridge=bridge interface=ether1
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface bridge vlan
add bridge=bridge tagged=ether4,ether5 vlan-ids=1000
add bridge=bridge vlan-ids=1
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=sfp1 list=WAN
/ip address
add address=X.X.X.X/X interface=sfp1 network=X.X.X.X
add address=10.10.100.1/24 interface=vlan1000 network=10.10.100.0
add address=192.168.100.1/24 interface=bridge network=192.168.100.0
/ip dhcp-client
# DHCP client can not run on slave interface!
add comment=defconf disabled=no interface=ether1
/ip dhcp-server network
add address=10.10.100.0/24 comment="Grey Network" dns-server=8.8.8.8,1.1.1.1 \
    gateway=10.10.100.1 netmask=24
add address=192.168.100.0/24 comment="Main Network" dns-server=\
    8.8.8.8,1.1.1.1 gateway=192.168.100.1 netmask=24
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,1.1.1.1
/ip dns static
add address=192.168.88.1 comment=defconf name=router.lan
/ip firewall filter
add action=accept chain=input comment=\
    "defconf: accept established,related,untracked" connection-state=\
    established,related,untracked
add action=accept chain=input dst-port=8291 protocol=tcp
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
    invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
    "defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
    in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
    ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
    ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
    connection-state=established,related
add action=accept chain=forward comment=\
    "defconf: accept established,related, untracked" connection-state=\
    established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
    connection-state=invalid
add action=drop chain=forward comment=\
    "defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
    connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
    ipsec-policy=out,none out-interface-list=WAN
/ip route
add distance=1 gateway=X.X.X.X
/ip service
set www disabled=yes
set www-ssl disabled=no
/system clock
set time-zone-name=Europe/Kiev
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
 
Sob
Forum Guru
Forum Guru
Posts: 6484
Joined: Mon Apr 20, 2009 9:11 pm

Re: RB760IGS ignores VLAN settings

Sun Jan 10, 2021 5:55 pm

When you have vlan interface on bridge, then in "/interface bridge vlan" it must be tagged also on bridge interface, e.g.:
/interface bridge vlan
add bridge=bridge tagged=bridge,ether4,ether5 vlan-ids=1000
Excessive quoting is useless and annoying. If you use it, please consider if you could do without it.

Who is online

Users browsing this forum: nhayuga, xeon3d and 63 guests