Community discussions

MikroTik App
 
spiceygas
just joined
Topic Author
Posts: 6
Joined: Thu Feb 04, 2021 3:46 am

Can't switch to SwOS

Thu Feb 04, 2021 3:53 am

Brand new MikroTik CRS312-4C+8XG-RM
RouterOS v6.45.9

I plan to use this as just a switch, not a router. Therefore looking to change to SwOS.

The menu setting that is supposed to switch the boot OS is missing. System ==> RouterBOARD ==> Settings. I've looked up screnshots on google, and there is literally a missing setting prompt on my screen.

Image

I've tried in both the browser-based setup and the WinBox application. Both are missing it. What gives?

I also tried this command, rebooted, and it came back up in RouterOS.
/system routerboard settings set boot-os=swos
viewtopic.php?t=129043
 
User avatar
k6ccc
Long time Member
Long time Member
Posts: 640
Joined: Fri May 13, 2016 12:01 am
Location: Glendora, CA, USA (near Los Angeles)

Re: Can't switch to SwOS

Thu Feb 04, 2021 8:38 pm

That's a fairly old version of RouterOS. Just a stab in the dark. Update to a current version of RouterOS and see if the command to switch to SwitchOS is there.
RB750Gr3, RB750r2, CRS326-24G-2S (in SwitchOS), CSS326-24G-2S, CSS106-5G-1S, RB260GS
Not sure if I beat them in submission, or they beat me into submission

Warning: I know enough to be dangerous...

Jim
 
spiceygas
just joined
Topic Author
Posts: 6
Joined: Thu Feb 04, 2021 3:46 am

Re: Can't switch to SwOS

Sat Feb 06, 2021 3:53 pm

I upgraded the RouterOS version. It gave me the SwOS boot option, and now it's stuck in a bootloop.

This got picked up in a different thread: viewtopic.php?f=13&t=171538&p=842537#p842537

Who is online

Users browsing this forum: No registered users and 76 guests