Community discussions

MikroTik App
User avatar
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 78
Joined: Sun Mar 10, 2019 4:27 am
Location: The Internet

Enable DHCP passthrough to upper router (DHCP server)

Sat Feb 06, 2021 2:17 am

I have a scenario similar to the Mikrotik dhcp relay wiki page:
A main router of another brand that makes the connection to ISP, this is also main DHCP server (
To it, I connected a Mikrotik HAP ac2 (

Now, I want a computer that is plugged to Mikrotik eth2 port, to use a static IP from upper router , e.g computer use IP
On the computer I manually set gateway to and ip, but ...

- I understand the Mikrotik needs to be setup as a DHCP relay ?
- I thought it might work directly since on the computer I manually specify upper gateway and static ip
- That computer is only accessible once I add the eth1 to the bridge (like in image), is this correct / needed ?
- Why doesn't that bridge already contain the eth1 by default, but it contains all the other ports ?

This seems to be exact same situation and solution: as this topic says.
Problem solved everything works.
I added ether1 (WAN) to the bridge used for DHCP-relay.
You do not have the required permissions to view the files attached to this post.
// looks like I am not smashing my router after all :) Thanks to Sob, anav, mkx, etc
Forum Veteran
Forum Veteran
Posts: 712
Joined: Sat May 05, 2018 11:55 am

Re: Enable DHCP passthrough to upper router (DHCP server)

Sat Feb 06, 2021 2:57 am

That won't work, the wiki example is using DHCP relay to pass requests for and subnets to a DHCP server running in the subnet.

If you wish to extend the network from the other router the hAP should have all ports in one bridge, no DHCP server or DHCP relay. The hAP itself can be assigned a static address or use the DHCP client to obtain one from the other router. I don't think there is a Quickset option for a bridged AP so it is a case of removing the unnecessary bits from the default configuration.

Who is online

Users browsing this forum: Joe1962, lghikas and 82 guests