Community discussions

MikroTik App
User avatar
just joined
Topic Author
Posts: 1
Joined: Mon Feb 08, 2021 10:38 pm

Unable to add local SMB shares

Tue Feb 09, 2021 12:08 am


I have a strange scenario where after installing a Mikrotik CRS125-24G-1S-2HnD-IN, I've been unable to connect to my SMB shares from my Windows computers. My network looks something like this:
Simplified Network Diagram Smaller.png
Previously I had just used the Rogers CODA Modem as a Router and during this configuration I was able to connect and setup the SMB shares on my Fedora Server without issue on both Windows Systems.

Since installing the MikroTik Cloud Router Switch, my Windows machines have been unsuccessful in finding the SMB shares. The Windows shares on my Windows machine do function, although upon initial setup it took a while for them to be found. I am able to ping the Fedora Server from both of my Windows machines and I'm able to SSH into it (as well as play Minecraft if that helps at all) over LAN. I have confirmed that the Samba Daemon is running on the Fedora Machine:
[jupdown@Fedora-Server ~]$ systemctl status smb.service
● smb.service - Samba SMB Daemon
     Loaded: loaded (/usr/lib/systemd/system/smb.service; enabled; vendor preset: disabled)
     Active: active (running) since Mon 2021-02-08 14:08:18 EST; 2h 17min ago
I also updated my smb.conf file after installing the MikroTik CRS:
        workgroup = WORKGROUP
        server string = Fedora-Server
        server role = standalone server
        hosts allow = 10.0.0. 127.       #This line previously had 192.168.1. in it for the Rogers CODA configuration
I'm at a loss as to where I should be starting with this issue. I figured I'd start here as I believe the issue has to do with the way I've configured my MikroTik CRS125-24G-1S-2HnD-IN (Since SMB worked just fine previously). Do I have to add a firewall permission or something for this to work (Local SSH seemed to work out of the box?) I've tried searching this issue but most of the posts that come up are related to the Router's SMB server (which I have set to Disabled). This is my current configuration:
[admin@CRS125] > /export hide-sensitive
# feb/08/2021 16:48:20 by RouterOS 6.48
# software id = J0IH-TTY3
# model = CRS125-24G-1S-2HnD
/interface bridge
add admin-mac=4C:5E:0C:92:18:45 auto-mac=no comment=defconf name=bridge
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-g/n channel-width=20/40mhz-XX country=canada disabled=no distance=\
    indoors frequency=auto installation=indoor mode=ap-bridge ssid="WifiName" wireless-protocol=802.11
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk mode=dynamic-keys supplicant-identity=MikroTik
/ip pool
add name=dhcp ranges=
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge name=defconf
/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=ether5
add bridge=bridge comment=defconf interface=ether6
add bridge=bridge comment=defconf interface=ether7
add bridge=bridge comment=defconf interface=ether8
add bridge=bridge comment=defconf interface=ether9
add bridge=bridge comment=defconf interface=ether10
add bridge=bridge comment=defconf interface=ether11
add bridge=bridge comment=defconf interface=ether12
add bridge=bridge comment=defconf interface=ether13
add bridge=bridge comment=defconf interface=ether14
add bridge=bridge comment=defconf interface=ether15
add bridge=bridge comment=defconf interface=ether16
add bridge=bridge comment=defconf interface=ether17
add bridge=bridge comment=defconf interface=ether18
add bridge=bridge comment=defconf interface=ether19
add bridge=bridge comment=defconf interface=ether20
add bridge=bridge comment=defconf interface=ether21
add bridge=bridge comment=defconf interface=ether22
add bridge=bridge comment=defconf interface=ether23
add bridge=bridge comment=defconf interface=ether24
add bridge=bridge comment=defconf interface=sfp1
add bridge=bridge comment=defconf interface=wlan1
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=ether1 list=WAN
/ip address
add address= comment=defconf interface=bridge network=
/ip dhcp-client
add comment=defconf disabled=no interface=ether1
/ip dhcp-server lease
# I've more or less statically allocated all my machines; nothing to see here 
/ip dhcp-server network
add address= comment=defconf gateway= netmask=24
/ip dns
set allow-remote-requests=yes
/ip dns static
add address= comment=defconf name=router.lan
/ip firewall filter
add action=accept chain=input comment="defconf: accept established,related,untracked" connection-state=\
add action=drop chain=input comment="defconf: drop invalid" connection-state=invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment="defconf: accept to local loopback (for CAPsMAN)" dst-address=
add action=drop chain=input comment="defconf: drop all not coming from LAN" in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=established,related
add action=accept chain=forward comment="defconf: accept established,related, untracked" connection-state=\
add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
add action=drop chain=forward comment="defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
    connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" ipsec-policy=out,none out-interface-list=WAN
add action=dst-nat chain=dstnat dst-port=25565 in-interface=ether1 protocol=tcp to-addresses= \
add action=dst-nat chain=dstnat dst-port=25565 in-interface=ether1 protocol=udp to-addresses= \
/ip service
set www-ssl disabled=no
/ip smb
set allow-guests=no domain=WORKGROUP
/system clock
set time-zone-name=America/Toronto
/system identity
set name=CRS125
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
From the few posts that I did find similar to my issue, I found one suggesting setting up an ACL (viewtopic.php?t=167379#p822598), although I have no idea how to do this (or what it is) even after reading the documentation.

I also found another one suggesting that changing the IP address back to 192.168.0.# may resolve the issue (viewtopic.php?t=109015#p541383)... although I'd like to keep this option as a last resort if possible.

I'm not looking to do anything fancy, I just want to be able to access my SMB shares over LAN on the same Subnet. If anyone has an idea as to where I should start on figuring this issue out, please let me know!
You do not have the required permissions to view the files attached to this post.
User avatar
Forum Veteran
Forum Veteran
Posts: 712
Joined: Sun Jun 28, 2015 7:36 pm

Re: Unable to add local SMB shares

Thu Feb 11, 2021 5:53 pm

You have:
/ip smb
set allow-guests=no domain=WORKGROUP
You need:
/ip smb
set enabled=yes allow-guests=no domain=WORKGROUP
So in terminal: ip smb set enabled=yes

If you want to know my network, you can find it here.

Telegram: @krafgrgi


Who is online

Users browsing this forum: Moba and 50 guests