Community discussions

MikroTik App
 
jvzg545cr
just joined
Topic Author
Posts: 9
Joined: Tue Apr 17, 2018 11:02 pm

Queue tree + pcq no working for me

Wed May 12, 2021 4:51 pm

Hello friends, what I will ask here is that it is duplicated in many forums but I cannot find something that can help me and I have configured it in the possible ways.

I have a mikrotik 4011 in production with 200 clients, I manage them by pppoe with plans of 5 and 15mb, configure queue tree + pcq and I notice that the clients pass their contracted limit on occasions and I have not been able to make it not go from there. I leave my export of the configuration.
/ip firewall mangle
add action=mark-connection chain=forward connection-mark=no-mark disabled=yes \
    in-interface-list=LAN new-connection-mark=Plan15mb-conn passthrough=yes \
    src-address-list="HOME 15MB"
add action=mark-packet chain=forward connection-mark=Plan15mb-conn disabled=yes \
    in-interface-list=WAN new-packet-mark=P15mb-down-pacotes passthrough=no
add action=mark-packet chain=forward connection-mark=Plan15mb-conn disabled=yes \
    in-interface-list=LAN new-packet-mark=P15mb-up-pacotes passthrough=no
add action=mark-connection chain=forward connection-mark=no-mark disabled=yes \
    in-interface-list=LAN new-connection-mark=Plan10mb-conn passthrough=yes \
    src-address-list="HOME 10MB"
add action=mark-packet chain=forward connection-mark=Plan10mb-conn disabled=yes \
    in-interface-list=WAN new-packet-mark=P10mb-down-pacotes passthrough=no
add action=mark-packet chain=forward connection-mark=Plan10mb-conn disabled=yes \
    in-interface-list=LAN new-packet-mark=P10mb-up-pacotes passthrough=no
add action=mark-connection chain=forward connection-mark=no-mark disabled=yes \
    in-interface-list=LAN new-connection-mark=Plan5mb-conn passthrough=yes \
    src-address-list="HOME 5MB"
add action=mark-packet chain=forward connection-mark=Plan5mb-conn disabled=yes \
    in-interface-list=WAN new-packet-mark=P5mb-down-pacotes passthrough=no
add action=mark-packet chain=forward connection-mark=Plan5mb-conn disabled=yes \
    in-interface-list=LAN new-packet-mark=P5mb-up-pacotes passthrough=no
add action=mark-connection chain=forward connection-mark=no-mark disabled=yes \
    in-interface-list=LAN new-connection-mark=Plan2mb-conn passthrough=yes \
    src-address-list="HOME 2MB"
add action=mark-packet chain=forward connection-mark=Plan2mb-conn disabled=yes \
    in-interface-list=WAN new-packet-mark=P2mb-down-pacotes passthrough=no
add action=mark-packet chain=forward connection-mark=Plan2mb-conn disabled=yes \
    in-interface-list=LAN new-packet-mark=P2mb-up-pacotes passthrough=no
add action=mark-connection chain=forward connection-mark=no-mark disabled=yes \
    in-interface-list=LAN new-connection-mark=Plan1mb-conn passthrough=yes \
    src-address-list="HOME 1M"
add action=mark-packet chain=forward connection-mark=Plan1mb-conn disabled=yes \
    in-interface-list=WAN new-packet-mark=P1mb-down-pacotes passthrough=no
add action=mark-packet chain=forward connection-mark=Plan1mb-conn disabled=yes \
    in-interface-list=LAN new-packet-mark=P1mb-up-pacotes passthrough=no
add action=mark-connection chain=forward connection-mark=no-mark disabled=yes \
    in-interface-list=LAN new-connection-mark=Plan512k-conn passthrough=yes \
    src-address-list="HOME 512k"
add action=mark-packet chain=forward connection-mark=Plan512k-conn disabled=yes \
    in-interface-list=WAN new-packet-mark=P512k-down-pacotes passthrough=no
add action=mark-packet chain=forward connection-mark=Plan512k-conn disabled=yes \
    in-interface-list=LAN new-packet-mark=P512k-up-pacotes passthrough=no

Another way

add action=mark-packet chain=forward comment=New disabled=yes new-packet-mark=\
    P15mb-up-pacotes passthrough=yes src-address-list="HOME 15MB"
add action=mark-packet chain=forward disabled=yes dst-address-list="HOME 15MB" \
    new-packet-mark=P15mb-down-pacotes passthrough=yes
add action=mark-packet chain=forward disabled=yes new-packet-mark=P10mb-up-pacotes \
    passthrough=yes src-address-list="HOME 10MB"
add action=mark-packet chain=forward disabled=yes dst-address-list="HOME 10MB" \
    new-packet-mark=P10mb-down-pacotes passthrough=yes
add action=mark-packet chain=forward disabled=yes new-packet-mark=P5mb-up-pacotes \
    passthrough=yes src-address-list="HOME 5MB"
add action=mark-packet chain=forward disabled=yes dst-address-list="HOME 5MB" \
    new-packet-mark=P5mb-down-pacotes passthrough=yes
add action=mark-packet chain=forward disabled=yes new-packet-mark=P2mb-up-pacotes \
    passthrough=yes src-address-list="HOME 2MB"
add action=mark-packet chain=forward disabled=yes dst-address-list="HOME 2MB" \
    new-packet-mark=P2mb-down-pacotes passthrough=yes
add action=mark-packet chain=forward disabled=yes new-packet-mark=P1mb-up-pacotes \
    passthrough=yes src-address-list="HOME 1M"
add action=mark-packet chain=forward disabled=yes dst-address-list="HOME 1M" \
    new-packet-mark=P1mb-down-pacotes passthrough=yes
add action=mark-packet chain=forward disabled=yes new-packet-mark=P512k-up-pacotes \
    passthrough=yes src-address-list="HOME 512k"
add action=mark-packet chain=forward disabled=yes dst-address-list="HOME 512k" \
    new-packet-mark=P512k-down-pacotes passthrough=yes

/queue type
add kind=pcq name=PCQ_Plan_512k_down pcq-classifier=dst-address pcq-rate=512k
add kind=pcq name=PCQ_Plan_2M_down pcq-burst-time=50s pcq-classifier=dst-address pcq-rate=2M
add kind=pcq name=PCQ_Plan_1M_down pcq-classifier=dst-address pcq-rate=1M
add kind=pcq name=PCQ_Plan_5M_down pcq-burst-time=50s pcq-classifier=dst-address pcq-rate=5M
add kind=pcq name=PCQ_Plan_6M_down pcq-classifier=dst-address pcq-rate=6M
add kind=pcq name=PCQ_Plan_8M_down pcq-burst-time=1m4s pcq-classifier=dst-address pcq-rate=8M
add kind=pcq name=PCQ_Plan_15M_down pcq-classifier=dst-address pcq-rate=15M
add kind=pcq name=PCQ_Plan_512k_up pcq-classifier=src-address pcq-rate=512k
add kind=pcq name=PCQ_Plan_1M_up pcq-classifier=src-address pcq-rate=1M
add kind=pcq name=PCQ_Plan_5M_up pcq-burst-time=50s pcq-classifier=src-address pcq-rate=5M
add kind=pcq name=PCQ_Plan_6M_up pcq-classifier=src-address pcq-rate=2M
add kind=pcq name=PCQ_Plan_8M_up pcq-classifier=src-address pcq-rate=4M
add kind=pcq name=PCQ_Plan_2M_up pcq-burst-time=50s pcq-classifier=src-address pcq-rate=2M
add kind=pcq name=PCQ_Plan_15M_up pcq-classifier=src-address pcq-rate=15M

/queue tree
add disabled=yes limit-at=215M max-limit=215M name=DW parent="Bridge DHCP"
add disabled=yes limit-at=230M max-limit=230M name=UP parent=ether2-GW
add disabled=yes limit-at=1M max-limit=215M name=H-1MB packet-mark=P1mb-down-pacotes parent=DW queue=PCQ_Plan_1M_down
add disabled=yes limit-at=5M max-limit=215M name=H-5MB packet-mark=P5mb-down-pacotes parent=DW priority=2 queue=PCQ_Plan_5M_down
add disabled=yes limit-at=5M max-limit=215M name=H-10MB packet-mark=P10mb-down-pacotes parent=DW queue=PCQ_Plan_8M_down
add disabled=yes limit-at=183M max-limit=183M name=H-15MB packet-mark=P15mb-down-pacotes parent=DW queue=PCQ_Plan_15M_down
add disabled=yes name=H-1MB-UP packet-mark=P1mb-up-pacotes parent=UP queue=PCQ_Plan_1M_up
add disabled=yes name=H-2MB-UP packet-mark=P2mb-up-pacotes parent=UP queue=PCQ_Plan_2M_up
add disabled=yes name=H-5MB-UP packet-mark=P5mb-up-pacotes parent=UP queue=PCQ_Plan_5M_up
add disabled=yes name=H-10MB-UP packet-mark=P10mb-up-pacotes parent=UP queue=PCQ_Plan_8M_up
add disabled=yes name=H-15MB-UP packet-mark=P15mb-up-pacotes parent=UP queue=PCQ_Plan_15M_up
add disabled=yes limit-at=10M max-limit=215M name=H-2MB packet-mark=P2mb-down-pacotes parent=DW priority=1 queue=PCQ_Plan_2M_down
add disabled=yes limit-at=512k max-limit=215M name=H-512k packet-mark=P512k-down-pacotes parent=DW queue=PCQ_Plan_512k_down

/ppp profile
add address-list="HOME 1M" bridge="Bridge DHCP" interface-list=LAN local-address=10.1.0.1 name="PPPoE_Plan 1M" remote-address="Plan 1MB" use-encryption=yes
add address-list="HOME 2MB" bridge="Bridge DHCP" interface-list=LAN local-address=10.1.0.1 name="PPPoE_Plan 2MB" remote-address="Plan 1.5MB" use-encryption=yes
add address-list="HOME 5MB" bridge="Bridge DHCP" interface-list=LAN local-address=10.1.0.1 name="PPPoE_Plan 5M" remote-address="Plan 5MB"
add address-list="HOME 10MB" bridge="Bridge DHCP" dns-server=1.1.1.1,1.0.0.1 interface-list=LAN local-address=10.1.0.1 name="PPPoE_Plan 10M" remote-address="Plan 10MB" use-encryption=yes
add address-list="HOME 512k" bridge="Bridge DHCP" interface-list=LAN local-address=10.1.0.1 name="PPPoE_Plan 512k" use-encryption=yes
add address-list="HOME 15MB" bridge="Bridge DHCP" dns-server=1.1.1.1,1.0.0.1 interface-list=LAN local-address=10.1.0.1 name=PPPoE_Plan_15MB remote-address="Plan 15MB" use-encryption=yes
add address-list="HOME 8MB" bridge="Bridge DHCP" interface-list=LAN local-address=10.1.0.1 name="PPPoE_PLan 8MB" remote-address="Plan 8MB"
 
lightmanster
just joined
Posts: 14
Joined: Tue Aug 29, 2017 11:04 am

Re: Queue tree + pcq no working for me

Thu May 13, 2021 10:42 am

just to be sure.
Fasttrack should be disabled for those connections. Fasttrack and queuing doesn't work together.

Kind regards
 
jvzg545cr
just joined
Topic Author
Posts: 9
Joined: Tue Apr 17, 2018 11:02 pm

Re: Queue tree + pcq no working for me

Fri May 14, 2021 5:25 pm

just to be sure.
Fasttrack should be disabled for those connections. Fasttrack and queuing doesn't work together.

Kind regards
I have no rules with fasttrack, the truth is I don't know what to do anymore, I don't know if it's server failure.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 11967
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: Queue tree + pcq no working for me

Fri May 14, 2021 5:35 pm

Enable IP firewall on bridge / settings
 
User avatar
CZFan
Forum Guru
Forum Guru
Posts: 2098
Joined: Sun Oct 09, 2016 8:25 pm
Location: South Africa, Krugersdorp (Home town of Brad Binder)
Contact:

Re: Queue tree + pcq no working for me

Fri May 14, 2021 6:34 pm

Hello friends, what I will ask here is that it is duplicated in many forums but I cannot find something that can help me and I have configured it in the possible ways.

I have a mikrotik 4011 in production with 200 clients, I manage them by pppoe with plans of 5 and 15mb, configure queue tree + pcq and I notice that the clients pass their contracted limit on occasions and I have not been able to make it not go from there. I leave my export of the configuration.
...
The marking of conn/pkt is not correct, you are only marking certain packets instead of all the connection packets, remove the "in-interface-list" property from conn & pkt marking rules.
 
jvzg545cr
just joined
Topic Author
Posts: 9
Joined: Tue Apr 17, 2018 11:02 pm

Re: Queue tree + pcq no working for me

Tue May 18, 2021 6:41 pm

Hello friends, what I will ask here is that it is duplicated in many forums but I cannot find something that can help me and I have configured it in the possible ways.

I have a mikrotik 4011 in production with 200 clients, I manage them by pppoe with plans of 5 and 15mb, configure queue tree + pcq and I notice that the clients pass their contracted limit on occasions and I have not been able to make it not go from there. I leave my export of the configuration.
...
The marking of conn/pkt is not correct, you are only marking certain packets instead of all the connection packets, remove the "in-interface-list" property from conn & pkt marking rules.
I'm not sure, I can't mark the connection correctly as you tell me
/ip firewall mangle
add action=mark-connection chain=forward connection-mark=no-mark \
    new-connection-mark=Plan15mb-conn passthrough=yes src-address-list=\
    "HOME 15MB"
add action=mark-packet chain=forward connection-mark=Plan15mb-conn \
    new-packet-mark=P15mb-down-pacotes passthrough=no
add action=mark-packet chain=forward connection-mark=Plan15mb-conn \
    new-packet-mark=P15mb-up-pacotes passthrough=no
 
jvzg545cr
just joined
Topic Author
Posts: 9
Joined: Tue Apr 17, 2018 11:02 pm

Re: Queue tree + pcq no working for me

Tue May 18, 2021 6:44 pm

Enable IP firewall on bridge / settings
I'm not sure what you mean
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 11967
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: Queue tree + pcq no working for me

Tue May 18, 2021 8:56 pm

Enable IP firewall on bridge / settings
I'm not sure what you mean
On Winbox click on bridge on the left, click on settings button on the new window opened,
select "use IP firewall" then click on "OK"
 
jvzg545cr
just joined
Topic Author
Posts: 9
Joined: Tue Apr 17, 2018 11:02 pm

Re: Queue tree + pcq no working for me

Wed May 19, 2021 12:08 am

Enable IP firewall on bridge / settings
I'm not sure what you mean
On Winbox click on bridge on the left, click on settings button on the new window opened,
select "use IP firewall" then click on "OK"
No, it can't be, I'm doing something wrong ... they keep going beyond the capacity supported by the pcq configured in the queue tree
 
jvzg545cr
just joined
Topic Author
Posts: 9
Joined: Tue Apr 17, 2018 11:02 pm

Re: Queue tree + pcq no working for me

Wed May 19, 2021 12:09 am

I just tried this setup and nothing
/ip firewall mangle
add action=mark-connection chain=forward connection-mark=no-mark new-connection-mark=15mb_conn passthrough=yes src-address-list=HOGAR15MB
add action=mark-packet chain=forward connection-mark=15mb_conn in-interface=ether2-GW new-packet-mark=D15mb_pacotes passthrough=no
add action=mark-packet chain=forward connection-mark=15mb_conn in-interface=all-ppp new-packet-mark=U15mb_pacotes passthrough=no
add action=mark-connection chain=forward connection-mark=no-mark new-connection-mark=10mb_conn passthrough=yes src-address-list="HOGAR 10MB"
add action=mark-packet chain=forward connection-mark=10mb_conn in-interface=ether2-GW new-packet-mark=D10mb_pacotes passthrough=no
add action=mark-packet chain=forward connection-mark=10mb_conn in-interface=all-ppp new-packet-mark=U10mb_pacotes passthrough=no
add action=mark-connection chain=forward connection-mark=no-mark new-connection-mark=8mb_conn passthrough=yes src-address-list="HOME 8MB"
add action=mark-packet chain=forward connection-mark=8mb_conn in-interface=ether2-GW new-packet-mark=D8mb_pacotes passthrough=no
add action=mark-packet chain=forward connection-mark=8mb_conn in-interface=all-ppp new-packet-mark=U8mb_pacotes passthrough=no
add action=mark-connection chain=forward connection-mark=no-mark new-connection-mark=5mb_conn passthrough=yes src-address-list="HOGAR 5MB"
add action=mark-packet chain=forward connection-mark=5mb_conn in-interface=ether2-GW new-packet-mark=D5mb_pacotes passthrough=no
add action=mark-packet chain=forward connection-mark=5mb_conn in-interface=all-ppp new-packet-mark=U5mb_pacotes passthrough=no
add action=mark-connection chain=forward connection-mark=no-mark new-connection-mark=2mb_conn passthrough=yes src-address-list="HOGAR 2MB"
add action=mark-packet chain=forward connection-mark=2mb_conn in-interface=ether2-GW new-packet-mark=D2mb_pacotes passthrough=yes
add action=mark-packet chain=forward connection-mark=2mb_conn in-interface=all-ppp new-packet-mark=U2mb_pacotes passthrough=no
add action=mark-connection chain=forward connection-mark=no-mark new-connection-mark=1mb_conn passthrough=yes src-address-list="HOGAR 1M"
add action=mark-packet chain=forward connection-mark=1mb_conn in-interface=ether2-GW new-packet-mark=D1mb_pacotes passthrough=no
add action=mark-packet chain=forward connection-mark=1mb_conn in-interface=all-ppp new-packet-mark=U1mb_pacotes passthrough=no
this is a 5mb client
Client.PNG
You do not have the required permissions to view the files attached to this post.
 
RnaPtk
just joined
Posts: 1
Joined: Mon Jul 20, 2020 10:50 am

Re: Queue tree + pcq no working for me

Wed May 26, 2021 3:28 pm

I just tried this setup and nothing
/ip firewall mangle
add action=mark-connection chain=forward connection-mark=no-mark new-connection-mark=15mb_conn passthrough=yes src-address-list=HOGAR15MB
add action=mark-packet chain=forward connection-mark=15mb_conn in-interface=ether2-GW new-packet-mark=D15mb_pacotes passthrough=no
add action=mark-packet chain=forward connection-mark=15mb_conn in-interface=all-ppp new-packet-mark=U15mb_pacotes passthrough=no
add action=mark-connection chain=forward connection-mark=no-mark new-connection-mark=10mb_conn passthrough=yes src-address-list="HOGAR 10MB"
add action=mark-packet chain=forward connection-mark=10mb_conn in-interface=ether2-GW new-packet-mark=D10mb_pacotes passthrough=no
add action=mark-packet chain=forward connection-mark=10mb_conn in-interface=all-ppp new-packet-mark=U10mb_pacotes passthrough=no
add action=mark-connection chain=forward connection-mark=no-mark new-connection-mark=8mb_conn passthrough=yes src-address-list="HOME 8MB"
add action=mark-packet chain=forward connection-mark=8mb_conn in-interface=ether2-GW new-packet-mark=D8mb_pacotes passthrough=no
add action=mark-packet chain=forward connection-mark=8mb_conn in-interface=all-ppp new-packet-mark=U8mb_pacotes passthrough=no
add action=mark-connection chain=forward connection-mark=no-mark new-connection-mark=5mb_conn passthrough=yes src-address-list="HOGAR 5MB"
add action=mark-packet chain=forward connection-mark=5mb_conn in-interface=ether2-GW new-packet-mark=D5mb_pacotes passthrough=no
add action=mark-packet chain=forward connection-mark=5mb_conn in-interface=all-ppp new-packet-mark=U5mb_pacotes passthrough=no
add action=mark-connection chain=forward connection-mark=no-mark new-connection-mark=2mb_conn passthrough=yes src-address-list="HOGAR 2MB"
add action=mark-packet chain=forward connection-mark=2mb_conn in-interface=ether2-GW new-packet-mark=D2mb_pacotes passthrough=yes
add action=mark-packet chain=forward connection-mark=2mb_conn in-interface=all-ppp new-packet-mark=U2mb_pacotes passthrough=no
add action=mark-connection chain=forward connection-mark=no-mark new-connection-mark=1mb_conn passthrough=yes src-address-list="HOGAR 1M"
add action=mark-packet chain=forward connection-mark=1mb_conn in-interface=ether2-GW new-packet-mark=D1mb_pacotes passthrough=no
add action=mark-packet chain=forward connection-mark=1mb_conn in-interface=all-ppp new-packet-mark=U1mb_pacotes passthrough=no
this is a 5mb client

Client.PNG
tried this setup
/ip firewall mangle
chain=forward action=mark-packet new-packet-mark=P15mb-down-pacotes passthrough=no dst-address-list=HOGAR15MB log=no log-prefix="" 
chain=forward action=mark-packet new-packet-mark=P15mb-up-pacotes passthrough=no src-address-list=HOGAR15MB log=no log-prefix=""
/queue tree
add disabled=yes limit-at=215M max-limit=215M name=DW parent="Bridge DHCP"
add disabled=yes limit-at=230M max-limit=230M name=UP parent=ether2-GW
add disabled=yes limit-at=183M max-limit=183M name=H-15MB packet-mark=P15mb-down-pacotes parent=DW queue=PCQ_Plan_15M_down
add disabled=yes name=H-15MB-UP packet-mark=P15mb-up-pacotes parent=UP queue=PCQ_Plan_15M_up

Who is online

Users browsing this forum: Bing [Bot], Netstumble and 56 guests