Community discussions

MikroTik App
 
forsquirel
just joined
Topic Author
Posts: 21
Joined: Sat Aug 14, 2021 6:46 pm

Hex s + CSS326. Just want a working vlan config!

Mon Aug 23, 2021 5:53 am

First and foremost, I'm brand new to the ecosystem. Also, I know its been asked a million times before and believe me I've read and read till my eyes have crossed. I'm still a bit confused.

I'm in the process of upgrading my home networking equipment to a better level. Right now I have everything up and running with a completely flat topology. Everything is in the same subnet. Unfortunately I'd like to split that up into vlans.

Everything falls into 1 of 3 categories
  • Guests
  • Cameras
  • Everything else
Now I spent 2 weeks just getting everything working with vlans only to find out that once I hooked it up to the internet I could get no traffic.
Can be found here
# aug/23/2021 02:38:54 by RouterOS 6.47.10
# software id = 
#
#
#
/interface bridge
add admin-mac=2C:C8:1B:17:A5:D7 auto-mac=no name=bridge vlan-filtering=yes
/interface ethernet
set [ find default-name=ether1 ] name=ether6
/interface vlan
add name=cameras vlan-id=30
add name=guest vlan-id=10
/interface list
add name=WAN
add name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip dhcp-server option
add code=6 name=LocalDNS value="'192.168.0.13''192.168.0.14'"
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/ip pool
add name=pool_guest ranges=192.168.10.2-192.168.10.14
add name=pool_cameras ranges=192.168.10.17-192.168.10.30
add name=pool_lan ranges=192.168.0.2-192.168.0.125
/ip dhcp-server
add address-pool=pool_cameras disabled=no interface=cameras name=dhcp_cameras
add add-arp=yes address-pool=pool_lan disabled=no interface=bridge name=\
    dhcp_lan
add address-pool=pool_guest disabled=no interface=guest name=dhcp_guest
/system logging action
set 1 disk-file-name=flash/log
/interface bridge port
add bridge=bridge interface=*2
add bridge=bridge interface=*3
add bridge=bridge interface=*4
add bridge=bridge interface=*5
add bridge=bridge interface=*6
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface bridge vlan
add bridge=bridge tagged=*5 untagged=bridge,*2 vlan-ids=1
add bridge=bridge tagged=*5 untagged=bridge,*2 vlan-ids=10
add bridge=bridge tagged=*5 untagged=bridge,*2 vlan-ids=30
/interface detect-internet
set detect-interface-list=WAN wan-interface-list=WAN
/interface list member
add interface=bridge list=LAN
add list=WAN
/ip address
add address=192.168.0.1/25 interface=bridge network=192.168.0.0
add address=192.168.10.16/25 interface=cameras network=192.168.10.0
add address=192.168.10.1/25 interface=guest network=192.168.10.0
/ip dhcp-client
add disabled=no

/ip dhcp-server network
add address=192.168.0.0/25 dhcp-option=LocalDNS dns-server=\
    192.168.0.13,192.168.0.14,192.168.0.15 gateway=192.168.0.1 netmask=25
add address=192.168.10.0/28 gateway=192.168.10.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.0.1 comment=defconf name=router.lan
/ip firewall filter
add action=accept chain=input comment=\
    "defconf: accept established,related,untracked" connection-state=\
    established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
    invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
    "defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
    in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
    ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
    ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
    connection-state=established,related
add action=accept chain=forward comment=\
    "defconf: accept established,related, untracked" connection-state=\
    established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
    connection-state=invalid
add action=drop chain=forward comment=\
    "defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
    connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
    ipsec-policy=out,none out-interface-list=WAN
/ip service
set telnet disabled=yes
/ip smb shares
set [ find default=yes ] directory=/flash/pub
/system identity
set name=Morehead
/system leds
add leds="" type=interface-activity
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
this is roughly my current working config (sanitized a bit)
# aug/22/2021 20:50:57 by RouterOS 6.48.3
# software id = d33d-b33f
#
# model = RB760iGS
# serial number = 8675309JNY
/interface bridge
add admin-mac=xxxxxxxxx auto-mac=no comment=defconf name=bridge
/interface ethernet
set [ find default-name=ether3 ] disabled=yes
set [ find default-name=ether4 ] disabled=yes
set [ find default-name=sfp1 ] disabled=yes
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip dhcp-server option
add code=6 name=HollyDNS value="'192.168.1.1''192.168.1.13''192.168.1.14'"
add code=6 name=EverlyDNS value="'192.168.1.1''192.168.1.14''192.168.1.13'"
add code=6 name=LocalDNS value="'192.168.1.1'"
/ip hotspot profile
set [ find default=yes ] html-directory=hotspot
/ip pool
add name=dhcp ranges=192.168.1.100-192.168.1.125
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge name=dhcp_lan
/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=ether5
add bridge=bridge comment=defconf interface=sfp1
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=ether1 list=WAN
/ip address
add address=192.168.1.1/25 interface=bridge network=192.168.1.0
/ip dhcp-client
add comment=defconf disabled=no interface=ether1

/ip dhcp-server network
add address=192.168.1.0/25 dhcp-option=HollyDNS dns-server=\
    192.168.1.13,192.168.1.14,192.168.1.15 gateway=192.168.1.1 netmask=25
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.1.1 name=router.lan
/ip firewall filter
add action=accept chain=input comment=\
    "defconf: accept established,related,untracked" connection-state=\
    established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
    invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
    "defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
    in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
    ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
    ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
    connection-state=established,related
add action=accept chain=forward comment=\
    "defconf: accept established,related, untracked" connection-state=\
    established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
    connection-state=invalid
add action=drop chain=forward comment=\
    "defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
    connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
    ipsec-policy=out,none out-interface-list=WAN
/system clock
set time-zone-name=America/California
/system identity
set name=Morehead
/system ntp client
set enabled=yes primary-ntp=192.168.1.16
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
All I'm looking for is to get 1 port, ether5, to connect to the switch to route traffic as needed. I had all this done in a OpenWRT setup just prior to switching over.

Can I do this with the hEX s or would the hEX PoE be a better choice? or something like the RB2011? I just need some segregation on the lan.

thanks,


edit: Solved. Managed to get a working setup through a trunk between the two.

Who is online

Users browsing this forum: Google [Bot], h1ghrise, lifeboy, phascogale, RobertsN and 64 guests