Community discussions

MikroTik App
 
dada
Member Candidate
Member Candidate
Topic Author
Posts: 245
Joined: Tue Feb 21, 2006 1:44 pm

WinBox issues

Thu Oct 25, 2007 5:36 pm

I have strange problems with winbox on my PC (WinXP 2GB RAM) - if I run multiple instances of WinBox the Winbox tend to crash silently (i.e. the application dissapears and no error dialog box is shown) when I try to open a new form (say WiFi configuration dialog or so). In most cases it helps if I close some unused winbox sessions (especially the ones which are already disconnected from radios). Sometimes winbox crashes even only one copy is running. It looks like some memory allocation problem in the application or so. Anybody hs the some problems? It may be related to some memory problem related to WinXP I think.

I have tried to use decompresed winbox (upx -d winbox.exe) to see if there are no UPX/swap related problems but it didn't help.
I am using the latest winbox I found on http://www.mikrotik.com.

Regards
Dalibor Toman
 
User avatar
mushmx
Frequent Visitor
Frequent Visitor
Posts: 81
Joined: Sat Jul 21, 2007 7:01 pm
Location: Mexico

Re: WinBox issues

Sun Nov 18, 2007 2:50 am

well some times this happend when you use the winbox turn off the wlan of ur notebook and connect directly with the RJ45 cable is more stable.
 
dada
Member Candidate
Member Candidate
Topic Author
Posts: 245
Joined: Tue Feb 21, 2006 1:44 pm

Re: WinBox issues

Tue Dec 11, 2007 4:05 pm

well some times this happend when you use the winbox turn off the wlan of ur notebook and connect directly with the RJ45 cable is more stable.
this is not the case. When I lost connectivity for some reason - the Winbox shows error box and the session is terminated after the OK button is pressed. I mean problems related directly to the winbox - not to the remote mikrotik nor the connection to it. If the problem appears it is not possible to establish reliable connection even with lokal (connected by ethernet) MTs. Then is enpough of the Winboxes is terminated I can start new Winbox session again. It looks like there is some problem with memory allocation in Winbox (or perhaps in Windows)... I would expect the Winbox will says something like 'There is strange problem with memory or with something else and we have to terminate'. But the application disappears silently...
 
User avatar
hilton
Long time Member
Long time Member
Posts: 635
Joined: Thu Sep 07, 2006 5:12 pm
Location: Jozi (aka Johannesburg), South Africa

Re: WinBox issues

Fri Dec 14, 2007 3:14 pm

Apparently winbox can be unstable if you connect via the MAC address. So rather use the IP address once it's set-up.

The latest version, 2.2.13 solves the problem of locating the unit via it's MAC address and then automatically connects you via the IP address if you click on it.

Hope this helps.
Regards
Hilton
 
dada
Member Candidate
Member Candidate
Topic Author
Posts: 245
Joined: Tue Feb 21, 2006 1:44 pm

Re: WinBox issues

Fri Dec 14, 2007 4:07 pm

Apparently winbox can be unstable if you connect via the MAC address. So rather use the IP address once it's set-up.

The latest version, 2.2.13 solves the problem of locating the unit via it's MAC address and then automatically connects you via the IP address if you click on it.

Hope this helps.
The problem I have is not related to MAC telnet (connected via IP) But maybe the newer versions of Winbox did something with it. For some time I didn't see the winbox disappear...
When the problem appear any new session made via Winbox crashes after a while (when I pickup an item from menu, try to see wireless card settings etc).

Thanks
 
User avatar
hilton
Long time Member
Long time Member
Posts: 635
Joined: Thu Sep 07, 2006 5:12 pm
Location: Jozi (aka Johannesburg), South Africa

Re: WinBox issues

Fri Dec 14, 2007 4:29 pm

You are not trying to run sniff or snooper by any chance?
Regards
Hilton
 
dada
Member Candidate
Member Candidate
Topic Author
Posts: 245
Joined: Tue Feb 21, 2006 1:44 pm

Re: WinBox issues

Fri Dec 14, 2007 5:51 pm

You are not trying to run sniff or snooper by any chance?
no sniffer.
 
ilius168
Member Candidate
Member Candidate
Posts: 255
Joined: Sat Apr 07, 2007 3:54 am

Re: WinBox issues

Wed Jan 02, 2008 4:22 pm

have u tried untick "load previous session" in winbox loader?
 
dada
Member Candidate
Member Candidate
Topic Author
Posts: 245
Joined: Tue Feb 21, 2006 1:44 pm

Re: WinBox issues

Fri Jan 04, 2008 11:02 am

have u tried untick "load previous session" in winbox loader?
not yet. It looks I found another problem the checkbox doesn't remember its settings after Save :-(

Usually the winbox is working fine. The problem usually appears when I left too many winbox sessions open and many of them lost connection to radios. Even active session may have the problem (I select wireless interface settings for example and the winbox terminates silently)

Who is online

Users browsing this forum: birlematei, MSN [Bot] and 64 guests