Community discussions

MUM Europe 2020
 
McFrosty
just joined
Topic Author
Posts: 11
Joined: Sat Apr 02, 2005 5:19 pm
Location: College Station, TX
Contact:

Giving clients Public IP addresses

Fri Dec 28, 2007 1:16 am

This should be easy, but every setup I have tried doesn't seem to work.

I have two class C public subnets and I am trying pass some public IP's along to my clients.

I am currently using the 1:1 NAT methodology, and it is working...for now.

I am seeing more and more requests to be removed from the 1:1 nat solution and be given full public IP addresses.

I have searched around the forums and have not really found a suitable answer. Can anybody provide a link or example?

Thanks,
McFrosty
 
gmsmstr
Trainer
Trainer
Posts: 940
Joined: Fri Jun 04, 2004 2:22 am
Location: St. Louis, MO
Contact:

Re: Giving clients Public IP addresses

Fri Dec 28, 2007 7:49 pm

This really depends on your configuration. proxy-arp may help, but not a good solution personally. This may be a question for a MT consultant http://www.mikrotik.com/consultants.html
Dennis Burgess, MCTCE, MTCNA, MCTCTE, MTCWE, MTCNIE, A+, N+, MCP, MTCSE Mikrotik Certified Consultant / Trainer
Need Mikrotik Support: http://www.linktechs.net -- Link Technologies, Inc.
-- Author of "Learn RouterOS: Second Edition"
 
triac
Frequent Visitor
Frequent Visitor
Posts: 91
Joined: Mon Feb 07, 2005 7:35 pm
Location: Italy

Re: Giving clients Public IP addresses

Sun Dec 30, 2007 2:20 pm

Hi McFrosty, Proxy-arp in my PPPoE server work fine! Add IP-pool of your public address range to customer profile

xxxxxxxxxxxxxxxxxxxxx example: create pool: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

[xxx@PPPoE Server] ip pool> add name=pool_1 range=88.xxx.xxx.100-88.xxx.xxx.200
[xxx@PPPoE Server] ip pool>
[xxx@PPPoE Server] ip pool> print
# NAME RANGES
0 pool_1 88.xxx.xxx.10-88.xxx.xxx.250
[xxx@PPPoE Server] ip pool>

xxxxxxxxxxxxxx Add pool to profile xxxxxxxxxxxxxxxxxxx

[xxx@PPPoE Server] ppp profile>add 0 remote-address=pool_1
(where "0" is the number of your actual customer profile).

[xxx@PPPoE Server] ppp profile>
[xxx@PPPoE Server] ppp profile> print
Flags: * - default

0 name="profile PPPoE" local-address=1x.xx.x0.5 remote-address=pool_1
use-compression=default use-vj-compression=default use-encryption=required
only-one=default change-tcp-mss=default

[xx@PPPoE Server] ppp profile>

xxxxxxxxxxxxx Enable Proxy-arp on WAN port xxxxxxxxxxxxxxxxxxx

[xxx@PPPoE Server] interface ethernet> set *WAN PORT NUMBER* arp=proxy-arp
[xxx@PPPoE Server] interface ethernet>


VERY IMPORTANT!!!

Masquerade NAT rule MUST be disabled!!!!

Try!!

Paolo

PS: TNX to CMIT, he have explained me these settings some time ago!


---Dennis... che schifo! Il forum non serve per far soldi ma per condividere esperienze! VERGOGNA!
Paolo Torri

Who is online

Users browsing this forum: No registered users and 26 guests