Community discussions

 
User avatar
karo84
Member Candidate
Member Candidate
Topic Author
Posts: 194
Joined: Fri Aug 17, 2007 9:06 am

ARP Problem, Argent

Sat Mar 29, 2008 6:59 pm

Hello Everybody
We use ROS 2.9.51 on PIII board.
There is a bridge rstp on,
Often, I have to delete all arp entries, in order to have ping (connection to clients).
Now I have written a script which deletes arp entries every 2 minutes. I thinkthis is abnormal act.
Why?
Any suggestions, any advise?


Regards
K. Aznavuryan
 
User avatar
ahmedsaffar76
Member
Member
Posts: 307
Joined: Sun Feb 17, 2008 2:56 pm
Location: Iraq

Re: ARP Problem, Argent

Sat Mar 29, 2008 11:32 pm

Hello Everybody
We use ROS 2.9.51 on PIII board.
There is a bridge rstp on,
Often, I have to delete all arp entries, in order to have ping (connection to clients).
Now I have written a script which deletes arp entries every 2 minutes. I thinkthis is abnormal act.
Why?
Any suggestions, any advise?


Regards
K. Aznavuryan
Hi ;
glad to write here .
could you please write the script you are using to delete the ARP .
i had another strange case for the ARP , recently i read about the ARP and how you could use it to protect the network bu using ARP-Reply .
when the ARP was enable , i found that in the ARP list it give me the MAC for the two NIC i am using in the router .
the mac for the both NIC was the same and it is not match the real MAC for any of the cards . :shock: :shock:
another question here to be sure of the ARP work .
if i remove the MAC of one of the clients from the ARP list and i am using ARP-REPLY , will he not be able to reach the internet anymore ?
with best regards .
 
User avatar
karo84
Member Candidate
Member Candidate
Topic Author
Posts: 194
Joined: Fri Aug 17, 2007 9:06 am

Re: ARP Problem, Argent

Sun Mar 30, 2008 1:04 am

Here the scheduled script
name="schedu"
on-event=
:foreach i in=[/ip arp find ] do=[/ip arp remove $i]

start-date=dec/12/2007 start-time=02:14:19 interval=2m run-count=200 next-run=04:04:19
 
User avatar
ahmedsaffar76
Member
Member
Posts: 307
Joined: Sun Feb 17, 2008 2:56 pm
Location: Iraq

Re: ARP Problem, Argent

Sun Mar 30, 2008 2:56 am

Here the scheduled script
name="schedu"
on-event=
:foreach i in=[/ip arp find ] do=[/ip arp remove $i]

start-date=dec/12/2007 start-time=02:14:19 interval=2m run-count=200 next-run=04:04:19
Hi Again ;
many thanks for the script you include i have some comment on it to achive my requirement .
first i need to disable MAC not to remove it and that for some MAC's i choose in the required period .
so will it be look like the following :
:foreach 1 in=[/ip arp find ] do=[/ip arp disable $1]
:foreach 2 in=[/ip arp find ] do=[/ip arp disable $2]
what about the following :
interval=2m run-count=200 next-run=04:04:19
could you explain it ?
will be waiting your reply .
with best regards .
 
User avatar
eebng_1422
Frequent Visitor
Frequent Visitor
Posts: 83
Joined: Sun Dec 23, 2007 12:39 am
Location: Assiut, Egypt
Contact:

Re: ARP Problem, Argent

Mon Mar 31, 2008 12:42 am

hi my friend,,,
i want to ask you if that script protect my network from netcut and other arp programs ????

:lol:
============
Ahmed Bakhiet
skype Name: abakhiet
Mob: +2/0108944553
Move 2 Improve
 
User avatar
ahmedsaffar76
Member
Member
Posts: 307
Joined: Sun Feb 17, 2008 2:56 pm
Location: Iraq

Re: ARP Problem, Argent

Mon Apr 14, 2008 7:50 pm

Here the scheduled script
name="schedu"
on-event=
:foreach i in=[/ip arp find ] do=[/ip arp remove $i]

start-date=dec/12/2007 start-time=02:14:19 interval=2m run-count=200 next-run=04:04:19
Hi Again ;
many thanks for the script you include i have some comment on it to achive my requirement .
first i need to disable MAC not to remove it and that for some MAC's i choose in the required period .
so will it be look like the following :
:foreach 1 in=[/ip arp find ] do=[/ip arp disable $1]
:foreach 2 in=[/ip arp find ] do=[/ip arp disable $2]
what about the following :
interval=2m run-count=200 next-run=04:04:19
could you explain it ?
will be waiting your reply .
with best regards .
Hi ;
still waiting your updates .
with best regards .

Who is online

Users browsing this forum: No registered users and 31 guests