Community discussions

MikroTik App
 
alisiddique
just joined
Topic Author
Posts: 2
Joined: Mon Aug 18, 2008 9:32 am

which webistes are viewd in my network by all office workers

Wed Aug 27, 2008 8:58 am

hello,

i am using the mikrotik as proxy machine and using winbox for bandwith control. i want that i can see which websites are wacthing by my office workers right now and i can also see a complete log which user access which websites.is it possible kindly help me.

THX
 
User avatar
roadrunner
Frequent Visitor
Frequent Visitor
Posts: 86
Joined: Thu May 18, 2006 11:22 pm
Location: US

Re: which webistes are viewd in my network by all office workers

Wed Aug 27, 2008 11:19 am

To see the current IP addresses of the proxy clients and the web servers they are currently connecting to, try this command:

/ip proxy connections print

To get more detail (including full urls) you might want to run a Linux machine running Squid or some other Proxy server to get better logs.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24605
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: which webistes are viewd in my network by all office workers

Wed Aug 27, 2008 11:21 am

the current proxy logs should be enough, you just need to find a program that can analyze them, and show you some report.
No answer to your question? How to write posts
 
User avatar
roadrunner
Frequent Visitor
Frequent Visitor
Posts: 86
Joined: Thu May 18, 2006 11:22 pm
Location: US

Re: which webistes are viewd in my network by all office workers

Wed Aug 27, 2008 8:01 pm

I often make things more complicated than they need to be.
To see the proxy logs normis mentioned use this command:

/system logging
add action=memory disabled=no prefix="" topics=web-proxy,account

The log entries will look like this:
11:15:35 web-proxy,account 10.11.15.35 GET http://search.yahoo.com/favicon.ico action=allow cache=MISS

For debug information as well you can also try:
add action=memory disabled=no prefix="" topics=web-proxy
(without account)

the logs will add extra info like this:
10:51:27 web-proxy,debug Response to "GET http://mozilla.mirror.facebook.com/fire ... mplete.mar":
10:51:27 web-proxy,debug HTTP/1.1 206 Partial Content
10:51:27 web-proxy,debug Date: Wed, 27 Aug 2008 16:51:26 GMT
10:51:27 web-proxy,debug Server: Apache/1.3.37.fb1
10:51:27 web-proxy,debug Last-Modified: Thu, 03 Jul 2008 12:58:06 GMT
10:51:27 web-proxy,debug Accept-Ranges: bytes
10:51:27 web-proxy,debug Content-Type: application/octet-stream
10:51:27 web-proxy,debug Content-Range: bytes 0-299999/7673924
10:51:27 web-proxy,debug Content-Length: 300000

Who is online

Users browsing this forum: mbovenka and 39 guests