Community discussions

MikroTik App
 
mudasir
Member Candidate
Member Candidate
Topic Author
Posts: 278
Joined: Tue Apr 29, 2008 3:38 am
Location: Karachi, Pakistan
Contact:

Error sending e-mail: invalid TO address

Wed Dec 03, 2008 8:19 am

Hi,

I am trying to send my Backup file using "/tool e-mail" options, but it is giving me error.

Error is

"Error sending e-mail: invalid TO address"

I am using following command

/tool e-mail send to="cool_mudasir@hotmail.com" subject"Testing Mail" body="This is
a Test Mail From Mikrotik ROS" server[:resolve my.smtp.com] from="coolmudasir@gmail.com" file="CrystalNet.backup"

I dont know why this error is coming...can anyone please help me out in this...
The smtp server is provided by my ISP, which works fine, just not working with MK.
Regards
Mudasir Mirza
http://www.diglinux.com
 
User avatar
bellis
newbie
Posts: 49
Joined: Wed Nov 05, 2008 1:15 am
Location: Woodland, WA
Contact:

Re: Error sending e-mail: invalid TO address

Thu Dec 04, 2008 7:49 pm

it looks like it may be an issue with authentication to the smtp server. to my knowledge, MT OS (as well as dude and other software that MT writes) does not have the ability to use mailservers that have authentication. for our dude, we had to create a mail server without authentication and then locked it down to the private ip of the dude machine. Havent found any other way around it.
"If it ain't broke, you're not tryin"
 
mudasir
Member Candidate
Member Candidate
Topic Author
Posts: 278
Joined: Tue Apr 29, 2008 3:38 am
Location: Karachi, Pakistan
Contact:

Re: Error sending e-mail: invalid TO address

Fri Dec 05, 2008 10:11 am

Hi,

Dear i am using this SMTP server on other machine, and it does not require any authentication. So there must be something else worng wtih MT.
Regards
Mudasir Mirza
http://www.diglinux.com
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24550
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Error sending e-mail: invalid TO address

Fri Dec 05, 2008 10:13 am

try other kinds of email addresses
No answer to your question? How to write posts
 
User avatar
balimore
Forum Veteran
Forum Veteran
Posts: 892
Joined: Mon Apr 10, 2006 3:38 am

Re: Error sending e-mail: invalid TO address

Fri Dec 05, 2008 4:18 pm

-----
Hello fren,

yup we are remember will give you simple idea...... Backup and SMTP update......
yes, ofcourse your execute is failed, try to SET first server name for.
i had success since 18 months ago with this http://forum.mikrotik.com/viewtopic.php?f=9&t=17102 until now and we have schedule every 12 hours will send of our backup scripts and SMTP updates Cetralized AAA. and everytime we received and monitor for IP address randomly from main ISP.

good luck....:wink:
again Thanks to Mikrotik & Teams

Hasbullah.com
------

Hi,

I am trying to send my Backup file using "/tool e-mail" options, but it is giving me error.

Error is

"Error sending e-mail: invalid TO address"

I am using following command

/tool e-mail send to="cool_mudasir@hotmail.com" subject"Testing Mail" body="This is
a Test Mail From Mikrotik ROS" server[:resolve my.smtp.com] from="coolmudasir@gmail.com" file="CrystalNet.backup"

I dont know why this error is coming...can anyone please help me out in this...
The smtp server is provided by my ISP, which works fine, just not working with MK.
 
mudasir
Member Candidate
Member Candidate
Topic Author
Posts: 278
Joined: Tue Apr 29, 2008 3:38 am
Location: Karachi, Pakistan
Contact:

Re: Error sending e-mail: invalid TO address

Sat Dec 06, 2008 12:10 pm

Hi,

Thanks for the reply. I dont understand that script completely.

Dear Normis, when you say try other kind of e-mail address, i have tried gmail.com, hotmail.com, yahoo.com, live.com. Same error on all e-mail address.

I only want a simple way to mail my backup file created on alternate days to my mail address which is cool_mudasir@hotmail.com.
Regards
Mudasir Mirza
http://www.diglinux.com
 
andrisuwignyo
just joined
Posts: 2
Joined: Thu Jun 10, 2010 5:55 am
Location: Parijs Van Java (Bandung), Indonesia
Contact:

Re: Error sending e-mail: invalid TO address

Thu Jun 10, 2010 5:58 am

Hi,

I am trying to send my Backup file using "/tool e-mail" options, but it is giving me error.

Error is

"Error sending e-mail: invalid TO address"

I am using following command

/tool e-mail send to="cool_mudasir@hotmail.com" subject"Testing Mail" body="This is
a Test Mail From Mikrotik ROS" server[:resolve my.smtp.com] from="coolmudasir@gmail.com" file="CrystalNet.backup"

I dont know why this error is coming...can anyone please help me out in this...
The smtp server is provided by my ISP, which works fine, just not working with MK.
Hi mudasir, i'm also get same problem with my x86 with ROS ver.4.9, i think it's some bug in this version. any idea gan??
 
andrisuwignyo
just joined
Posts: 2
Joined: Thu Jun 10, 2010 5:55 am
Location: Parijs Van Java (Bandung), Indonesia
Contact:

Re: Error sending e-mail: invalid TO address

Thu Jun 10, 2010 5:53 pm

fiuh... finally i've get a solved of this problem.

the key is:
[wignyo@Felix-Net] > tool e-mail print 
    server: 74.125.155.109:25
      from: "<andrisuwignyo>"
  username: "my.gmail.account@gmail.com"
  password: "my.gmail.password"
and taraaaa.. this successfully running email sending from my x86 box
 
plisken
Forum Guru
Forum Guru
Posts: 2453
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: Error sending e-mail: invalid TO address

Sat May 03, 2014 4:38 pm

Who knows IP-address from Hotmail smtp-server and ports? for tools-email
 
Yukado
newbie
Posts: 27
Joined: Tue Apr 20, 2010 10:37 pm

Re: Error sending e-mail: invalid TO address

Thu May 22, 2014 5:57 pm

I would like to know if the email tool work well.

I am trying to send a mail using the yahoo mail server and I cannot do it.

Has anybody gotten success using that tool?

Thanks for your answers.
 
plisken
Forum Guru
Forum Guru
Posts: 2453
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: Error sending e-mail: invalid TO address

Thu May 22, 2014 6:05 pm

The email tool works perfect, but you must now the IP-address from the mail server and the port.
I use a pop3 server and this works perfect.
http://www.wirelessinfo.be/index.php/mi ... ages/email
Look to my website, sorry but no englisch but look to the printscreens a made
 
gersonsmanet
just joined
Posts: 2
Joined: Thu May 13, 2010 3:04 am

Re: Error sending e-mail: invalid TO address

Fri Aug 18, 2017 6:04 pm

I was able to solve the problem.

I activated the firewall log and realized that the mikrotik address was on a spam list.

I followed the instructions of the site that was listed ip and removed from the list.

After a few minutes everything worked perfectly.

Who is online

Users browsing this forum: Bing [Bot] and 39 guests