Community discussions

MikroTik App
 
Yeahlight
just joined
Topic Author
Posts: 2
Joined: Fri Mar 13, 2009 3:10 pm

Need some assistance with port forwarding to internal IP

Fri Mar 13, 2009 4:05 pm

Picture of setup (RB450G): http://www.eqcprices.com/setup.JPG

The server is "athlon" (192.168.0.248) and I cannot seem to get port 3784 opened to allow clients to connect. I can connect locally through port 3784, so the issue must be with the configuration of the router.

/ip firewall nat add chain=dstnat protocol=tcp dst-port=3784 action=dst-nat to-address=192.168.0.248 to-ports=3784 in-interface=WAN

I am sure the issue is not with my above NAT rule, but rather something else.
 
yri
newbie
Posts: 42
Joined: Wed Jun 28, 2006 1:19 pm

Re: Need some assistance with port forwarding to internal IP

Fri Mar 13, 2009 8:27 pm

Picture of setup (RB450G): http://www.eqcprices.com/setup.JPG

The server is "athlon" (192.168.0.248) and I cannot seem to get port 3784 opened to allow clients to connect. I can connect locally through port 3784, so the issue must be with the configuration of the router.

/ip firewall nat add chain=dstnat protocol=tcp dst-port=3784 action=dst-nat to-address=192.168.0.248 to-ports=3784 in-interface=WAN

I am sure the issue is not with my above NAT rule, but rather something else.

add action=dst-nat chain=dstnat comment="" disabled=no dst-address=189.106.101.6 dst-port=3784 \
protocol=tcp to-addresses=192.168.0.5 to-ports=0-65535
add action=src-nat chain=srcnat comment="" disabled=no protocol=tcp src-address=192.168.0.5 \
src-port=3784 to-addresses=189.106.101.6 to-ports=0-65535
 
Yeahlight
just joined
Topic Author
Posts: 2
Joined: Fri Mar 13, 2009 3:10 pm

Re: Need some assistance with port forwarding to internal IP

Fri Mar 13, 2009 8:44 pm

Thank you for the reply.

I am assuming you want me to use my public IP address in place of 189.106.101.6 and my server's local IP in place of 192.168.0.5?

I added these rules and clients are still not able to connect through port 3784.
 
Pilgrim
Member Candidate
Member Candidate
Posts: 265
Joined: Sun Mar 30, 2008 1:04 pm

Re: Need some assistance with port forwarding to internal IP

Fri Mar 13, 2009 11:10 pm

Picture of setup (RB450G): http://www.eqcprices.com/setup.JPG

The server is "athlon" (192.168.0.248) and I cannot seem to get port 3784 opened to allow clients to connect. I can connect locally through port 3784, so the issue must be with the configuration of the router.

/ip firewall nat add chain=dstnat protocol=tcp dst-port=3784 action=dst-nat to-address=192.168.0.248 to-ports=3784 in-interface=WAN

I am sure the issue is not with my above NAT rule, but rather something else.

I think the line is correct and it should work. But it seems from the picture that the "to-address=192.168.0.248" was not recognized. try to make a /ip firewall nat print and check

Moreover, if your firewall is set up to block outside traffic not initiated from inside i.e. block all new connections from wan side the you need of course to put in a rule in your filter / forward chain to accept traffic to 3784

something like this

chain=forward action=accept protocol=tcp dst-port=3784

and the rule must be placed in the forward chain before all new connections are dropped.

rgs Pilgrim
 
elsecz
just joined
Posts: 3
Joined: Sat Mar 14, 2009 2:31 pm

Re: Need some assistance with port forwarding to internal IP

Sat Mar 14, 2009 3:04 pm

I tried to solve this problem also. I guess there's gonna be problem with default gateway of athlon machine. Can you make in terminal
/ip dhcp-server network print
and send it?

Who is online

Users browsing this forum: tipex and 82 guests