Community discussions

 
mohdhizami
just joined
Topic Author
Posts: 4
Joined: Sun Oct 26, 2008 11:44 am

how to block youtube on mikrotik 3.23

Sun May 03, 2009 3:15 pm

please help me how to block youtube..
 
csickles
Forum Guru
Forum Guru
Posts: 1257
Joined: Fri May 28, 2004 8:46 pm
Location: Phoenix, AZ
Contact:

Re: how to block youtube on mikrotik 3.23

Sun May 03, 2009 9:12 pm

There are some basic methods and some advanced...

If you are running proxy, and forcing http: thru it, then just add it to the access list with an action of deny.

I use the following methods...
1) Force all http traffoc thru a proxy.
2) Force DNS lookups to the DNS proxy.
3) Use OpenDNS forname resolution, and specify youtube as "banned".
4) Place a redirrect rule in the proxy settings to something like "get a life.com" (*.youtube.*)

This will block youtube by name but not by IP...
I would like to use address lists here, but havent had the time to figure it out yet..

IE a script or import routine that mailtained an address list for "banned" sites and then add a single entry to the proxy to look for items "on the list" and take action..

A "reverse" dns lookup would be handy...

IE: look at the URL, deturman that an address in contained, then look the addredd up and obtain the domain, if one is found, check it against the access list.. if not on a banned list, allow it, if banned then drop or re-dirrect..

For 80% , the baisic steps above will take care of the issue...
If the re-dirrect page states that youtube is not allowed, or that its use is controlled, then you can allways look at activity after the fact and address it with the user...

Some places frown on "blocking" access to sites.... but I dont belive there is a rule that says thay tou cant make it PAINFULLY slow.... that makes it "accessable" but un useable...

just an idea..
Things that make you go "Hmmmmmmmm"...

Craig
 
mohdhizami
just joined
Topic Author
Posts: 4
Joined: Sun Oct 26, 2008 11:44 am

Re: how to block youtube on mikrotik 3.23

Tue May 05, 2009 8:47 am

yes i want running proxy use CF disk...and how to setting the proxy use CF... can u teach me... :?
 
iwantlemonjuice
Member Candidate
Member Candidate
Posts: 101
Joined: Tue Nov 04, 2008 4:53 am
Location: Boracay Island, Philippines

Re: how to block youtube on mikrotik 3.23

Tue May 05, 2009 3:08 pm

hey dude try this im doing this to my box and its working

;;; youtube block
chain=forward action=drop src-address=74.125.15.0/24

correct me if im wrong :D
 
cas3ter01
just joined
Posts: 18
Joined: Mon Jun 08, 2009 9:21 pm

Re: how to block youtube on mikrotik 3.23

Mon Jun 08, 2009 9:58 pm

 
User avatar
fatonk
Member
Member
Posts: 439
Joined: Tue Feb 22, 2005 11:06 am
Location: Mitrovica/Kosova

Re: how to block youtube on mikrotik 3.23

Wed Jun 17, 2009 10:51 am

If you want to filter by IP addresses, use this address-list it filters most of the WEB Video, Youtube, Redtube, Youporn, Dailymotion etc ...

/ip firewall address-list
add address=208.117.224.0/24 comment="" disabled=no list=Youtube
add address=208.117.225.0/24 comment="" disabled=no list=Youtube
add address=208.117.228.0/24 comment="" disabled=no list=Youtube
add address=208.117.229.0/24 comment="" disabled=no list=Youtube
add address=208.117.232.0/24 comment="" disabled=no list=Youtube
add address=208.117.233.0/24 comment="" disabled=no list=Youtube
add address=208.117.234.0/24 comment="" disabled=no list=Youtube
add address=208.117.238.0/24 comment="" disabled=no list=Youtube
add address=208.65.152.0/24 comment="" disabled=no list=Youtube
add address=208.65.153.0/24 comment="" disabled=no list=Youtube
add address=208.65.154.0/24 comment="" disabled=no list=Youtube
add address=64.15.112.0/20 comment="" disabled=no list=Youtube
add address=208.117.236.0/24 comment="" disabled=no list=Youtube
add address=74.125.96.0/19 comment="" disabled=no list=Youtube
add address=72.14.221.0/24 comment="" disabled=no list=Youtube
add address=84.53.128.0/18 comment=Redtube disabled=no list=Youtube
add address=87.248.192.0/19 comment=Youporn disabled=no list=Youtube
add address=216.155.128.0/19 comment=Redtube disabled=no list=Youtube
add address=208.73.208.0/21 comment=Redtube disabled=no list=Youtube
add address=66.55.140.0/23 comment=Redtube disabled=no list=Youtube
add address=74.125.208.0/24 comment="" disabled=no list=Youtube

Regards

Faton
 
iwantlemonjuice
Member Candidate
Member Candidate
Posts: 101
Joined: Tue Nov 04, 2008 4:53 am
Location: Boracay Island, Philippines

Re: how to block youtube on mikrotik 3.23

Tue Aug 04, 2009 1:29 pm

wow thanks for fatok posting and it works

thanks
 
ennoc
just joined
Posts: 10
Joined: Thu Jul 30, 2009 12:18 am

Re: how to block youtube on mikrotik 3.23

Sat Aug 08, 2009 1:56 am

hello.. maybe this question is close now, but id like to know how to do it, block youtube... i need the address list and what else... im a beginer on mikrotik.. sorry guys.
 
iwantlemonjuice
Member Candidate
Member Candidate
Posts: 101
Joined: Tue Nov 04, 2008 4:53 am
Location: Boracay Island, Philippines

Re: how to block youtube on mikrotik 3.23

Sat Aug 08, 2009 9:34 am

hey enoc

1.
you see fatonk post the following address list go to terminal

ip firewall address-list

then copy that fatonk address list and paste one by one

2.
now drop the address-list=youtube to ur firewall something like this

;;; youtube
chain=forward action=drop protocol=tcp dst-address-list=Youtube

cheers
Last edited by iwantlemonjuice on Sat Aug 08, 2009 11:40 am, edited 1 time in total.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8318
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: how to block youtube on mikrotik 3.23

Sat Aug 08, 2009 10:47 am

Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
ennoc
just joined
Posts: 10
Joined: Thu Jul 30, 2009 12:18 am

Re: how to block youtube on mikrotik 3.23

Mon Aug 10, 2009 10:24 pm

thank you so much.. i just miss up the rule for the filter .. thank you.. i got it now
 
rigan123
just joined
Posts: 13
Joined: Mon Nov 28, 2011 12:50 pm

Re: how to block youtube on mikrotik 3.23

Thu Jul 04, 2013 2:45 pm

Not a good idea !

1. IP may be changed anytime
2. You want to block Youtube video only but not whole Youtube site. You should browse Youtube but you shouldn't stream video.
3. If you block IP then you can't browse some other hosted sites too.Like youtube is owned by Google.If you block whole youtube IP it means you are blocking Google too.

The best way as I've seen is to user Layer 7 protocol to stop video streaming.I'm also looking for the perfect REGEXP of Layer 7 that matches and works.I hope this will solve the problem.

Best Regards,
Rigan.

Who is online

Users browsing this forum: Majestic-12 [Bot], MSN [Bot] and 32 guests