Community discussions

MikroTik App
 
erudite
just joined
Topic Author
Posts: 20
Joined: Thu Mar 13, 2008 11:11 am

change IP, GATEWAY and DNS ADDRESS

Tue Sep 15, 2009 1:43 pm

I have mikrotik 2.9.45 version configure by one engineer who have left the company.It is configure as dhcp, NAT and firewall. We have a change of IP ADDRESS. Pls can somebody help me on how to change it to the new ip , gateway and DNS ?
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: change IP, GATEWAY and DNS ADDRESS

Tue Sep 15, 2009 3:37 pm

Should not be a problem. I use ssh to manage my MT boxes.

/ip address
add address=xx.xx.xx.xx/xx interface=ether1

/ip route add gateway=xx.xx.xx.yy

/ip dns
set primary-dns=zz.zz.zz.zz
set secondary-dns=ww.ww.ww.ww

Replace all with appropriate settings. Remove the old settings once the new ones operate ok.
 
erudite
just joined
Topic Author
Posts: 20
Joined: Thu Mar 13, 2008 11:11 am

Re: change IP, GATEWAY and DNS ADDRESS

Wed Sep 16, 2009 11:37 am

Thanks for your reply. If i implement all this command script with the new set of IP paramenter, won't it remove the old IPs ? OR How do I remove the Old onces after implementation. thanks
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: change IP, GATEWAY and DNS ADDRESS

Wed Sep 16, 2009 12:07 pm

Inserting the new ips will not remove anything. The old ips should remain and working until you remove them.
/ip address
print
remove X

Replace X with the line number of the ip you wish to remove. Same with the gateway.
 
erudite
just joined
Topic Author
Posts: 20
Joined: Thu Mar 13, 2008 11:11 am

Re: change IP, GATEWAY and DNS ADDRESS

Wed Sep 16, 2009 12:19 pm

Thanks once again. Now inserting the new ips with the old once in place, will it work with the new ip settings without removing the old onces ?
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: change IP, GATEWAY and DNS ADDRESS

Wed Sep 16, 2009 12:26 pm

Yes. It should work with both ips.

ADD: The one it uses is normally determined by the masquerade or srcnat in "/ip firewall nat". If you use the masquerade rule rather than src-nat, the results may be unpredictable until you remove all but one ip from that interface.
 
erudite
just joined
Topic Author
Posts: 20
Joined: Thu Mar 13, 2008 11:11 am

Re: change IP, GATEWAY and DNS ADDRESS

Wed Sep 16, 2009 1:28 pm

AM greatful, I will implement this then get back to you later.
 
erudite
just joined
Topic Author
Posts: 20
Joined: Thu Mar 13, 2008 11:11 am

Re: change IP, GATEWAY and DNS ADDRESS

Thu Sep 17, 2009 12:28 pm

It works after removing the former gatway IP.
thanks once again.
bye

Who is online

Users browsing this forum: ieleja, mszru and 32 guests