Community discussions

MUM Europe 2020
 
User avatar
ScottReed
Member Candidate
Member Candidate
Topic Author
Posts: 111
Joined: Thu Sep 24, 2009 9:47 pm
Location: Montana / Western Massachusetts

Replicating Configurations

Tue Feb 23, 2010 1:02 am

This is not a question, but more a How-To on replicating a standard configuration to other routerboards. I'm putting this together because I had a real need for this in my application and I found some other posts from people receiving "short" answers and being told that the necessity to do this is "useless".

In short, it is not useless and there are people with this need.

The problem areas of restoring a backup to a new router and then importing a script are as follows:

- Wireless interface(s)
This means that any location of the config that references a wireless interface will show up as UNKNOWN
- User-Manager settings

First, you should have three things done...
1 - Multiple Mikrotik routers of the same model/hardware
2 - A system backup of the router where you created your standard config
3 - A full export of the config from that same router

Next, you need to do some editing of the exported RSC file...
1 - Find ALL entries for mac-address= and remove them
2 - If you use User-Manager you need to edit the adding of the customer and remove references to parent= and subscriber=
3 - You can probably remove any L7 and Firewall rules too, but it's OK to leave them. However, later when we import this script you may receive a "Duplicate Name" warning.

You should also create a small Post Cleanup script to run at the very end. I've attached a copy of what mine is like...
You will need to edit this and might even need to remove lines!
/interface wireless security-profiles remove 1
/ip address set 2 interface=name_of_your_wlan_int
/ip dhcp-server set 0 interface=name_of_your_wlan_int
/ip hotspot set 0 interface=name_of_your_wlan_int
/ip firewall filter set 23 in-interface=name_of_your_wlan_int
/ip firewall filter set 24 in-interface=name_of_your_wlan_int
/tool graphing interface set 1 interface=name_of_your_wlan_int
/user remove 0
Save the script with a meaningful name and tack PostCleanup to the name.

So basically what is happening in this Post Cleanup script is i'm referencing locations where the wlan interface is used but showing as "UNKNOWN". The very last line is removing the default 'admin' user.

When you're ready to setup the new router you want this standard config on, follow these steps...
1 - Using SFTP (WinSCP) copy the correct Mikrotik RouterOS Firmware, User-Manager, System Backup, System Config script and Post Cleanup script to the router.
2 - Let the router update itself and install user-manager if need be. Update the license if need be.
3 - Verify the packages installed
4 - Load the System Backup and reboot
5 - Import the System Config Script (you may receive a warning because of L7/Firewall rules)
6 - Import the Post Cleanup Script

That's it. I have cloned eight RB433's using this procedure.

In my application I do have a few other modifications to perform afterwards to make each router specific to its location. Basically the identity and the SSID. And, sometimes the 802.11 channel!

If anyone is going to question my need for this cloning, that is fine, but for the sake of this initial post I am not going to go into detail.

Hope this helps someone!
:D

Who is online

Users browsing this forum: yuridee and 39 guests