Community discussions

 
cyph3r
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 73
Joined: Sun May 25, 2008 12:21 pm
Location: Pakistan
Contact:

Mikrotik Proxy Process !!!!

Wed May 12, 2010 3:26 pm

i m using mikrotik web proxy with hotspot
why my server process is going to too high
it goes to 50% to 90%

when i off web proxy it goes to 3% to 15%

any solution ???????

ram 1 gb
processor 2.8 ghz
Regards,
Mehmood Ahmed |ĉУρĤ3г|
(+92)345-2835810
www.adminsline.com
adminsline.wordpress.com
E-mail: admin [at] adminsline.com
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6616
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: Mikrotik Proxy Process !!!!

Wed May 12, 2010 3:58 pm

Do you have any problems from CPU load? CPU is working (CPU load is going up), and it is good.
 
cyph3r
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 73
Joined: Sun May 25, 2008 12:21 pm
Location: Pakistan
Contact:

Re: Mikrotik Proxy Process !!!!

Wed May 12, 2010 5:37 pm

when the process goes up
my internet goes slow down !!!!
Regards,
Mehmood Ahmed |ĉУρĤ3г|
(+92)345-2835810
www.adminsline.com
adminsline.wordpress.com
E-mail: admin [at] adminsline.com
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6616
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: Mikrotik Proxy Process !!!!

Thu May 13, 2010 10:31 am

Are you sure that Internet is not slowed down by other factors?
 
GuJack20
Trainer
Trainer
Posts: 322
Joined: Sat Jun 12, 2004 9:44 pm
Location: Tirana
Contact:

Re: Mikrotik Proxy Process !!!!

Fri May 14, 2010 12:18 pm

A processor of 50-90 shouldn't slow the internet..
--Do you remember that guy who gave up? Neither does anybody else!
 
cyph3r
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 73
Joined: Sun May 25, 2008 12:21 pm
Location: Pakistan
Contact:

Re: Mikrotik Proxy Process !!!!

Sat May 15, 2010 9:47 pm

Thanx 4 replies

when the process touch to 100% ,then internet goes down !!


why it goes to high ?????
Regards,
Mehmood Ahmed |ĉУρĤ3г|
(+92)345-2835810
www.adminsline.com
adminsline.wordpress.com
E-mail: admin [at] adminsline.com
 
pospanko
Member Candidate
Member Candidate
Posts: 272
Joined: Sun Dec 18, 2005 4:23 pm

Re: Mikrotik Proxy Process !!!!

Sat Apr 09, 2011 5:42 pm

Thanx 4 replies

when the process touch to 100% ,then internet goes down !!


why it goes to high ?????
Hi all!
I openned this topis once again because web-proxy in MT with RB is useless.
I tested it on RB433AH with 8GB MicroSD and with 1 (i write it: ONE) wireless client and after few pages are oppened, processor goes up to 100% and surfing stops for few seconds. After that I can surf for few pages and all over agian, start-stop-start-stop...
Terrible!!! Are there any plans to rewrite proxy and manage it to work? You can't say that RB433AH can't manage one client for wireless and proxy,,,
Is anyone have some advice? I denyed cookies to being cached but no changes,,,
 
siprox
Frequent Visitor
Frequent Visitor
Posts: 83
Joined: Fri Apr 01, 2011 11:14 am

Re: Mikrotik Proxy Process !!!!

Mon Apr 11, 2011 11:03 am

maybe cpu process till 100% when proxy building cache,..the solution usual im doing is disable nat redirect to proxy port.
 
pospanko
Member Candidate
Member Candidate
Posts: 272
Joined: Sun Dec 18, 2005 4:23 pm

Re: Mikrotik Proxy Process !!!!

Tue Apr 12, 2011 7:09 pm

maybe cpu process till 100% when proxy building cache,..the solution usual im doing is disable nat redirect to proxy port.
Hi. Thx for answer.
No, I tested it for few days so it isn't in cache build. So, how do you redirect traffic to proxy? By routing it or...?
 
siprox
Frequent Visitor
Frequent Visitor
Posts: 83
Joined: Fri Apr 01, 2011 11:14 am

Re: Mikrotik Proxy Process !!!!

Thu Apr 14, 2011 12:02 am

say now your cache is 20gb on disk and you want to reboot your router with internal proxy enable, it will take -+ 20 minute to building cache, and then make web proxy running, if the same time router building cache, it will slow down or make internet connection down, because nat redirect.
litle tricky im using is, disable nat redirect with scheduler using start time parameter set to "startup" and type this script on event like this :
/ip firewall nat set [find comment="REDIRECT-PROXY"] disabled=yes
:log info "======  DISABLE NAT-REDIRECT-PROXY ======";
nat redirect. to proxy.
6   ;;; REDIRECT-PROXY
     chain=dstnat action=redirect to-ports=3129 protocol=tcp 
     src-address=!192.168.100.3 dst-address-list=!speedtest 
     in-interface=eth2-lokal dst-port=80
anytime we rebooting the router, nat redirect will disabled.

hth.

Who is online

Users browsing this forum: No registered users and 37 guests