Community discussions

 
tomwaterloo
newbie
Topic Author
Posts: 31
Joined: Sun Mar 08, 2009 8:25 pm
Location: Chicago IL

test email not working with gmail

Wed Jul 21, 2010 8:45 pm

I am trying to send a test email via gmail and do not receive anything.

From terminal I type:

send subject="test" body="test" to=tom.waterloo@gmail.com



Email is setup as follows:

[admin@MikroTik] /tool e-mail> print
server: 209.85.225.18:465
from: "Tom Mikrotik"
username: "tom.waterloo@gmail.com"
password: "Mypassword"


Any ideas? Thanks, and of course Mypassword is an alias for my real password since I don't want the whole world to know what it is.
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: test email not working with gmail

Wed Jul 21, 2010 8:58 pm

I would try port 25. Email servers normally deliver email to port 25. I show gmail smtp severs as 74.125.xx.xx.
 
Feklar
Forum Guru
Forum Guru
Posts: 1726
Joined: Tue Dec 01, 2009 11:46 pm

Re: test email not working with gmail

Wed Jul 21, 2010 9:00 pm

gmail's SMTP server doesn't use port 25 if I remember correctly. You'll have to look up their documentation to see what port to use.
 
fewi
Forum Guru
Forum Guru
Posts: 7734
Joined: Tue Aug 11, 2009 3:19 am

Re: test email not working with gmail

Wed Jul 21, 2010 9:07 pm

RouterOS cannot use SSL/TLS for email, which is required to send through gmail. So as far as I know you cannot use gmail to send emails from RouterOS.
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: test email not working with gmail

Wed Jul 21, 2010 9:11 pm

My email server delivers email to gmail.com using port 25. If you are using an email client with gmail (like outlook or thunderbird), that is the port (edit: port 465) you would use to send email to outside addresses.

@fewi: that is true if the destination address is not local.

ADD: try this address for gmail email server. It worked for me. 74.125.47.27
@tomwaterloo: You should have a test email from me (my router using "/tool e-mail" actually) in your inbox if my log is correct.
 
tomwaterloo
newbie
Topic Author
Posts: 31
Joined: Sun Mar 08, 2009 8:25 pm
Location: Chicago IL

Re: test email not working with gmail

Wed Jul 21, 2010 10:35 pm

server: 74.125.47.27:465
from: "Tom Waterloo"
username: "tom.waterloo"
password: "mypassword"

server: 74.125.47.27:25
from: "Tom Waterloo"
username: "tom.waterloo"
password: "mypassword"

tried both of these and neither could send a test message. any other ideas?
 
fewi
Forum Guru
Forum Guru
Posts: 7734
Joined: Tue Aug 11, 2009 3:19 am

Re: test email not working with gmail

Wed Jul 21, 2010 10:36 pm

Leave off the username and password, change the from to something that isn't @gmail.com - as Tim points out at that point you should be able to send to @gmail.com addresses (but not to other domains).
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: test email not working with gmail

Wed Jul 21, 2010 10:38 pm

Did you check your email?
From info (at) wififoryou.com
Subject: test
Body: test

I used the ip I posted as the email server. I had no username or password entered.
 
tomwaterloo
newbie
Topic Author
Posts: 31
Joined: Sun Mar 08, 2009 8:25 pm
Location: Chicago IL

Re: test email not working with gmail

Wed Jul 21, 2010 10:41 pm

server: 74.125.47.27:465
from: "Tom Waterloo"
username: ""
password: ""


Does not work. and does not work with port 25.

Does anyone have notifications being sent through Gmail smtp servers? If so, what are your email settings.

Thanks,
 
tomwaterloo
newbie
Topic Author
Posts: 31
Joined: Sun Mar 08, 2009 8:25 pm
Location: Chicago IL

Re: test email not working with gmail

Wed Jul 21, 2010 10:44 pm

Surfer Tim,

I did receive the test email from you. Not sure why it works for you but not for me.

Tom
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: test email not working with gmail

Wed Jul 21, 2010 10:51 pm

You are about to get a second test. I used this for the entries:
server: 74.125.47.27
from: test (at) wififoryou.com
username = ""
password = ""

Replace the (at) with @, of course. I don't like email spiders.
 
tomwaterloo
newbie
Topic Author
Posts: 31
Joined: Sun Mar 08, 2009 8:25 pm
Location: Chicago IL

Re: test email not working with gmail

Wed Jul 21, 2010 10:59 pm

[admin@MikroTik] /tool e-mail> print
server: 74.125.47.27
from: "test@wififoryou.com"
username: ""
password: ""


Still does not work for me? Any ideas?
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: test email not working with gmail

Wed Jul 21, 2010 11:05 pm

Here is mine:
[admin@test] /tool e-mail> print
    server: 74.125.47.27:25
      from: "test@wififoryou.com"
  username: ""
  password: ""
[admin@test] /tool e-mail> send to=tom.waterloo@gmail.com subject=test body="test3 from SurferTim"
 
tomwaterloo
newbie
Topic Author
Posts: 31
Joined: Sun Mar 08, 2009 8:25 pm
Location: Chicago IL

Re: test email not working with gmail

Wed Jul 21, 2010 11:09 pm

It does work and has been working after all. Gmail has been putting my test emails into spam.

Thanks,
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: test email not working with gmail

Thu Jul 22, 2010 2:17 pm

Good to hear it works. A couple (edit: ok, a few) things to insure your email gets through if you use a service that filters spam:
1) Use a valid 'from' address. Most email servers will trash anything with a malformed 'from' address.
2) Put the 'from' address in your address book or friends list.
3) Don't send a lot of emails in a row. Some email servers will delay accepting the email from the same address (edit: and to the same address) too many times in a row.

ADD: My email server is stricter than this. It is set to reject any email if it cannot resolve the domain of the sender.
 
andrescamino
Member Candidate
Member Candidate
Posts: 198
Joined: Wed Aug 19, 2009 7:07 pm
Location: Guayaquil-Ecuador

Re: test email not working with gmail

Thu Sep 23, 2010 8:13 pm

Hi to everyone,

I'm experiencing the same problem as tomwaterloo, and did all of the modifications as SurferTim said, but no luck. I've tried with this configuration:
[admin@MKTStation] > tool e-mail print
    server: 74.125.65.109:465
      from: "<andrescamino@gmail.com>"
  username: "andrescamino@gmail.com"
  password: "mypassword"
also with
[admin@MKTStation] > tool e-mail print                                               
    server: 74.125.65.109:25    
      from: "<andrescamino@gmail.com>"
  username: "andrescamino@gmail.com"
  password: "mypassword"
and trying to send emails to my other personal account with this line
[admin@MKTStation] > tool e-mail send to=andres_camino@hotmail.com subject=test bod
y="this is a test"
also to other accounts but still no luck...i'm pretty sure the router has internet access and can reach the ip address of the gmail smtp server...can you give some guidance of how to set this up in the right way...i've also waited for an hour to receive mails, also looked into the spam folder...but nothing happens, can you give some guidance?

Thanks
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: test email not working with gmail

Thu Sep 23, 2010 8:18 pm

I've not had very good luck with the gmail server unless you are sending the email to a gmail address. Then I use port 25. I posted a response to your other thread. Take a look at the wiki about setup. like the log setting.
http://wiki.mikrotik.com/wiki/Email_set ... leshooting

If you use gmail (it is secure on port 465), you need to use this:
/tool e-mail send to=yourname@hotmail.com subject="test" body="test" tls=yes
Requires V4.X
 
andrescamino
Member Candidate
Member Candidate
Posts: 198
Joined: Wed Aug 19, 2009 7:07 pm
Location: Guayaquil-Ecuador

Re: test email not working with gmail

Thu Sep 23, 2010 8:35 pm

Hi SurferTim

Thanks a lot...it actually works sending from a gmail account to another gmail account...

I have another question...I used port 25 and whenever i want to send this to another accout
/tool e-mail send to=yourname@hotmail.com subject="test" body="test" tls=yes
i can't writ the TLS it is like it is not valid by the RouterOS, and i have the RouterOS version v4.3
what could happen?
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: test email not working with gmail

Thu Sep 23, 2010 8:38 pm

Hi SurferTim

Thanks a lot...it actually works sending from a gmail account to another gmail account...

I have another question...I used port 25 and whenever i want to send this to another accout
/tool e-mail send to=yourname@hotmail.com subject="test" body="test" tls=yes
i can't writ the TLS it is like it is not valid by the RouterOS, and i have the RouterOS version v4.3
what could happen?
I don't know exactly when the tls feature appeared. I would upgrade the OS to v4.10 or 4.11 and try it again. And use port 465 if you use tls=yes
 
tomwaterloo
newbie
Topic Author
Posts: 31
Joined: Sun Mar 08, 2009 8:25 pm
Location: Chicago IL

Re: test email not working with gmail

Fri Sep 24, 2010 3:09 am

When I got this working the messages were sent to spam. Check your spam box at gmail. IF the message is there, set up a contact with the return address of the message.
 
Zapnologica
Long time Member
Long time Member
Posts: 594
Joined: Fri Sep 25, 2009 8:15 pm
Location: South frica

Re: test email not working with gmail

Wed Nov 17, 2010 2:43 pm

Hi,

i am also having problems,

i have read this thread and it still dont work:

when i try send a email in log it says:
abnormal termination (timeout)
im in SA i dono if that makes a diff?
 
dssmiktik
Forum Veteran
Forum Veteran
Posts: 732
Joined: Fri Aug 17, 2007 8:42 am

Re: test email not working with gmail

Wed Nov 17, 2010 8:03 pm

It should work, just follow these steps:
1) Configure gmail to use https mode: Settings -> General -> Browser connection: Always use https
2) Configure RouterOS email settings:
/tool e-mail
set from=example@gmail.com password=<password> server=74.125.127.109:587 username=example@gmail.com
3) When sending email from RouterOS, use these settings:
/tool e-mail send to=example@gmail.com body="Example" subject="Example" tls=yes
Doug
 
User avatar
deviant2
just joined
Posts: 15
Joined: Tue Dec 07, 2010 7:08 pm

Re: test email not working with gmail

Sat Dec 11, 2010 9:15 pm

gmail :

Gmail Help - IMAP = http://mail.google.com/support/bin/answ ... swer=77659
Gmail Help - POP3 = http://mail.google.com/support/bin/answ ... swer=76147

it show which port number will be used.

actually ... i didnt know which one is gmail/google ip used for email (ive tried block all google ip, but still some pc can browsing google.com). so use domain name.
Newbee was here ... !!!
 
el berto
Member Candidate
Member Candidate
Posts: 197
Joined: Wed Sep 26, 2007 10:53 am

Re: test email not working with gmail

Fri Apr 27, 2012 6:27 pm

Sorry, I'm a bit confused.....
if you have your own g-mail account (x example AdamSendler[at]gmail.com, with your password "H3r0" and your username for login "AdamSendler"), must Mikrotik use your login credentials to send e-mail through g-mail smtp server...... (I think yes, so everyone could make spam using Mikrotik).
Then, the name of sender, must be the e-mail owner (in this case "AdamSendler@gmail.com") or could you put "RB433_Mt_Everest@gmail.com"?

I don't know why, but it doesn't work.....

My account: crs[....]@gmail.com

I placed the configuration on Thunderbird and it works correctly:
smtp.googlemail.com (solved as 173.194.70.16) on port 465 with TLS
[admin@VLAN_Sede] /tool e-mail> print
   address: 173.194.70.16
      port: 465
      from: crs*******@gmail.com
      user: crs*******@gmail.com
  password: *****
[admin@VLAN_Sede] /tool e-mail> 
send to=crs********@gmail.com subject=test body=hello tls=yes port=465
I see on log Error sending e-mail: error connecting to server.
I also tried to change IP address and port, but the same.
 
User avatar
skot
Long time Member
Long time Member
Posts: 586
Joined: Wed Nov 30, 2011 3:05 am

Re: test email not working with gmail

Fri Apr 27, 2012 7:45 pm

I send email using gmail using port 587 with TLS:

http://support.google.com/mail/bin/answ ... swer=13287 says:
Outgoing Mail (SMTP) Server - requires TLS3 or SSL: smtp.gmail.com (use authentication)
Use Authentication: Yes
Port for TLS/STARTTLS: 587
Port for SSL: 465
 
el berto
Member Candidate
Member Candidate
Posts: 197
Joined: Wed Sep 26, 2007 10:53 am

Re: test email not working with gmail

Mon Apr 30, 2012 1:00 pm

Server: 173.194.69.109
If I insert "smtp.gmail.com" it says "Error in Server - ip address or ipv6 address expected!"
173.194.69.109 is the solved DNS for smtp.gmail.com.
Port: 587
From: crs******@gmail.com
User: crs******@gmail.com
Password: *****
send to=m******@tim.it subject=gigi body=tttt t
ls=yes
Same error connecting to server.
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: test email not working with gmail

Mon Apr 30, 2012 2:40 pm

I tested that with the ip you used, and mine sent the email.
/tool e-mail
set server=173.194.69.109:587
set from=myuser@gmail.com
set username=myuser
set password=mypassword
 
rayman1366
Frequent Visitor
Frequent Visitor
Posts: 65
Joined: Mon Feb 20, 2012 1:49 am

Re: test email not working with gmail

Sat Jan 19, 2013 4:00 pm

hi i have 2 mik with same email config, one of them work fine with gmail, but another not work!
why?
i checked 2rd and it can send email to my email without any problem, but cannot send backup!
 
User avatar
donjames
Frequent Visitor
Frequent Visitor
Posts: 87
Joined: Fri Mar 14, 2008 7:07 pm
Location: Henderson, Texas
Contact:

Re: test email not working with gmail

Tue Jul 12, 2016 6:30 am

HI folks,

I have been trying to send email from my Mikrotik RB951 router using the gmail smtp server.  It appeared not to be working even though I could send email from Thunderbird using the same gmail account.  Well, guess what?  There is a setting in the "my account" section of the gmail account that allows you to send email from a "less secure" source which, in this case, happens to be the RB91 router.  

In order to set the gmail email server to send from a "less secure" source, go to your gmail account using your web browser.   Click on your profile photo in the upper-right corner of the web page.  If you haven't uploaded a profile photo, there will be a circle with a "D" in the middle of it.  In the dialog box that appears, click on "my account".  You are now in the "my account" page.  Under "signing in and security", click on "Signing in to Google".  Scroll down to the bottom of the web page and notice "Allow less secure apps: OFF" .  Click on the button to the right and you should now see "Allow less secure apps: ON".  You are now ready to set up your RB951 to send email from the gmail smtp server.

From the command line in Windows, OS X, Linux or Unix, type:
ping smtp.gmail.com
The IP address that you see is the one you will use to configure email in the RB951 router.
Access the RB951 router using Winbox.  Click on Tools and choose "Email Settings".  In the dialog box that appears enter the following data:
server: <the IP address that appeared from ping smtp.gmail.com>
port: 587
Start TLS: yes
From: <your gmail>@gmail.com
User: <your gmail>@gmail.com
Password: <your gmail password>

Be sure to click on "Apply", the "OK". 

You are now ready to send email from the RB951.

I hope this helps.

Regards,
donjames
 
User avatar
k6ccc
Member
Member
Posts: 480
Joined: Fri May 13, 2016 12:01 am
Location: Glendora, CA, USA (near Los Angeles)

Re: test email not working with gmail

Tue Jul 12, 2016 7:35 am

<snip>
In order to set the gmail email server to send from a "less secure" source, go to your gmail account using your web browser.   Click on your profile photo in the upper-right corner of the web page.  If you haven't uploaded a profile photo, there will be a circle with a "D" in the middle of it.  In the dialog box that appears, click on "my account".  You are now in the "my account" page.  Under "signing in and security", click on "Signing in to Google".  Scroll down to the bottom of the web page and notice "Allow less secure apps: OFF" .  Click on the button to the right and you should now see "Allow less secure apps: ON".  You are now ready to set up your RB951 to send email from the gmail smtp server.
I sure wish I could find those setting.  When I click on "Signing in to Google", I get one section for Password and sign-in method with Password, 2-Step Verification,and App passwords.  Below that is Account recovery options.  That has Recovery email, Recovery phone, and Secret Question.  That's it for Signing into Google.  Below that is a section for Device activity & notifications, and another section for Connected apps & sites.  Nowhere on the page is anything about less secure apps.

Jim
RB750Gr3, RB750r2, CRS326-24G-2S (in SwitchOS), CSS326-24G-2S, CSS106-5G-1S, RB260GS
Not sure if I beat them in submission, or they beat me into submission


Jim
 
User avatar
donjames
Frequent Visitor
Frequent Visitor
Posts: 87
Joined: Fri Mar 14, 2008 7:07 pm
Location: Henderson, Texas
Contact:

Re: test email not working with gmail

Tue Jul 12, 2016 3:59 pm

Hi Jim,

Scroll further down the page and look in the section, "Connected apps & sites".  "Allow less secure apps"  is the last entry in that section.

Don
 
User avatar
k6ccc
Member
Member
Posts: 480
Joined: Fri May 13, 2016 12:01 am
Location: Glendora, CA, USA (near Los Angeles)

Re: test email not working with gmail

Tue Jul 12, 2016 5:04 pm

Hi Jim,

Scroll further down the page and look in the section, "Connected apps & sites".  "Allow less secure apps"  is the last entry in that section.

Don
Not there.  All I have in that section is sub-sections for  "Apps connected to your account" and "Saved Passwords".
UPDATE!
On my primary personal G-Mail account I have 2 Factor Authentication turned on.  When 2FA is on, the Allow less secure apps is not shown.  I just logged into a different G-Mail account that does not use 2FA, and Allow less secure apps is allowed on that account.
To confirm all that, I just logged into several other G-Mail accounts (between personal and work I have access to something like 10 of them).  Some of the accounts have 2FA set up and some do not.  Every account with 2FA would not show the option for less secure apps.  The accounts that do not use 2FA, have the option for less secure apps.  So I think that's the answer.  As a general rule, I prefer to use 2FA, but will have to try using one of the accounts that is not set up for 2FA.
RB750Gr3, RB750r2, CRS326-24G-2S (in SwitchOS), CSS326-24G-2S, CSS106-5G-1S, RB260GS
Not sure if I beat them in submission, or they beat me into submission


Jim
 
User avatar
donjames
Frequent Visitor
Frequent Visitor
Posts: 87
Joined: Fri Mar 14, 2008 7:07 pm
Location: Henderson, Texas
Contact:

Re: test email not working with gmail

Tue Jul 12, 2016 7:13 pm

Hi Jim,

Please let me know if you can get it to work.

Thanks,

Don
 
User avatar
k6ccc
Member
Member
Posts: 480
Joined: Fri May 13, 2016 12:01 am
Location: Glendora, CA, USA (near Los Angeles)

Re: test email not working with gmail

Tue Jul 12, 2016 11:22 pm

Well, I got it working - finally.  Tried all kinds of stuff.  Tried G-Mail, my ISP's server, and even my own mail server.  From router #1 which connects to the LAN for my server, I could send mail via the local LAN IP address, but not the public IP from either router.  I know that an external device can send mail via my mail server, so I knew the ports were open to the server on router #1.  When sending to my own server, I had the advantage that I could look at the server logs to see if anything was getting to the mail server - and there wasn't when it failed.  Started thinking it might be a firewall issue.  Looked at my firewall rules in the input chain and found the answer.  I was very specific on what was allowed on the input chain, and anything else was dropped.  I did not have a rule allowing established and related connections in the input chain - DUH!  Had not been an issue before as there was not any other router generated outbound traffic other than items that would have specifically allowed return path.

Working fine now!

Jim
RB750Gr3, RB750r2, CRS326-24G-2S (in SwitchOS), CSS326-24G-2S, CSS106-5G-1S, RB260GS
Not sure if I beat them in submission, or they beat me into submission


Jim
 
User avatar
donjames
Frequent Visitor
Frequent Visitor
Posts: 87
Joined: Fri Mar 14, 2008 7:07 pm
Location: Henderson, Texas
Contact:

Re: test email not working with gmail

Wed Jul 13, 2016 2:06 am

Hi Jim,

That's great!  I think we finally solved the mystery of how to send email from a Routerboard using the gmail smtp server.  There has been a lot of discussion on this forum about this.

Don
 
freemannnn
Long time Member
Long time Member
Posts: 669
Joined: Sun Oct 13, 2013 7:29 pm

Re: test email not working with gmail

Wed Jul 13, 2016 3:36 pm


From the command line in Windows, OS X, Linux or Unix, type:
ping smtp.gmail.com
The IP address that you see is the one you will use to configure email in the RB951 router.
for your information......from ros 6.33 and up there is no reason to resolve smtp.gmail.com

What's new in 6.33 (2015-Nov-06 12:49):
*) email - allow server to be specified as fqdn which is resolved on each send;

thank u mikrotik for this nice feature ;)
 
User avatar
donjames
Frequent Visitor
Frequent Visitor
Posts: 87
Joined: Fri Mar 14, 2008 7:07 pm
Location: Henderson, Texas
Contact:

Re: test email not working with gmail

Wed Jul 13, 2016 10:24 pm


From the command line in Windows, OS X, Linux or Unix, type:
ping smtp.gmail.com
The IP address that you see is the one you will use to configure email in the RB951 router.
for your information......from ros 6.33 and up there is no reason to resolve smtp.gmail.com

What's new in 6.33 (2015-Nov-06 12:49):
*) email - allow server to be specified as fqdn which is resolved on each send;

thank u mikrotik for this nice feature ;)
I tested  the email using smtp.gmail.com and it does work.  Thanks for the update.
Regards,
Don
 
User avatar
k6ccc
Member
Member
Posts: 480
Joined: Fri May 13, 2016 12:01 am
Location: Glendora, CA, USA (near Los Angeles)

Re: test email not working with gmail

Wed Jul 13, 2016 10:30 pm

I updated one of my routers to 6.34 (from 6.25) this morning, so I will also give it a try...


Sent from my Droid Turbo via Tapatalk, so blame any typos or spelling errors on Android
RB750Gr3, RB750r2, CRS326-24G-2S (in SwitchOS), CSS326-24G-2S, CSS106-5G-1S, RB260GS
Not sure if I beat them in submission, or they beat me into submission


Jim
 
User avatar
donjames
Frequent Visitor
Frequent Visitor
Posts: 87
Joined: Fri Mar 14, 2008 7:07 pm
Location: Henderson, Texas
Contact:

Re: test email not working with gmail

Thu Jul 14, 2016 12:27 am

I updated one of my routers to 6.34 (from 6.25) this morning, so I will also give it a try...


Sent from my Droid Turbo via Tapatalk, so blame any typos or spelling errors on Android
Hi Jim,
Be sure to update your routerboard firmware.  I have an RB751 that was running firmware version 3.24 and would not send email.  I updated it to firmware version 3.33 and RouterOS version 6.34.5 and now it sends email.  It would also not set the clock with a query to an NTP server.
Don
 
User avatar
k6ccc
Member
Member
Posts: 480
Joined: Fri May 13, 2016 12:01 am
Location: Glendora, CA, USA (near Los Angeles)

Re: test email not working with gmail

Thu Jul 14, 2016 12:40 am

I updated one of my routers to 6.34 (from 6.25) this morning, so I will also give it a try...


Sent from my Droid Turbo via Tapatalk, so blame any typos or spelling errors on Android
Hi Jim,
Be sure to update your routerboard firmware.  I have an RB751 that was running firmware version 3.24 and would not send email.  I updated it to firmware version 3.33 and RouterOS version 6.34.5 and now it sends email.  It would also not set the clock with a query to an NTP server.
Don
Updated firmware to 3.33 and ROS 6.35.4  Working fine on both routers now!
Jim
RB750Gr3, RB750r2, CRS326-24G-2S (in SwitchOS), CSS326-24G-2S, CSS106-5G-1S, RB260GS
Not sure if I beat them in submission, or they beat me into submission


Jim
 
User avatar
donjames
Frequent Visitor
Frequent Visitor
Posts: 87
Joined: Fri Mar 14, 2008 7:07 pm
Location: Henderson, Texas
Contact:

Re: test email not working with gmail

Thu Jul 14, 2016 3:21 pm

I updated one of my routers to 6.34 (from 6.25) this morning, so I will also give it a try...


Sent from my Droid Turbo via Tapatalk, so blame any typos or spelling errors on Android
Hi Jim,
Be sure to update your routerboard firmware.  I have an RB751 that was running firmware version 3.24 and would not send email.  I updated it to firmware version 3.33 and RouterOS version 6.34.5 and now it sends email.  It would also not set the clock with a query to an NTP server.
Don
Updated firmware to 3.33 and ROS 6.35.4  Working fine on both routers now!
Jim
HI Jim,
Glad to hear it.  I have been looking for a way to send email from my RB951 using the gmail smtp server.  Looks like that problem is finally solved.   
Don
 
User avatar
berry2012
newbie
Posts: 38
Joined: Thu Apr 25, 2013 4:07 pm
Location: Nigeria
Contact:

Re: test email not working with gmail

Mon Oct 17, 2016 5:33 pm

Hi,


########Enable logging for the email service so you can see the sending activities
/system logging add topics=e-mail action=memory


######Configure email service
/tool e-mail
set address=74.125.28.108
set port=587
set from=youremail@domain.com
set user=youremail@domain.com
set password=emailpassword

#########Send test email here - this will work
router>> /tool e-mail send to=example@example.com subject="test" body="test"

The commands should look like this.
Screen Shot 2016-10-17 at 3.25.52 PM.png
If you are testing via GUI -Winbox, I have detected and error that if you leace the CC: blank, test mail will not go through. You will get an error of INVALID TO ADDRESS. Be sure to enter an email address there.
See Image
Screen Shot 2016-10-17 at 3.32.19 PM.png
You do not have the required permissions to view the files attached to this post.
--
Regards,
Olawale
MTCNA, MTCTCE, MTCRE, MTCUME

Who is online

Users browsing this forum: MSN [Bot] and 23 guests