Community discussions

MUM Europe 2020
 
inertia
newbie
Topic Author
Posts: 43
Joined: Wed Aug 04, 2010 1:08 pm

Problems With Paypal

Wed Aug 18, 2010 7:22 pm

Hi there,

We are having some problems regarding the paypal payment through user manager. Even though the entries for the paypal website as described on the wiki are in the walled garden, the RB doesn't let the user access the site if the first transaction fails. Second problem is that even when the user can get to the paypal and the payment has been successfully completed, the user cannot login with the login and password they registered on the signup page and it says invalid username or password on the splash page. Although it does show the newly created users in the user section of the User manager. We are using user manager 4.11. Also one more issue is that sometimes in payment status we could see paypal socket error.
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: Problems With Paypal

Wed Aug 18, 2010 9:50 pm

Could be one of a few challenges. Do you have a SSL certificate installed on the User Manager router? If not, insure you uncheck the 'secure response' block on the PayPal section of the customer entry.
 
inertia
newbie
Topic Author
Posts: 43
Joined: Wed Aug 04, 2010 1:08 pm

Re: Problems With Paypal

Thu Aug 19, 2010 12:47 am

I have not got SSL certificates on router. But i have unchecked secure reply from paypal. Still getting same problem...
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: Problems With Paypal

Thu Aug 19, 2010 11:47 am

If you are having problems getting through the walled garden, here is what I use with Authorize.net, adapted to PayPal. I had exactly the same problem with them as you have with PayPal. I found without this, the walled garden will stop allowing the SSL pages through after a couple minutes. I think I have all the ips listed here.

/ip hotspot walled-garden ip
add dst-host=www.paypal.com dst-address=64.4.241.33 action=accept
add dst-host=www.paypal.com dst-address=64.4.241.49 action=accept
add dst-host=www.paypal.com dst-address=66.211.169.2 action=accept
add dst-host=www.paypal.com dst-address=66.211.169.65 action=accept

FYI: I do not see this as a Mikrotik bug. It is the nature of SSL protocol. Once SSL protocol is initiated, the only data available is the ip and port. The URL is in the packet header. The packet header is encrypted. Otherwise, a GET form submission would not be secure. Wouldn't want this unencrypted, would you?
https://www.paypal.com?user=myuser&pwd=mypassword
 
inertia
newbie
Topic Author
Posts: 43
Joined: Wed Aug 04, 2010 1:08 pm

Re: Problems With Paypal

Thu Aug 19, 2010 1:24 pm

Thanks for your help. I could now go to paypal every time. But still having the same issue of Paypal Socket Error. Could anyone please tell me how to resolve it???
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: Problems With Paypal

Thu Aug 19, 2010 1:30 pm

One down, one to go. :D
Do you have anything in the firewall filter that would block the PayPal server from performing a callback to your router?
Are you certain your ISP is not blocking port 80 inbound requests? From a computer behind your router:
http://www.grc.com
Select "Shields Up!" and follow the prompts. If port 80 is not showing open, something is wrong.
 
inertia
newbie
Topic Author
Posts: 43
Joined: Wed Aug 04, 2010 1:08 pm

Re: Problems With Paypal

Thu Aug 19, 2010 1:57 pm

Nothing stopping in firewall. I have checked it from Shields Up and everything seems to be fine.
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: Problems With Paypal

Thu Aug 19, 2010 2:05 pm

At this point, my expertise ends. I use Authorize.Net. The only other thing I can suggest is look at the router log, and see if anything is there about the transaction.

EDIT: Removed remark about walled garden and callback. The walled garden would not be involved in the callback.
 
inertia
newbie
Topic Author
Posts: 43
Joined: Wed Aug 04, 2010 1:08 pm

Re: Problems With Paypal

Thu Aug 19, 2010 2:56 pm

It is nothing there in log regarding the transaction.
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: Problems With Paypal

Thu Aug 19, 2010 5:18 pm

Is there anything in your PayPal account about the transactions? Authorize.Net will send me an email if the server did not complete the callback to my server.
 
inertia
newbie
Topic Author
Posts: 43
Joined: Wed Aug 04, 2010 1:08 pm

Re: Problems With Paypal

Thu Aug 19, 2010 5:51 pm

In my paypal account, it shows me that transaction completed.
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: Problems With Paypal

Thu Aug 19, 2010 6:04 pm

When you check the user in User Manager, do you show the time that was purchased?

You do have the radius section of the hotspot router set up, correct? Insure in "/ip hotspot profile" you have "use-radius=yes" and the /radius section set correctly.
 
inertia
newbie
Topic Author
Posts: 43
Joined: Wed Aug 04, 2010 1:08 pm

Re: Problems With Paypal

Thu Aug 19, 2010 6:14 pm

Yeah i have got everything in the radius server setup properly. Because if a create a user myself, then i am able to login and use internet and in ip/hotspot i could see an active user from Radius sever. I am attaching the snapshot taken from usermanager for payments.
You do not have the required permissions to view the files attached to this post.
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: Problems With Paypal

Thu Aug 19, 2010 6:21 pm

I don't know how PayPal works, but Authorize.Net requires my radius server to be on NTP. If it gets more than about 10 minutes off the correct time, the transactions fail. Set the clock to the correct time and try it again, just to insure that is not it. If you don't have NTP set, the time will not survive a reboot. It goes back to 1970.
 
inertia
newbie
Topic Author
Posts: 43
Joined: Wed Aug 04, 2010 1:08 pm

Re: Problems With Paypal

Thu Aug 19, 2010 7:18 pm

I have changed the time, as well as installed the NTP. But still same problem.
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: Problems With Paypal

Thu Aug 19, 2010 7:31 pm

Last thing from me: you might want to follow these debugging instructions in the wiki:
http://wiki.mikrotik.com/wiki/User_Mana ... l_payments
It may get you results faster if nobody else has an answer for you.
 
bkirchner
just joined
Posts: 2
Joined: Fri Sep 10, 2010 8:36 am

Re: Problems With Paypal

Fri Sep 10, 2010 8:41 am

Inertia,

I am having the same problem with my setup everything seems to work but I dont get a response from paypal I get an Paypal Response Error: Socket Error.

Did you ever get your problem resolved? What was the solution if so?

Thanks.
 
Radiokot
just joined
Posts: 11
Joined: Sun Apr 17, 2011 9:31 pm

Problems With Paypal SOLUTION

Sat Apr 30, 2011 8:05 pm

The solution is:

/ ip firewall mangle add chain=forward protocol=tcp tcp-flags=syn tcp-mss=1453-65535 action=change-mss new-mss=1360 disabled=no

Who is online

Users browsing this forum: Google [Bot] and 42 guests