Community discussions

MikroTik App
 
foudanet
just joined
Topic Author
Posts: 14
Joined: Wed Jun 29, 2011 5:10 pm

pcc+hotspot canot download by 2 line

Mon Jul 04, 2011 2:18 am

i have dell gx110 with 3 ethernet card and i confiegrd that to have pcc + hotspot

this option it is very good without hotspot
i have tow adsl line 2M+2M the same getway & dns
without hotspot i make download by tow line 450k/s

but with hotspot i canot do that
what is the proplem

it is my config
/ip hotspot profile
set default dns-name="" hotspot-address=0.0.0.0 html-directory=hotspot \
    http-proxy=0.0.0.0:0 login-by=http-chap name=default rate-limit="" \
    smtp-server=0.0.0.0 split-user-domain=no use-radius=no
add dns-name=www.net.com hotspot-address=10.1.1.1 html-directory=hotspot \
    http-proxy=0.0.0.0:0 login-by=http-chap name=hsprof1 rate-limit="" \
    smtp-server=0.0.0.0 split-user-domain=no use-radius=no
/ip hotspot user profile
set default advertise=no idle-timeout=none keepalive-timeout=1m name=default \
    open-status-page=always rate-limit=64K/200K shared-users=1 \
    status-autorefresh=1m transparent-proxy=yes
add advertise=yes advertise-interval=1s,5s advertise-timeout=immediately \
    advertise-url=http://10.1.1.1/radvert.html idle-timeout=none \
    keepalive-timeout=2m name="net cut" open-status-page=http-login \
    session-timeout=5m shared-users=unlimited status-autorefresh=1m \
    transparent-proxy=yes
add advertise=no idle-timeout=none keepalive-timeout=2m name=uprof1 \
    open-status-page=always shared-users=1 status-autorefresh=1m \
    transparent-proxy=yes
add advertise=no idle-timeout=none keepalive-timeout=1m name=1M \
    open-status-page=always rate-limit=40K/800K shared-users=1 \
    status-autorefresh=1m transparent-proxy=yes


/ip pool
add name=dhcp-pool-1 ranges=10.1.1.2-10.1.1.254
/ip dhcp-server
add address-pool=dhcp-pool-1 authoritative=after-2sec-delay bootp-support=\
    static disabled=no interface="hotspot\r\
    \n" lease-time=3d name=dhcp1


/ip address
add address=10.1.1.1/24 broadcast=10.1.1.255 comment="added by setup" \
    disabled=no interface="hotspot\r\
    \n" network=10.1.1.0
add address=15.5.5.5/32 broadcast=15.5.5.5 comment="" disabled=no interface=\
    "hotspot\r\
    \n" network=15.5.5.5
add address=10.5.5.2/24 broadcast=10.5.5.255 comment="" disabled=no \
    interface=wan2 network=10.5.5.0
add address=10.4.4.2/24 broadcast=10.4.4.255 comment="" disabled=no \
    interface=wan1 network=10.4.4.0



/ip dns
set allow-remote-requests=yes cache-max-ttl=1w cache-size=2048KiB \
    max-udp-packet-size=512 primary-dns=4.2.2.6 secondary-dns=4.2.2.3


/ip firewall mangle
add action=accept chain=prerouting comment="" disabled=no dst-address=\
    10.4.4.1 in-interface="hotspot\r\
    \n"
add action=accept chain=prerouting comment="" disabled=no dst-address=\
    10.5.5.1 in-interface="hotspot\r\
    \n"
add action=mark-connection chain=input comment=NET1 disabled=no in-interface=\
    wan1 new-connection-mark=wan1_conn passthrough=yes
add action=mark-connection chain=output comment="" disabled=no dst-port=80 \
    new-connection-mark=wan1_conn passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:2/0 protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local dst-port=80 in-interface=wan1 \
    new-connection-mark=wan1_conn passthrough=yes per-connection-classifier=\
    both-addresses:2/0 protocol=tcp
add action=mark-routing chain=prerouting comment="" connection-mark=wan1_conn \
    disabled=no in-interface=wan1 new-routing-mark=to_wan1 passthrough=yes
add action=mark-routing chain=output comment="" connection-mark=wan1_conn \
    disabled=no new-routing-mark=to_wan1 passthrough=yes
add action=mark-connection chain=input comment=NET2 disabled=no in-interface=\
    wan2 new-connection-mark=wan2_conn passthrough=yes
add action=mark-connection chain=output comment="" disabled=no dst-port=80 \
    hotspot=auth new-connection-mark=wan2_conn passthrough=yes \
    per-connection-classifier=both-addresses-and-ports:2/1 protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local dst-port=80 in-interface=wan2 \
    new-connection-mark=wan2_conn passthrough=yes per-connection-classifier=\
    both-addresses:2/1 protocol=tcp
add action=mark-routing chain=prerouting comment="" connection-mark=wan2_conn \
    disabled=no in-interface=wan2 new-routing-mark=to_wan2 passthrough=yes
add action=mark-routing chain=output comment="" connection-mark=wan2_conn \
    disabled=no new-routing-mark=to_wan2 passthrough=yes


/ip firewall nat
add action=passthrough chain=unused-hs-chain comment=\
    "place hotspot rules here" disabled=yes
add action=masquerade chain=srcnat comment="masquerade hotspot network" \
    disabled=no src-address=10.1.1.0/24
add action=masquerade chain=srcnat comment="" disabled=no out-interface=wan1
add action=masquerade chain=srcnat comment="" disabled=no out-interface=wan2



/ip route
add check-gateway=ping comment="" disabled=no distance=2 dst-address=\
    0.0.0.0/0 gateway=10.5.5.1 routing-mark=to_wan2 scope=30 target-scope=10
add check-gateway=ping comment="" disabled=no distance=2 dst-address=\
    0.0.0.0/0 gateway=10.5.5.1 scope=30 target-scope=10
add check-gateway=ping comment="" disabled=no distance=1 dst-address=\
    0.0.0.0/0 gateway=10.4.4.1 routing-mark=to_wan1 scope=30 target-scope=10
add check-gateway=ping comment="" disabled=no distance=1 dst-address=\
    0.0.0.0/0 gateway=10.4.4.1 scope=30 target-scope=10


 
foudanet
just joined
Topic Author
Posts: 14
Joined: Wed Jun 29, 2011 5:10 pm

Re: pcc+hotspot canot download by 2 line

Mon Jul 04, 2011 12:18 pm

can i get help to this Problem
 
fewi
Forum Guru
Forum Guru
Posts: 7734
Joined: Tue Aug 11, 2009 3:19 am

Re: pcc+hotspot canot download by 2 line

Mon Jul 04, 2011 8:15 pm

Search the forums. Hotspots don't work out of the box with PCC. Several threads contain workarounds. On the same box the workarounds are fairly complicated. The simplest option is to buy a 450G or comparable router and use it for PCC, and to put the Hotspot server behind it. Then configure PCC standalone on the 450G, the Hotspot standalone on the server, and use the 450G as the server's default gateway (routed, no NAT).
Specific answers require specific questions. When in doubt, post the output of "/ip address print detail", "/ip route print detail", "/interface print detail", "/ip firewall export", and an accurate network diagram.
 
foudanet
just joined
Topic Author
Posts: 14
Joined: Wed Jun 29, 2011 5:10 pm

Re: pcc+hotspot canot download by 2 line

Tue Jul 05, 2011 2:15 am

thank you
i will get mor pc to do that

Who is online

Users browsing this forum: No registered users and 61 guests