Community discussions

MikroTik App
 
User avatar
pedzopenguin
just joined
Topic Author
Posts: 15
Joined: Thu Mar 10, 2011 4:42 am
Location: Belgrade, Serbia

Janis Megis "Qos Best Practise" router configuration

Mon Jan 02, 2012 9:17 am

Wouldn't it be more convenient for everyone that Janis Megis has included actual (complete) router configuration at the end of his presentation (http://mum.mikrotik.com/presentations/C ... _Megis.pdf)?! :)
He only gave examples for client bandwidth limitations (page 26 and 28 of his presentation) using PCQ and QT.

I am a beginner learning QoS and after few weeks of studying this subject my head hurts really bad :(
I've also watched video several times and it helped a lot at understanding things!
But the more I learn (find out) more questions pop out...

Thanks to fewi I've implemented "Initial Configuration" and now I want to implement QoS (traffic prioritization) with even traffic distribution among clients (pcq-rate=0) for both upload and download.

Could PLEASE someone write down the COMPLETE configuration using Megis' example including packet markings in Mangle Prerouting and traffic prioritization at Global-In queue of packet flow diagram?

So far I have found following threads very educational if someone is searching the forum for same information:
QoS nat limiting with pcq and QT
Working QoS configuration
Bandwidth Managment and Queues
Manual:Packet Flow
Manual:Queues - PCQ Examples
Manual:HTB

In following days I will try to manage that myself using things I've learned so far... but - I ask again - wouldn't it be more easier if Megis gave complete router configuration on his example...
I've seen things you people wouldn't believe...
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24645
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Janis Megis "Qos Best Practise" router configuration

Mon Jan 02, 2012 9:52 am

the presentation contains examples. it doesn't have complete config for everyone, because everyone needs a different thing to prioritize, and there is no universal solution to copy/paste. watch the tiktube.com video presentation, read the slides, and if you have a general understanding of RouterOS, you should be able to understand how to make this.
No answer to your question? How to write posts
 
User avatar
pedzopenguin
just joined
Topic Author
Posts: 15
Joined: Thu Mar 10, 2011 4:42 am
Location: Belgrade, Serbia

Re: Janis Megis "Qos Best Practise" router configuration

Mon Jan 02, 2012 10:33 am

I did that...
I just stated that learning this stuff and it would be a lot more easier if he included complete setup of his example (using rules and conditions he gave as an example). I agree that everyone of us have different needs.

What I'm saying is that using commands on how to seperate http downloads from http requests and so on is hard when you start learning RouterOS possibilities.
Everything is documented and well, I must add, just that configuration would make things a lot easier to understand and would give guides on what you have to learn in more depth.
I've seen things you people wouldn't believe...
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1734
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: Janis Megis "Qos Best Practise" router configuration

Mon Jan 02, 2012 11:01 am

Information from slide 34 shows that mangle chain is prerouting
slide 35 gives you all options that you need to put into the rule.

http long conection rules should look like this:

/ip firewall mangle
add action=mark-packet chain=prerouting in-interface=Local protocol=tcp dst-port=80 \
connection-bytes=500000-0 new-packet-mark=Download_services comment="HTTP Upload"
add action=mark-packet chain=prerouting in-interface=Public protocol=tcp src-port=80 \
connection-bytes=500000-0 new-packet-mark=Download_services comment="HTTP Download"

As you can see transferring table in to CLI commands is as easy as copy-paste.
About queues - slide 34 shows where and slide 36 give details how. together with HTB topic in manual it should be also as easy as copy-paste.
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
rado3105
Member
Member
Posts: 493
Joined: Sat Jan 12, 2008 11:45 pm

Re: Janis Megis "Qos Best Practise" router configuration

Mon Sep 17, 2012 2:50 pm

Double QoS
It is possible to mark and shape traffic twice in
the same router:
Mangle chain Prerouting – for first marking
Global-in HTB – for first shaping
Mangle chain Forward or Postrouting for second
marking
Global-out or Out-interface HTB for second marking
Double QoS is only possible with Queue Tree


What does this exactly mean?
I still dont get difference between forward and pre/postrouting. Can anybody explain?


http://www.ae.iitm.ac.in/pipermail/ilug ... 18702.html
http://www.linuxhomenetworking.com/wiki ... g_iptables
 
forne
Frequent Visitor
Frequent Visitor
Posts: 65
Joined: Tue Feb 15, 2011 3:18 pm

Re: Janis Megis "Qos Best Practise" router configuration

Mon Sep 17, 2012 5:25 pm

rado3105,
this page may help you: http://wiki.mikrotik.com/wiki/Manual:Packet_Flow

Who is online

Users browsing this forum: anav, igaunis, ramibb and 30 guests