Community discussions

MUM Europe 2020
 
phrozenpenguin
newbie
Topic Author
Posts: 49
Joined: Wed Nov 23, 2011 4:13 am

RB751U-2HnD crashing when using Skype

Sun Jan 15, 2012 7:01 am

I am using a RB751U-2HnD and have a problem where the router regularly restarts when using Skype from a machine on the LAN. I usually use Skype on a wireless connection from a Macbook. This is very frustrating but I must be doing something wrong as I cannot believe Mikrotik would fail at Skype! What happens is Skype call drops, no access to the web, then network comes back up (or I plug ethernet in) and when I login to Winbox the uptime corresponds to the recent crash.

I am running RouterOS 5.11 and believe I have enabled uPNP. Below shows the usual outputs, if any more would be helpful please let me know. It may be something to do with MTU or MSS (there are mangle rules to alter MSS than don't seem to print from command line?

I don't fully understand how to setup logging so the MT won't loose records when restarting.

Any advice very much appreciated.

Crude Network Diagram
ADSL --[telephone]-- MODEM ----[cat5]----Mikrotik-----LAN (+ Wifi)
/ip address print detail
Flags: X - disabled, I - invalid, D - dynamic
0 ;;; local LAN
address=192.168.88.1/24 network=192.168.88.0 interface=bridge-local
actual-interface=bridge-local

1 D address=192.168.1.10/24 network=192.168.1.0 interface=ether1-gateway
actual-interface=ether1-gateway

2 D address=111.xxx.xxx.xxx/32 network=111.xxx.xxx.xxx interface=pppoe-out1
actual-interface=pppoe-out1
/ip route print detail
Flags: X - disabled, A - active, D - dynamic,
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
B - blackhole, U - unreachable, P - prohibit
0 ADS dst-address=0.0.0.0/0 gateway=111..xxx.xxx.xxx
gateway-status=111.xxx.xxx.xxx reachable pppoe-out1 distance=1 scope=30
target-scope=10

1 ADC dst-address=111..xxx.xxx.xxx/32 pref-src=111.69.245.4 gateway=pppoe-out1
gateway-status=pppoe-out1 reachable distance=0 scope=10

2 ADC dst-address=192.168.1.0/24 pref-src=192.168.1.10 gateway=ether1-gateway
gateway-status=ether1-gateway reachable distance=0 scope=10

3 ADC dst-address=192.168.88.0/24 pref-src=192.168.88.1 gateway=bridge-local
gateway-status=bridge-local reachable distance=0 scope=10
/interface print detail
Flags: D - dynamic, X - disabled, R - running, S - slave
0 R name="wlan1" type="wlan" mtu=1500 l2mtu=2290

1 R name="ether1-gateway" type="ether" mtu=1500 l2mtu=1600 max-l2mtu=4076

2 R name="ether2-master-local" type="ether" mtu=1500 l2mtu=1598 max-l2mtu=2028

3 R name="ether3-slave-local" type="ether" mtu=1500 l2mtu=1598 max-l2mtu=2028

4 name="ether4-slave-local" type="ether" mtu=1500 l2mtu=1598 max-l2mtu=2028

5 name="ether5-alone" type="ether" mtu=1500 l2mtu=1598 max-l2mtu=2028

6 R name="bridge-local" type="bridge" mtu=1500 l2mtu=1598

7 R name="pppoe-out1" type="pppoe-out" mtu=1492
/ip firewall export
# jan/15/2012 17:51:02 by RouterOS 5.11
# software id = XXXX-XXXX
#
/ip firewall connection tracking
set enabled=yes generic-timeout=10m icmp-timeout=10s tcp-close-timeout=10s \
tcp-close-wait-timeout=10s tcp-established-timeout=1d tcp-fin-wait-timeout=\
10s tcp-last-ack-timeout=10s tcp-syn-received-timeout=5s \
tcp-syn-sent-timeout=5s tcp-syncookie=no tcp-time-wait-timeout=10s \
udp-stream-timeout=3m udp-timeout=10s
/ip firewall filter
add action=accept chain=forward disabled=no dst-address=192.168.1.1 \
in-interface=bridge-local out-interface=ether1-gateway
add action=accept chain=output comment=PPTP_GRE disabled=no protocol=gre
add action=accept chain=input comment=PPTP_GRE disabled=no protocol=gre
add action=accept chain=input comment="default configuration - PPTP" disabled=\
no dst-port=1723 in-interface=pppoe-out1 protocol=tcp
add action=accept chain=input comment="default configuration" disabled=no \
protocol=icmp
add action=accept chain=input comment="default configuration" connection-state=\
established disabled=no
add action=accept chain=input comment=\
"This is to enable ODMON SNMP checking remotely." disabled=no dst-port=161 \
protocol=udp src-address=188.124.160.10
add action=accept chain=input comment="default configuration" connection-state=\
related disabled=no
add action=drop chain=input comment="default configuration" disabled=no \
in-interface=pppoe-out1
/ip firewall mangle
add action=mark-packet chain=forward comment=VoIP disabled=no new-packet-mark=\
VoIP passthrough=no src-address=192.168.88.200
add action=mark-packet chain=forward comment=VoIP disabled=no dst-address=\
192.168.88.200 new-packet-mark=VoIP passthrough=no
/ip firewall nat
add action=redirect chain=dstnat comment="For proxy" disabled=yes dst-port=80 \
protocol=tcp to-ports=8080
add action=masquerade chain=srcnat comment="default configuration" disabled=no \
out-interface=pppoe-out1
add action=masquerade chain=srcnat comment=\
"This is required to access Vigor modem on 192.168.1.1" disabled=no \
out-interface=ether1-gateway
/ip firewall service-port
set ftp disabled=no ports=21
set tftp disabled=no ports=69
set irc disabled=no ports=6667
set h323 disabled=no
set sip disabled=yes ports=5060,5061,50600 sip-direct-media=yes
set pptp disabled=no
/ip upnp print
enabled: yes
allow-disable-external-interface: yes
show-dummy-rule: yes
 
User avatar
cbrown
Trainer
Trainer
Posts: 1840
Joined: Thu Oct 14, 2010 8:57 pm
Contact:

RB751U-2HnD crashing when using Skype

Sun Jan 15, 2012 4:23 pm

I had the same issue when pushing any amount of data over the 751. What I had done is left the same power supply in place that came with the 750 which is 12V - 500mA and the board was not getting enough power. The 751 comes with a 12V -1A but I did not have one and used a 24V instead. I am not sure if it is recommended to use a 24V with the 751 but it has been working for me. Maybe someone else could elaborate on that.
C.Brown

cbrown[at]ravenrocknetworks.com
MTCNA - MTCRE - MTCWE - MTCTCE
MTCSE - TRAINER-0179
 
phrozenpenguin
newbie
Topic Author
Posts: 49
Joined: Wed Nov 23, 2011 4:13 am

Re: RB751U-2HnD crashing when using Skype

Sun Jan 15, 2012 9:29 pm

cbrown - thanks for the idea.

I was using the 24v 0.8amp that was supplied. I will try with a 12v 1.25amp I have and see if that improves things. I bought from a reputable reseller so would hope they were supplying decent power supplies.

If anyone else has other ideas please add them.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3428
Joined: Mon May 31, 2004 2:55 pm

Re: RB751U-2HnD crashing when using Skype

Mon Jan 16, 2012 10:04 am

you have only one device that is experiencing such problems?
What routerboard firmware you are using now?
Can you tell us the best way how to reproduce this reboot using the skype - what should be do (step by step)?
 
phrozenpenguin
newbie
Topic Author
Posts: 49
Joined: Wed Nov 23, 2011 4:13 am

Re: RB751U-2HnD crashing when using Skype

Mon Jan 16, 2012 10:46 am

This is my one and only Mikrotik device - the first one I have ever used. I am trialling in at home in preparation for a deployment of 16+ and a 450G for work - but if I can't sort this than that deployment won't happen :-(

I am using RouterOS 5.11, but have upgrade from 5.9 and 5.10 - all experience the same problem.

The best way to reproduce it is to use Skype - voice or video call. I am usually calling from Australasia to Europe. I'm using a Macbook (Skype version 5.3), and travel with it - so sometime Skype would be open and logged in when I connect, and sometime Skype would startup when already connected. I note this as it may have something to do with uPNP access? It appears at random times but has been happening over a period of weeks, and ever since I had the device. It works with another Mac as well. I don't have a Windows box to test.

I am wondering if I can put any logging (that will save to USB or survive a reboot) or watch anything whilst on a call (e.g. NAT tables etc?). The CPU seems to rise, but not be pegged at 100%.

Any ideas?
 
uldis
MikroTik Support
MikroTik Support
Posts: 3428
Joined: Mon May 31, 2004 2:55 pm

Re: RB751U-2HnD crashing when using Skype

Mon Jan 16, 2012 1:33 pm

What do you see in the 'system routerboard' section - what bios version? Have you tried to disable the uPNP, does it still crash?
 
phrozenpenguin
newbie
Topic Author
Posts: 49
Joined: Wed Nov 23, 2011 4:13 am

Re: RB751U-2HnD crashing when using Skype

Mon Jan 16, 2012 9:31 pm

Current firmware is 2.36, and upgrade firmware is 2.37 - the change log only indicates a couple of unrelated things. Do you recommend I upgrade?

Potentially useful - in System > Health, I get an empty box.

uPNP was disabled by default, and I had the problem. I enabled it after reading that Skype would need it otherwise it could/would fill the memory up due to a large number of connections.
 
phrozenpenguin
newbie
Topic Author
Posts: 49
Joined: Wed Nov 23, 2011 4:13 am

Re: RB751U-2HnD crashing when using Skype

Fri Jan 20, 2012 11:32 pm

I have not been using this device much, but can confirm the issue still happens with the different 12v 1.25a PSU, so I do not think PSU draw is the issue. It doesn't hang doing anything else - including extensive down/up loading, considerably more machines etc. But just Skype on a single machine forces a crash :-(

My next steps are to upgrade the firmware, try without uPNP, and then I will wipe the config and start from scratch, building up a basic setup and making sure I understand how everything works.

I am still very much open to advice and suggestions :-)
Last edited by phrozenpenguin on Sun Jan 22, 2012 12:10 am, edited 1 time in total.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3428
Joined: Mon May 31, 2004 2:55 pm

Re: RB751U-2HnD crashing when using Skype

Sat Jan 21, 2012 11:48 am

upgrade to RoutrerOS v5.12 and upgrade the bios to v2.38
Do you have some eoip or pptp tunnels?
 
phrozenpenguin
newbie
Topic Author
Posts: 49
Joined: Wed Nov 23, 2011 4:13 am

Re: RB751U-2HnD crashing when using Skype

Sun Jan 22, 2012 12:12 am

upgrade to RoutrerOS v5.12 and upgrade the bios to v2.38
I have now upgraded.
Do you have some eoip or pptp tunnels?
One PPTP VPN access for when I am offsite - rarely used.
 
phrozenpenguin
newbie
Topic Author
Posts: 49
Joined: Wed Nov 23, 2011 4:13 am

Re: RB751U-2HnD crashing when using Skype

Mon Jan 23, 2012 12:15 am

I upgrade to latest firmware and routeros as above.
I've upgraded to a 12v 2A PSU incase it was this.
I have simplified my setup - a PPPoE WAN connection, DHCP server for ethernet and Wifi, SNMP for monitoring.
I still have random reboots. When it comes back up my log file says:
jan/02/1970 12:00:17 system,error,critical router was rebooted without proper shutdown (cause 1)
This is getting to the point where the device is unusable and I do not know what else I can try to sort. It I have tried two different WAN connections in two different locations, and have the same issues. Consumer (D-Link and Netgear) have no problems in either location.
Any other ideas?
 
User avatar
cbrown
Trainer
Trainer
Posts: 1840
Joined: Thu Oct 14, 2010 8:57 pm
Contact:

RB751U-2HnD crashing when using Skype

Mon Jan 23, 2012 12:36 am

I wish I knew what to tell you. Have you tried a 24V 1a PSU? Since I put that on my 751 the reboot issue disappeared. But I am also no electrical engineer. :)
C.Brown

cbrown[at]ravenrocknetworks.com
MTCNA - MTCRE - MTCWE - MTCTCE
MTCSE - TRAINER-0179
 
uldis
MikroTik Support
MikroTik Support
Posts: 3428
Joined: Mon May 31, 2004 2:55 pm

Re: RB751U-2HnD crashing when using Skype

Mon Jan 23, 2012 1:31 pm

I wish I knew what to tell you. Have you tried a 24V 1a PSU? Since I put that on my 751 the reboot issue disappeared. But I am also no electrical engineer. :)
This is a diffrent issue, not related to this topic. Changing the PSU adapter is only a temporary fix, you need to repair the device, contact seller for RMA repair.
 
lostar
just joined
Posts: 8
Joined: Sun Jan 15, 2012 1:10 pm

Re: RB751U-2HnD crashing when using Skype

Sat Jan 28, 2012 9:37 pm

I also have router reboots while using Skype.
[@MikroTik] /system routerboard> p
       routerboard: yes
             model: 751U-2HnD
     serial-number: 2C4F0139F0A1
  current-firmware: 2.37
  upgrade-firmware: 2.37
I've tried to investigate this issues, it looks like flash process consumes a lot of CPU (80-100%). Router almost do not respond on other requests (ssh login, web login and so on) so it is hard to watch this situation in live.

What kind of information could be useful for debugging this issue? It is very annoying =(
 
phrozenpenguin
newbie
Topic Author
Posts: 49
Joined: Wed Nov 23, 2011 4:13 am

Re: RB751U-2HnD crashing when using Skype

Sun Jan 29, 2012 10:13 am

lostar, sorry to hear you are having the same problem. I am being told to change the power adaptor - but I have tried three and it has not fixed the issue. What PSU are you using? Do you use wireless devices, and if so what? I use macbooks, iPad, iPhone and Android devices. I'm wondering if there is a compatibility issue...
Last edited by phrozenpenguin on Tue Jan 31, 2012 9:43 am, edited 1 time in total.
 
lostar
just joined
Posts: 8
Joined: Sun Jan 15, 2012 1:10 pm

Re: RB751U-2HnD crashing when using Skype

Sun Jan 29, 2012 8:44 pm

I'm using PSU 12V, 1A (bundled with RB751U).
In my network a lot of apple devices (MacBookAir, MacBook Pro, iPhone, iPad) and some Android based devices. Last time Skype was running on MacBook Air - wireless connection was used.
Router establish l2tp connection with my ISP for internet access.
 
phrozenpenguin
newbie
Topic Author
Posts: 49
Joined: Wed Nov 23, 2011 4:13 am

Re: RB751U-2HnD crashing when using Skype

Tue Jan 31, 2012 9:48 am

I'm using PSU 12V, 1A (bundled with RB751U).
In my network a lot of apple devices (MacBookAir, MacBook Pro, iPhone, iPad) and some Android based devices. Last time Skype was running on MacBook Air - wireless connection was used.
Router establish l2tp connection with my ISP for internet access.
Interesting - I have a similar setup, and a Macbook Air has problems (along with the Macbook, and a couple of Android devices will be connected at the same time). The 'flash' process jumps up to high CPU usage when I use Skype - and this process is "cpu usage when writing to NAND" according to http://wiki.mikrotik.com/wiki/Manual:Tools/Profiler. I'm not sure why Skype would cause the device to write to NAND? Does anybody have more ideas apart from a PSU? I have had the same problem using the (same) device with another config and a different type of WAN connection....

I am willing to explore other options e.g. wifi config errors etc - but the problem manifests itself when using Skype - everything else is stable. Very frustrating!
 
phrozenpenguin
newbie
Topic Author
Posts: 49
Joined: Wed Nov 23, 2011 4:13 am

Re: RB751U-2HnD crashing when using Skype

Tue Jan 31, 2012 9:27 pm

I just did some more testing:

- Running Winbox on Macbook connected to Wifi
- Skype video conversation on Macbook Air connected to Wifi
- Winbox profiler shows 'flash' process jumping to ~80% (CPU at 100%)
- Winbox disconnects
- Macbook and Android phone are not able to browse the web / Winbox will not connect / Webfig will not load
- In this instance Skype call did not drop, but all other connectivity did.
- When Skype call finished, other devices could browse the web again.

At start of Skype call, sectors written since reboot was 2,536. After 30 minutes of Skype call, this was 4,112. Does this sound correct?
 
mtmx80
Frequent Visitor
Frequent Visitor
Posts: 87
Joined: Wed Mar 16, 2011 11:12 pm

Re: RB751U-2HnD crashing when using Skype

Mon Feb 06, 2012 3:51 am

+1 Same here Skype on wireless with ROS 5.12 and FW 2.38. There is no tunnels configured.
I also have router reboots while using Skype.
[@MikroTik] /system routerboard> p
       routerboard: yes
             model: 751U-2HnD
     serial-number: 2C4F0139F0A1
  current-firmware: 2.37
  upgrade-firmware: 2.37
I've tried to investigate this issues, it looks like flash process consumes a lot of CPU (80-100%). Router almost do not respond on other requests (ssh login, web login and so on) so it is hard to watch this situation in live.

What kind of information could be useful for debugging this issue? It is very annoying =(
 
phrozenpenguin
newbie
Topic Author
Posts: 49
Joined: Wed Nov 23, 2011 4:13 am

Re: RB751U-2HnD crashing when using Skype

Mon Feb 06, 2012 4:43 am

I have narrowed this down to the wireless interface and posted my findings here: http://forum.mikrotik.com/viewtopic.php ... 3&p=302265
I have tried both 12v and 24v PSU so I don't believe that is the issue.
 
lostar
just joined
Posts: 8
Joined: Sun Jan 15, 2012 1:10 pm

Re: RB751U-2HnD crashing when using Skype

Sat Feb 18, 2012 10:10 pm

I've got .rif file and sent it to support. Waiting for response...
 
phrozenpenguin
newbie
Topic Author
Posts: 49
Joined: Wed Nov 23, 2011 4:13 am

Re: RB751U-2HnD crashing when using Skype

Sun Feb 19, 2012 9:04 pm

I've got .rif file and sent it to support. Waiting for response...
Do please keep us updated. I was spending so much time on this fault I just bought a separate wireless access point which worked fine.
 
lostar
just joined
Posts: 8
Joined: Sun Jan 15, 2012 1:10 pm

RB751U-2HnD crashing when using Skype

Wed Feb 29, 2012 1:09 pm

Looks like 5.14 solves this issue for me. But I'm not sure — need more time.
 
lostar
just joined
Posts: 8
Joined: Sun Jan 15, 2012 1:10 pm

RB751U-2HnD crashing when using Skype

Sun Mar 04, 2012 8:28 pm

It works slightly better but problem still here...
 
krakenant
Member Candidate
Member Candidate
Posts: 136
Joined: Sat Feb 06, 2010 6:32 am

Re: RB751U-2HnD crashing when using Skype

Sun Apr 01, 2012 1:39 am

Any word back on this? I just got my first report of it and we are schedule to roll out more RB751s to our customers.
 
lostar
just joined
Posts: 8
Joined: Sun Jan 15, 2012 1:10 pm

RB751U-2HnD crashing when using Skype

Sun Apr 01, 2012 1:59 am

I've switched to other wifi AP hardware. Hope Mikrotik will fix it issue in the following update.
 
jeflogic
just joined
Posts: 2
Joined: Tue May 22, 2012 6:25 pm

Re: RB751U-2HnD crashing when using Skype

Tue May 22, 2012 6:44 pm

I have not read the entire conversation. Just in case this information helps...

I do know that the Apple.com site has stated at one point that they have known compatibility issue with "N" routers. I have accessed all RouterBoard units I have deployed and changed the wireless setting from B/G/N to B/G only. NO one has noticed the difference and not one call for Wireless cutting out.
 
phrozenpenguin
newbie
Topic Author
Posts: 49
Joined: Wed Nov 23, 2011 4:13 am

Re: RB751U-2HnD crashing when using Skype

Tue Jun 05, 2012 12:32 pm

Just an update. I dug my device out, updated to v5.17 and started using it. No reboots as of yet, but Skype or Dropbox use on one machine makes the network unusable elsewhere. Winbox or SSH won't connect to check usage. No new clients can connect via wifi.

I'm going to try dropping to B/G, but that is a bit of a waste of buying 'n' gear!

Still not impressed :(
 
User avatar
dreik
just joined
Posts: 1
Joined: Mon Sep 17, 2012 10:21 pm
Contact:

Re: RB751U-2HnD crashing when using Skype

Mon Sep 17, 2012 10:28 pm

I also have router reboots while using Skype.
I've tried to investigate this issues, it looks like flash process consumes a lot of CPU (80-100%). Router almost do not respond on other requests (ssh login, web login and so on) so it is hard to watch this situation in live.

What kind of information could be useful for debugging this issue? It is very annoying =(
I've the same issue on my
[@home] /system routerboard> p
       routerboard: yes
             model: 751U-2HnD
     serial-number: 2C4F013E9321
  current-firmware: 2.41
  upgrade-firmware: 2.41
Once i'm starting uTorrent - device is going "down" in a few.
Thanks,
dreik
 
User avatar
HumanDamned
newbie
Posts: 40
Joined: Wed Jun 20, 2012 11:21 am
Location: Tallinn

Re: RB751U-2HnD crashing when using Skype

Thu Sep 27, 2012 9:58 pm

+1

RB751U-2HnD crashing when using uTorrent 3.2

I have 1PC and 1 server with uTorrent installed... by default they are working good, but when I try to upload something from PC to Server Mikrotik crushes...then the LAN connection on both machines is lost....upload process stops. After few seconds mikrotik reboots and connection is up again.
The profile shows only 98.5% IDLE... flash does not consume anything.
CPU load is about 2-5%.
Also using PPPoE Client for WAN connection.
The Log shows me - system,error,critical router was rebooted without proper shutdown.

When I close uTorrent and try to upload files again - router does not crush.
Please help!
UPD1: Strange, but router crushes even if uTorrent is just running, but not downloading nor seeding anything.
UPD2: I've tryed to disable UPnP, NAT-PMP and DHT options in uTorrent. The router still crushes, but the upload process does not stop and I do not loose the connection. I also tried to ping google at the same time and in the moment of "crush" I've lost 4 pakets and before and after that time increaes to 2000ms.
UPD3: Tried on factory default settings and RB751U-2HnD stills gives me an Error: router has been disconnected.
UPD4: Tried to simply upload and download via Mikrotik at the same time, while pinging Mikrotik. The download speed drops from 1mb/s to 30kb/s...and Mikrotik starts lagging.... but it does not restart.
 routerboard: yes
 model: 751U-2HnD
 serial-number: 2FF101267B71
 current-firmware: 2.41
 upgrade-firmware: 2.41
You do not have the required permissions to view the files attached to this post.
Last edited by HumanDamned on Fri Sep 28, 2012 12:13 pm, edited 7 times in total.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3428
Joined: Mon May 31, 2004 2:55 pm

Re: RB751U-2HnD crashing when using Skype

Thu Sep 27, 2012 11:28 pm

what does the log file say about the reboot?
What RouterOS version you are using?
 
User avatar
HumanDamned
newbie
Posts: 40
Joined: Wed Jun 20, 2012 11:21 am
Location: Tallinn

Re: RB751U-2HnD crashing when using Skype

Thu Sep 27, 2012 11:36 pm

The Log shows me - system,error,critical router was rebooted without proper shutdown.
I'm using v5.20
 #   NAME                    VERSION                    SCHEDULED              
 0   routeros-mipsbe         5.20                                              
 1 X ipv6                     5.20                                              
 2   mpls                     5.20                                              
 3   system                 5.20                                              
 4   wireless                5.20                                              
 5   routerboard           5.20                                              
 6   security                5.20                                              
 7   advanced-tools      5.20                                              
 8   hotspot                5.20                                              
 9   ppp                      5.20                                              
10   routing                 5.20                                              
11   dhcp                    5.20   
Is there any way to determine what exactly causes the reboot?
 
User avatar
HumanDamned
newbie
Posts: 40
Joined: Wed Jun 20, 2012 11:21 am
Location: Tallinn

Re: RB751U-2HnD crashing when using Skype

Fri Sep 28, 2012 3:00 pm

Got a reply from mikrotik support:
Kernel crashes on the router. When it happens you need to power cycle it to get it
in working order. We will see what we can do to fix this problem.
 
User avatar
HumanDamned
newbie
Posts: 40
Joined: Wed Jun 20, 2012 11:21 am
Location: Tallinn

Re: RB751U-2HnD crashing when using Skype

Thu Oct 18, 2012 5:17 pm

Updated to Version 5.21 and still have the same problem =(
Please help!
 
mangup
just joined
Posts: 3
Joined: Tue Nov 29, 2005 1:33 pm

Re: RB751U-2HnD crashing when using Skype

Tue Nov 06, 2012 12:53 am

I have same problem,
brand new RB, updated to 5.21 and router firmware 3.0
:(
 
User avatar
Pearse
just joined
Posts: 4
Joined: Wed Feb 16, 2011 5:33 pm

same issue here

Sat Nov 10, 2012 4:26 pm

We have over 600 mikrotik devices Power is very stable 24v UPS on every site. We have the same issue on an OmniTik, RB411GL and a few RB433AH rebooting. When there is high bandwidth over 20mbps or so the router will might reboot. We had to downgrade from 5.21 as the routers became even more unstable with frequent lockups and sometimes rebooting every minute or so. Sometimes the devices will lockup and are not visible in ip neighbours, It is still possible to ping the Ethernet interface, wireless clients (RBsextant’s) stay associated but they cant ping the AP nor can you mac-telnet over the wireless. Winbox, mac-telnet wont work but SSH does after 10 or so attempts and we can reboot.
 
kurtkraut
Frequent Visitor
Frequent Visitor
Posts: 73
Joined: Wed Feb 15, 2012 2:55 am

Re: RB751U-2HnD crashing when using Skype

Sat Nov 10, 2012 6:15 pm

Hi,


One question: if you use the Traffic Generator/Simulator tool Mikrotik has to generate an intensive network usage, does the crashing/freezing sympton also occurs?
 
User avatar
HumanDamned
newbie
Posts: 40
Joined: Wed Jun 20, 2012 11:21 am
Location: Tallinn

Re: RB751U-2HnD crashing when using Skype

Mon Dec 10, 2012 10:05 pm

I've send my RB to RMA...so I changed it to RB751G. My problem was described as: "reboots on heavy traffic load after a while".
The reason for such behaviour is unknown.
 
elektronb
just joined
Posts: 7
Joined: Fri Mar 02, 2012 3:53 pm

Re: RB751U-2HnD crashing when using Skype

Tue Mar 26, 2013 2:49 pm

i have same problem :(

RB751U-2HnD 5.24
firemware 3.02


HELP!

Support replay:
>> You have configured both User Manager and also Web proxy on this device. The
RB751U
>> is a home class device, it can't handle these server-level type of services.
>>
>> If you must have these services, I suggest you to use a device with more RAM and
>> more CPU power, like the http://routerboard.com/RB2011UAS-2HnD-IN

web proxy and user manager disabled

:? :?
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24364
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RB751U-2HnD crashing when using Skype

Tue Mar 26, 2013 3:02 pm

Did you try RouterOS v6?
No answer to your question? How to write posts
 
elektronb
just joined
Posts: 7
Joined: Fri Mar 02, 2012 3:53 pm

Re: RB751U-2HnD crashing when using Skype

Tue Mar 26, 2013 3:06 pm

Yes is worst (blaze) :(

system,error,critical router was rebooted without proper shutdown.

To help has not who me :(

i don't have money for new router

Can this nobody not check?

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
It is not deleted problem continuously
 
elektronb
just joined
Posts: 7
Joined: Fri Mar 02, 2012 3:53 pm

Re: RB751U-2HnD crashing when using Skype

Wed Mar 27, 2013 8:54 am

HELP ME PLEASE :(
 
User avatar
cybernetus
newbie
Posts: 41
Joined: Sat Sep 08, 2012 1:39 am
Location: Belo Horizonte/MG/Brazil
Contact:

Re: RB751U-2HnD crashing when using Skype

Sun Apr 21, 2013 2:35 am

Did you try RouterOS v6?
With the RouterOS v6 this problems was solved @normis ?
My RBs: RB751U-2HnD, RB951G-2Hnd , RB750-GL
 
User avatar
cybernetus
newbie
Posts: 41
Joined: Sat Sep 08, 2012 1:39 am
Location: Belo Horizonte/MG/Brazil
Contact:

Re: RB751U-2HnD crashing when using Skype

Sun Apr 28, 2013 11:47 pm

HELP ME PLEASE :(
I don't know if you solve your problem, but this post has some configs to use on your routerboard.

i made some of this configs on my router and it's stable for many hours.

http://forum.mikrotik.com/viewtopic.php ... 26#p303575
My RBs: RB751U-2HnD, RB951G-2Hnd , RB750-GL
 
shizny
just joined
Posts: 9
Joined: Sun Sep 18, 2011 12:33 pm
Location: Estonia

Re: RB751U-2HnD crashing when using Skype

Sat Jul 12, 2014 10:11 am

im jumping into same boat with all of you, cuz im having (only some firewall rules and nat rules) same crash problem, with my 751g 2hnd board.
everything is latest (firmware, bios). yesterday i had two crashes.

if i remember it correctly, it all started after 6.10 or 6.11 upgrade. then i think crash was gone in 6.12 or 6.13 but bow on 6.15 its back again.
 
kurtkraut
Frequent Visitor
Frequent Visitor
Posts: 73
Joined: Wed Feb 15, 2012 2:55 am

Re: RB751U-2HnD crashing when using Skype

Sat Jul 12, 2014 8:25 pm

shizny, it crashes only if you use Skype? No other application or traffic is able to crash the router?
 
geordy
just joined
Posts: 10
Joined: Tue Feb 25, 2014 12:20 pm

Re: RB751U-2HnD crashing when using Skype

Mon Jul 14, 2014 4:29 pm

Same problem here on 6.15 and 3.16 routerboard version:
routerboard: yes
model: 2011UiAS-2HnD
serial-number: XXXXXXXXXXX
current-firmware: 3.16
upgrade-firmware: 3.16
Basically the router crashes when I use a torrent client with the following message:
system,error,critical router was rebooted without proper shutdown by watchdog timer
I switched off the watchdog timer and the router now did not reboot, but it died.

I have the torrent client on a separate VLAN and it has two FW rules, one for NFS access and one for access to the internet.

The only solution I can find is to limit the torrent to a max of 2 Mbit.
 
User avatar
cybernetus
newbie
Posts: 41
Joined: Sat Sep 08, 2012 1:39 am
Location: Belo Horizonte/MG/Brazil
Contact:

Re: RB751U-2HnD crashing when using Skype

Tue Jul 15, 2014 9:54 pm

Same problem here on 6.15 and 3.16 routerboard version:
routerboard: yes
model: 2011UiAS-2HnD
serial-number: XXXXXXXXXXX
current-firmware: 3.16
upgrade-firmware: 3.16
Basically the router crashes when I use a torrent client with the following message:
system,error,critical router was rebooted without proper shutdown by watchdog timer
I switched off the watchdog timer and the router now did not reboot, but it died.

I have the torrent client on a separate VLAN and it has two FW rules, one for NFS access and one for access to the internet.

The only solution I can find is to limit the torrent to a max of 2 Mbit.
try this: http://forum.mikrotik.com/viewtopic.php ... 26#p303575

My router with this configs and the version 6.15 stops this crashes.
My RBs: RB751U-2HnD, RB951G-2Hnd , RB750-GL
 
paullleta
just joined
Posts: 1
Joined: Thu Oct 30, 2014 5:38 pm

Re: RB751U-2HnD crashing when using Skype

Wed Jan 07, 2015 11:04 am

I am using a RB751U-2HnD and have a problem where the router regularly restarts when using Skype from a machine on the LAN. I usually use Skype on a wireless connection from a Macbook. This is very frustrating but I must be doing something wrong as I cannot believe Mikrotik would fail at Skype! What happens is Skype call drops, no access to the web, then network comes back up (or I plug ethernet in) and when I login to Winbox the uptime corresponds to the recent crash.

I am running RouterOS 5.11 and believe I have enabled uPNP. Below shows the usual outputs, if any more would be helpful please let me know. It may be something to do with MTU or MSS (there are mangle rules to alter MSS than don't seem to print from command line?

I don't fully understand how to setup logging so the MT won't loose records when restarting.

Any advice very much appreciated.

Crude Network Diagram
ADSL --[telephone]-- MODEM ----[cat5]----Mikrotik-----LAN (+ Wifi)
/ip address print detail
Flags: X - disabled, I - invalid, D - dynamic
0 ;;; local LAN
address=192.168.88.1/24 network=192.168.88.0 interface=bridge-local
actual-interface=bridge-local

1 D address=192.168.1.10/24 network=192.168.1.0 interface=ether1-gateway
actual-interface=ether1-gateway

2 D address=111.xxx.xxx.xxx/32 network=111.xxx.xxx.xxx interface=pppoe-out1
actual-interface=pppoe-out1
/ip route print detail
Flags: X - disabled, A - active, D - dynamic,
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
B - blackhole, U - unreachable, P - prohibit
0 ADS dst-address=0.0.0.0/0 gateway=111..xxx.xxx.xxx
gateway-status=111.xxx.xxx.xxx reachable pppoe-out1 distance=1 scope=30
target-scope=10

1 ADC dst-address=111..xxx.xxx.xxx/32 pref-src=111.69.245.4 gateway=pppoe-out1
gateway-status=pppoe-out1 reachable distance=0 scope=10

2 ADC dst-address=192.168.1.0/24 pref-src=192.168.1.10 gateway=ether1-gateway
gateway-status=ether1-gateway reachable distance=0 scope=10

3 ADC dst-address=192.168.88.0/24 pref-src=192.168.88.1 gateway=bridge-local
gateway-status=bridge-local reachable distance=0 scope=10
/interface print detail
Flags: D - dynamic, X - disabled, R - running, S - slave
0 R name="wlan1" type="wlan" mtu=1500 l2mtu=2290

1 R name="ether1-gateway" type="ether" mtu=1500 l2mtu=1600 max-l2mtu=4076

2 R name="ether2-master-local" type="ether" mtu=1500 l2mtu=1598 max-l2mtu=2028

3 R name="ether3-slave-local" type="ether" mtu=1500 l2mtu=1598 max-l2mtu=2028

4 name="ether4-slave-local" type="ether" mtu=1500 l2mtu=1598 max-l2mtu=2028

5 name="ether5-alone" type="ether" mtu=1500 l2mtu=1598 max-l2mtu=2028

6 R name="bridge-local" type="bridge" mtu=1500 l2mtu=1598

7 R name="pppoe-out1" type="pppoe-out" mtu=1492
/ip firewall export
# jan/15/2012 17:51:02 by RouterOS 5.11
# software id = XXXX-XXXX
#
/ip firewall connection tracking
set enabled=yes generic-timeout=10m icmp-timeout=10s tcp-close-timeout=10s \
tcp-close-wait-timeout=10s tcp-established-timeout=1d tcp-fin-wait-timeout=\
10s tcp-last-ack-timeout=10s tcp-syn-received-timeout=5s \
tcp-syn-sent-timeout=5s tcp-syncookie=no tcp-time-wait-timeout=10s \
udp-stream-timeout=3m udp-timeout=10s
/ip firewall filter
add action=accept chain=forward disabled=no dst-address=192.168.1.1 \
in-interface=bridge-local out-interface=ether1-gateway
add action=accept chain=output comment=PPTP_GRE disabled=no protocol=gre
add action=accept chain=input comment=PPTP_GRE disabled=no protocol=gre
add action=accept chain=input comment="default configuration - PPTP" disabled=\
no dst-port=1723 in-interface=pppoe-out1 protocol=tcp
add action=accept chain=input comment="default configuration" disabled=no \
protocol=icmp
add action=accept chain=input comment="default configuration" connection-state=\
established disabled=no
add action=accept chain=input comment=\
"This is to enable ODMON SNMP checking remotely." disabled=no dst-port=161 \
protocol=udp src-address=188.124.160.10
add action=accept chain=input comment="default configuration" connection-state=\
related disabled=no
add action=drop chain=input comment="default configuration" disabled=no \
in-interface=pppoe-out1
/ip firewall mangle
add action=mark-packet chain=forward comment=VoIP disabled=no new-packet-mark=\
VoIP passthrough=no src-address=192.168.88.200
add action=mark-packet chain=forward comment=VoIP disabled=no dst-address=\
192.168.88.200 new-packet-mark=VoIP passthrough=no
/ip firewall nat
add action=redirect chain=dstnat comment="For proxy" disabled=yes dst-port=80 \
protocol=tcp to-ports=8080
add action=masquerade chain=srcnat comment="default configuration" disabled=no \
out-interface=pppoe-out1
add action=masquerade chain=srcnat comment=\
"This is required to access Vigor modem on 192.168.1.1" disabled=no \
out-interface=ether1-gateway
/ip firewall service-port
set ftp disabled=no ports=21
set tftp disabled=no ports=69
set irc disabled=no ports=6667
set h323 disabled=no
set sip disabled=yes ports=5060,5061,50600 sip-direct-media=yes
set pptp disabled=no
/ip upnp print
enabled: yes
allow-disable-external-interface: yes
show-dummy-rule: yes

Pau Mungai Kenya.

I have a RB751 and i am logged in to my users using the Userman. The problem is my users keeps of being disconnected because of a problem i am not familiar with. Kindly help

Who is online

Users browsing this forum: Gurewitz, krisjanisj, simcard and 43 guests