Community discussions

MUM Europe 2020
 
poznavatelj
just joined
Topic Author
Posts: 3
Joined: Tue Jan 24, 2012 12:24 am

MikroTik - uTorrent behing NAT does not work

Mon Jan 30, 2012 10:51 pm

uTorrent does not make any connection through MikroTik RB751U-2HnD.
I have disabled NAT-PMP and uPnP in uTorrent, and I select one single port 42056.
On router I have srncat masquerade on Out Interface.
Maybe someone have advice about such a topic like MikroTik-uTorrent behing NAT.

THX
 
changeip
Forum Guru
Forum Guru
Posts: 3804
Joined: Fri May 28, 2004 5:22 pm

Re: MikroTik - uTorrent behing NAT does not work

Mon Jan 30, 2012 11:16 pm

just open port 42056 (udp/tcp) to your internal ip and it should work. dstnat rule inbound ...
Colo and Wholesale Bandwidth Available! Sales at SanDiegoBroadband dot com
 
poznavatelj
just joined
Topic Author
Posts: 3
Joined: Tue Jan 24, 2012 12:24 am

Re: MikroTik - uTorrent behing NAT does not work

Tue Jan 31, 2012 7:10 am

I have dynamic IPs (DHCP)
I have tried rules 0 and 1, but still nothing is better.

NAT:
0 chain=dstnat action=dst-nat to-ports=42056 protocol=udp in-interface=ether1-gateway src-port=42056 dst-port=42056
1 chain=dstnat action=dst-nat to-ports=42056 protocol=tcp in-interface=ether1-gateway src-port=42056 dst-port=42056
2 ;;; default configuration
chain=srcnat action=masquerade out-interface=ISPname

THX
 
poznavatelj
just joined
Topic Author
Posts: 3
Joined: Tue Jan 24, 2012 12:24 am

Re: MikroTik - uTorrent behing NAT does not work

Tue Jan 31, 2012 2:02 pm

I found the solution. :)

THX
 
changeip
Forum Guru
Forum Guru
Posts: 3804
Joined: Fri May 28, 2004 5:22 pm

Re: MikroTik - uTorrent behing NAT does not work

Tue Jan 31, 2012 6:41 pm

yep - just remove src-port=42056 from the rules you posted.
Colo and Wholesale Bandwidth Available! Sales at SanDiegoBroadband dot com
 
troy
Member
Member
Posts: 309
Joined: Thu Jun 30, 2005 6:47 pm

Re: MikroTik - uTorrent behing NAT does not work

Sun Feb 05, 2012 6:35 pm

Dunno what solution you found, but here's my setup:
/ip upnp
set allow-disable-external-interface=no enabled=yes
/ip upnp interfaces
add interface=wan type=external
add interface=lan type=internal
I get lots and lots of dynamic nat rules from utorrent and other applications. Works a treat!
 
tournet
just joined
Posts: 11
Joined: Fri Nov 20, 2009 8:05 pm

Re: MikroTik - uTorrent behing NAT does not work

Wed Feb 26, 2014 5:25 am

I encounter the same problem.
My wan connection is PPPOE
lan gateway is 192.168.0.1
internal client's IP address is 192.168.0.223
the utorrent use port 56667, here is my nat config for utorrent.
/ip firewall nat
    add action=dst-nat chain=dstnat comment=utorrent dst-address=\
    !192.168.0.1 dst-port=56667 protocol=tcp src-address=!192.168.0.0/24 \
    to-addresses=192.168.0.223 to-ports=56667
but the utorrent tells " Port is not open (you are still able to download)", what the problem of this nat config?
BTW, I don't want to use upnp.
 
francisuk24
newbie
Posts: 28
Joined: Tue Mar 18, 2014 12:10 am
Location: United Kingdom
Contact:

Re: MikroTik - uTorrent behing NAT does not work

Mon Mar 31, 2014 4:37 am

Im using transmission on ubuntu with port 51413 and says that is Open when you go to click it.
Image

/ip firewall nat
add chain=dstnat action=dst-nat to-addresses=192.168.1.3 to-ports=51413 protocol=tcp dst-port=51413
Dunno what solution you found, but here's my setup:
/ip upnp
set allow-disable-external-interface=no enabled=yes
/ip upnp interfaces
add interface=wan type=external
add interface=lan type=internal
I get lots and lots of dynamic nat rules from utorrent and other applications. Works a treat!
using UPnP can be a security risk but then again so is torrents lol ;)
RouterBoard RB750R2, RouterOS Level 4
ISP: Zen Internet via VDSL 2 > 74.68Mb Down / 17.84Mb Up
 
badmojorayman
just joined
Posts: 1
Joined: Wed Apr 20, 2016 12:52 am

Re: MikroTik - uTorrent behing NAT does not work

Wed Apr 20, 2016 12:54 am

My router is now running 6.34.2 and none of these settings work. Did they change "wan" and "lan" to another set of words?
 
Sob
Forum Guru
Forum Guru
Posts: 5136
Joined: Mon Apr 20, 2009 9:11 pm

Re: MikroTik - uTorrent behing NAT does not work

Wed Apr 20, 2016 1:28 am

Intead of "wan" and "lan", use real names of your interfaces, e.g. "wlan1" or "ether1".
People who quote full posts should be spanked with ethernet cable. Some exceptions for multi-topic threads may apply. Not intended as incentive for masochists.

Who is online

Users browsing this forum: dejoebad, nowinskit and 45 guests