Community discussions

 
alexk1r
just joined
Topic Author
Posts: 4
Joined: Tue May 22, 2012 11:56 am

Problems with ether3 and onwards and portforwarding question

Wed May 23, 2012 12:39 pm

Hi, all. Got a Routerboard 750G to replace a slowly dying Cisco (Linksys) router because I heard good things about these lovely routers, plus customisability is amazing (maybe too amazing).

This may be a stupid question but bare with me, it's my first time working with Routerboard stuff.

I set everything nicely, Internet is running, LAN is running but it only works on Ether2, which is fine as I got the main switch connected to that. Problem is the other 3 Ether ports, they don't seem to be active. I initially assume that since these 3 ports are slaves they'll take the master's (which is the perfectly working Ether2. Looking at http://wiki.mikrotik.com/wiki/Manual:In ... face_state

That's all I have to do.. or not?

I have another question, which is about Port forwarding. I assume this is done via Firewall rules. We have one of the PC running a server for testing, which is 192.168.10.67, I set up AWS to route it here and in the old router I simply port forwarded 80 and 443 to 192.168.10.67 and it works. Unfortunately, doing something similar in firewall rules didn't work for me.

I tried this:

http://wiki.mikrotik.com/wiki/Forwardin ... nternal_IP

Replacing the numbers there with what we have but doesn't seem to be an answer.
 
alexk1r
just joined
Topic Author
Posts: 4
Joined: Tue May 22, 2012 11:56 am

Re: Problems with ether3 and onwards and portforwarding ques

Thu May 24, 2012 11:51 am

OK, I figured out the port forwarding issue. There's one thing I forgot to do, that is mascaraing locally. So for those who have problems, to forward outside traffic on a specific port to a local address you need to do this:

WAN IP = 9x.xxx.x8.xx4
LAN IP you want to forward to = 192.168.10.67
Port I want to forward = 80

You pretty much need these rules added:
/ip firewall nat 
add action=dst-nat chain=dstnat comment="Jira" disabled=no  protocol=tcp dst-port=80 dst-address=9x.xxx.x8.xx4 to-addresses=192.168.10.67 to-ports=80

/ip firewall nat
add chain=srcnat action=src-nat protocol=tcp dst-port=80 src-address=192.168.10.67 to-addresses=9x.xxx.x8.xx4 place-before=0 to-ports=80

/ip firewall nat
add chain=srcnat action=masquerade src-address=192.168.10.0/24 dst-port=80 protocol=tcp
Of course you also need the WAN mascaraing as well but I had that rule by default. It's essentially same as the above but:
/ip firewall nat
add chain=srcnat interface=ether1 action=masquerade
Still not sure why I only have Internet connection on Ether2 only, maybe it's simply DHCP is not serving any other ports? I'll try to figure it out myself but any help will speed up my progress. :)
Last edited by alexk1r on Fri May 25, 2012 12:00 pm, edited 1 time in total.
 
alexk1r
just joined
Topic Author
Posts: 4
Joined: Tue May 22, 2012 11:56 am

Re: Problems with ether3 and onwards and portforwarding ques

Thu May 24, 2012 12:59 pm

Answer to my initial question was a silly one. I assumed it didn't work, when in fact it did. The problem was that the NAS that is connected to ether3 would get an IP from the DHCP even though I explicitly set to a static one in ARP table. Which confused me as it didn't occur to check if it was assigned a different IP and seeing 1 MAC with 2 different IPs is just weird. Funny enough all the other other devices that I set to be static behave nicely. It also seems to always go for the same IP address. In the end I had to set the IP statically within the actual NAS.
 
GuJack20
Trainer
Trainer
Posts: 322
Joined: Sat Jun 12, 2004 9:44 pm
Location: Tirana
Contact:

Re: Problems with ether3 and onwards and portforwarding ques

Thu May 24, 2012 1:35 pm

I just had finished writing my post but it seems you have figured everything out by yourself

Congratulations
--Do you remember that guy who gave up? Neither does anybody else!
 
alexk1r
just joined
Topic Author
Posts: 4
Joined: Tue May 22, 2012 11:56 am

Re: Problems with ether3 and onwards and portforwarding ques

Fri May 25, 2012 12:12 pm

I just had finished writing my post but it seems you have figured everything out by yourself

Congratulations
Thanks. :) I never set up a Mikrotik router before so I reckoned, it would be faster to solve the problem if I asked here as well as trying to figure out it myself.

One more question. How do I go about setting the static IPs for the clients? Setting them statically just in ARP table didn't do the trick it seems. Do I need to tinker with the DHCP as well? I see I can set static leases there. Err, not sure if that's the proper way of doing it.
 
CelticComms
Forum Guru
Forum Guru
Posts: 1766
Joined: Wed May 02, 2012 5:48 am

Re: Problems with ether3 and onwards and portforwarding ques

Sat May 26, 2012 12:03 am

Yes you make clients use the same IPs by setting them to be static in the DHCP server section.
Interlynx | Networking and Information Security Consultants & Trainers | Email: routerlynx@gmail.com
BGP | EIGRP | OSPF | MPLS | Firewall | VPN | IPsec | Multicast | QOS | IPv4/6 | STP | VLAN | PON | AE | M2M | and more!

Who is online

Users browsing this forum: Google [Bot] and 21 guests