Community discussions

MikroTik App
 
silentwishes
just joined
Topic Author
Posts: 16
Joined: Tue Jul 31, 2012 1:33 am

Experts plz help!!!

Thu Oct 11, 2012 6:25 pm

I have a x86 based mikrotik 5.20 installed and i have configured 2 WAN PCC Loadbalancing with hotspot and its not working
here is the script me using!
Mikrotik PCC 2WAN LOADBALANCING SCRIPT SCRIPT
DSL MODEM 1: 192.168.1.1
DSL MODEM 2: 192.168.2.1




/ ip address
add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Local
add address=192.168.1.2/24 network=192.168.1.0 broadcast=192.168.1.255 interface=WAN1
add address=192.168.2.2/24 network=192.168.2.0 broadcast=192.168.2.255 interface=WAN2

/ ip firewall mangle
add chain=prerouting dst-address=192.168.1.0/24 action=accept in-interface=Local
add chain=prerouting dst-address=192.168.2.0/24 action=accept in-interface=Local
add chain=prerouting in-interface=WAN1 connection-mark=no-mark action=mark-connection \
new-connection-mark=WAN1_conn
add chain=prerouting in-interface=WAN2 connection-mark=no-mark action=mark-connection \
new-connection-mark=WAN2_conn
add chain=prerouting in-interface=Local connection-mark=no-mark dst-address-type=!local \
per-connection-classifier=both-addresses:2/0 action=mark-connection new-connection-mark=WAN1_conn
add chain=prerouting in-interface=LAN connection-mark=no-mark dst-address-type=!local \
per-connection-classifier=both-addresses:2/1 action=mark-connection new-connection-mark=WAN2_conn
add chain=prerouting connection-mark=WAN1_conn in-interface=Local action=mark-routing \
new-routing-mark=to_WAN1
add chain=prerouting connection-mark=WAN2_conn in-interface=Local action=mark-routing \
new-routing-mark=to_WAN2
add chain=output connection-mark=WAN1_conn action=mark-routing new-routing-mark=to_WAN1
add chain=output connection-mark=WAN2_conn action=mark-routing new-routing-mark=to_WAN2

/ ip route
add dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_WAN1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=to_WAN2 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.1.1 distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.2.1 distance=2 check-gateway=ping

/ ip firewall nat
add chain=srcnat out-interface=WAN1 action=masquerade
add chain=srcnat out-interface=WAN2 action=masquerade

/ip firewall nat add action=accept chain=pre-hotspot disabled=no dst-address-type=!local hotspot=auth

then i configured hotspot if anybody have any solution plzzzz help

and this script is working on 4.x but not working in 5.20
 
User avatar
cbrown
Trainer
Trainer
Posts: 1839
Joined: Thu Oct 14, 2010 8:57 pm
Contact:

Experts plz help!!!

Thu Oct 11, 2012 11:06 pm

 
silentwishes
just joined
Topic Author
Posts: 16
Joined: Tue Jul 31, 2012 1:33 am

Re: Experts plz help!!!

Sun Oct 14, 2012 12:16 pm

thank you for replying dear but my problem is different one
every think is working correct only one connection is not working some time works for just 2 or 3 seconds but then it leaves the connection i dont know why!!!?
 
User avatar
c0d3rSh3ll
Long time Member
Long time Member
Posts: 557
Joined: Mon Jul 25, 2011 9:42 pm
Location: [admin@Chile] >

Re: Experts plz help!!!

Sun Oct 14, 2012 7:52 pm

set mangle pcc with hotspot=auth.

add chain=prerouting in-interface=Local connection-mark=no-mark dst-address-type=!local \
per-connection-classifier=both-addresses:2/0 action=mark-connection new-connection-mark=WAN1_conn
add chain=prerouting in-interface=LAN connection-mark=no-mark dst-address-type=!local \
per-connection-classifier=both-addresses:2/1 action=mark-connection new-connection-mark=WAN2_conn

Who is online

Users browsing this forum: Google [Bot] and 83 guests