Community discussions

MUM Europe 2020
 
Jeffrey06
just joined
Topic Author
Posts: 18
Joined: Sat Nov 19, 2011 1:56 am

Simple Wireless AP Setup

Fri Oct 19, 2012 2:20 am

I need a basic guide to setup my MikroTik just for a wireless router for my guests.

I have my DSL Modem that has a default gateway of 192.168.0.1

I'm wanting to give my Mikrotik a IP of 192.168.1.200, then assign IP's via DHCP for 192.168.1.x for my guests.

Here is what I have, I can connect and Win 7 DOESN'T give me the "Limited or No Connectivity Message" but I'm unable to open any webpage. Also, I'm unable to ping 192.168.0.1

I'm also unsure for the DHCP Client. Should I configured for the WAN or the LAN?

I've attached a screen of my setup, any help would be appreciated.
You do not have the required permissions to view the files attached to this post.
 
User avatar
cbrown
Trainer
Trainer
Posts: 1840
Joined: Thu Oct 14, 2010 8:57 pm
Contact:

Simple Wireless AP Setup

Fri Oct 19, 2012 2:27 am

Please post /export compact
C.Brown

cbrown[at]ravenrocknetworks.com
MTCNA - MTCRE - MTCWE - MTCTCE
MTCSE - TRAINER-0179
 
Jeffrey06
just joined
Topic Author
Posts: 18
Joined: Sat Nov 19, 2011 1:56 am

Re: Simple Wireless AP Setup

Fri Oct 19, 2012 3:11 am

[admin@MikroTik] > export compact
# jan/02/1970 01:15:57 by RouterOS 5.14
# software id = FW4M-101H
#
/interface wireless
set 0 band=2ghz-b/g disabled=no frequency=2412 l2mtu=2290 mode=ap-bridge \
wireless-protocol=802.11
/ip pool
add name=dhcp_pool1 ranges=192.168.0.1-192.168.0.254
add name=dhcp_pool2 ranges=192.168.1.0-192.168.1.254
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=ether1 name=dhcp_server1
add address-pool=dhcp_pool2 disabled=no interface=wlan1 name=dhcp_server2
/ip address
add address=192.168.0.200/24 interface=ether1
add address=192.168.1.1/24 interface=wlan1
/ip dhcp-server network
add address=192.168.1.1/32 gateway=192.168.0.1
[admin@MikroTik] >
 
Jeffrey06
just joined
Topic Author
Posts: 18
Joined: Sat Nov 19, 2011 1:56 am

Re: Simple Wireless AP Setup

Fri Oct 19, 2012 4:55 am

Also, here is another export (my latest)
 [admin@MikroTik] > /ip address print detail
Flags: X - disabled, I - invalid, D - dynamic 
 0   address=192.168.0.200/24 network=192.168.0.0 interface=ether1 
     actual-interface=ether1 

 1   address=192.168.1.1/24 network=192.168.1.0 interface=wlan1 
     actual-interface=wlan1 

 2 D address=192.168.0.11/24 network=192.168.0.0 interface=ether1 
     actual-interface=ether1 
[admin@MikroTik] > /ip route print detail
Flags: X - disabled, A - active, D - dynamic, 
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, 
B - blackhole, U - unreachable, P - prohibit 
 0 ADS  dst-address=0.0.0.0/0 gateway=192.168.0.1 
        gateway-status=192.168.0.1 reachable via  ether1 distance=0 scope=30 
        target-scope=10 vrf-interface=ether1 

 1 ADC  dst-address=192.168.0.0/24 pref-src=192.168.0.200 gateway=ether1 
        gateway-status=ether1 reachable distance=0 scope=10 

 2 ADC  dst-address=192.168.1.0/24 pref-src=192.168.1.1 gateway=wlan1 
        gateway-status=wlan1 reachable distance=0 scope=10 
[admin@MikroTik] > /interface p
ppp-client  pppoe-client  pptp-client  print
ppp-server  pppoe-server  pptp-server  
[admin@MikroTik] > /interface p
ppp-client  pppoe-client  pptp-client  print
ppp-server  pppoe-server  pptp-server  
[admin@MikroTik] > /interface print detail
Flags: D - dynamic, X - disabled, R - running, S - slave 
 0  R  name="ether1" type="ether" mtu=1500 l2mtu=1526 max-l2mtu=1526 

 1     name="ether2" type="ether" mtu=1500 l2mtu=1522 max-l2mtu=1522 

 2     name="ether3" type="ether" mtu=1500 l2mtu=1522 max-l2mtu=1522 

 3  R  name="wlan1" type="wlan" mtu=1500 l2mtu=2290 
[admin@MikroTik] > /ip pool print detail
 0 name="dhcp_pool1" ranges=192.168.0.1-192.168.0.254 

 1 name="dhcp_pool2" ranges=192.168.1.0-192.168.1.254 
[admin@MikroTik] > ip dhcp-server export
# oct/18/2012 20:53:04 by RouterOS 5.14
# software id = FW4M-101H
#
/ip dhcp-server
add address-pool=dhcp_pool1 authoritative=after-2sec-delay bootp-support=static \
    disabled=no interface=ether1 lease-time=3d name=dhcp_server1
add address-pool=dhcp_pool2 authoritative=after-2sec-delay bootp-support=static \
    disabled=no interface=wlan1 lease-time=3d name=dhcp_server2
/ip dhcp-server config
set store-leases-disk=5m
/ip dhcp-server network
add address=192.168.1.1/32 dhcp-option="" dns-server="" gateway=192.168.1.1 \
    ntp-server="" wins-server=""
[admin@MikroTik] > /ip dhcp-server print detail
Flags: X - disabled, I - invalid 
 0   name="dhcp_server1" interface=ether1 lease-time=3d address-pool=dhcp_pool1 
     bootp-support=static authoritative=after-2sec-delay 

 1   name="dhcp_server2" interface=wlan1 lease-time=3d address-pool=dhcp_pool2 
     bootp-support=static authoritative=after-2sec-delay 
[admin@MikroTik] > /ip firewall export
# oct/18/2012 20:53:29 by RouterOS 5.14
# software id = FW4M-101H
#
/ip firewall connection tracking
set enabled=yes generic-timeout=10m icmp-timeout=10s tcp-close-timeout=10s \
    tcp-close-wait-timeout=10s tcp-established-timeout=1d tcp-fin-wait-timeout=\
    10s tcp-last-ack-timeout=10s tcp-syn-received-timeout=5s \
    tcp-syn-sent-timeout=5s tcp-syncookie=no tcp-time-wait-timeout=10s \
    udp-stream-timeout=3m udp-timeout=10s
/ip firewall filter
add action=passthrough chain=unused-hs-chain comment="place hotspot rules here" \
    disabled=yes
/ip firewall nat
add action=passthrough chain=unused-hs-chain comment="place hotspot rules here" \
    disabled=yes
/ip firewall service-port
set ftp disabled=no ports=21
set tftp disabled=no ports=69
set irc disabled=no ports=6667
set h323 disabled=no
set sip disabled=no ports=5060,5061 sip-direct-media=yes
set pptp disabled=no
[admin@MikroTik] >
 
deejayq
Member Candidate
Member Candidate
Posts: 195
Joined: Wed Feb 23, 2011 8:33 am

Re: Simple Wireless AP Setup

Fri Oct 19, 2012 10:43 am

you should set a src-nat masquerade rule for clients coming from wlan
delete dhcp_pool1, you don't need it
delete dhcp_server1, you don't need it
dhcp-server network should be something like address 192.168.1.0/24 gateway=192.168.1.1 also include some dns servers here
set and ip route to destination 0.0.0.0 gateway 192.168.0.1 (assuming 192.168.0.1 is the gateway that you see if you were to connect directly to DSL modem.
i don't know much about wireless modes, but i think it has to be mode=ap and not mode=ap-bridge
 
Jeffrey06
just joined
Topic Author
Posts: 18
Joined: Sat Nov 19, 2011 1:56 am

Re: Simple Wireless AP Setup

Fri Oct 19, 2012 8:58 pm

Thank you for the help, but still no luck. When I first connect my Laptop to the network it looks fine, after I try to go to a webpage it will time out and I let the "Limited or No Connectivity" error icon on my Wireless.

Here is my latest print..









  MMM      MMM       KKK                          TTTTTTTTTTT      KKK
  MMMM    MMMM       KKK                          TTTTTTTTTTT      KKK
  MMM MMMM MMM  III  KKK  KKK  RRRRRR     OOOOOO      TTT     III  KKK  KKK
  MMM  MM  MMM  III  KKKKK     RRR  RRR  OOO  OOO     TTT     III  KKKKK
  MMM      MMM  III  KKK KKK   RRRRRR    OOO  OOO     TTT     III  KKK KKK
  MMM      MMM  III  KKK  KKK  RRR  RRR   OOOOOO      TTT     III  KKK  KKK

  MikroTik RouterOS 5.14 (c) 1999-2012       http://www.mikrotik.com/





[admin@MikroTik] > /ip address print detail 
Flags: X - disabled, I - invalid, D - dynamic 
 0   address=192.168.0.200/24 network=192.168.0.0 interface=ether1 
     actual-interface=ether1 

 1   address=192.168.1.1/24 network=192.168.1.0 interface=wlan1 
     actual-interface=wlan1 

 2 D address=192.168.0.11/24 network=192.168.0.0 interface=ether1 
     actual-interface=ether1 
[admin@MikroTik] > /ip route print detail 
Flags: X - disabled, A - active, D - dynamic, 
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, 
B - blackhole, U - unreachable, P - prohibit 
 0 ADS  dst-address=0.0.0.0/0 gateway=192.168.0.1 
        gateway-status=192.168.0.1 reachable via  ether1 distance=0 scope=30 
        target-scope=10 vrf-interface=ether1 

 1   S  dst-address=0.0.0.0/0 gateway=192.168.0.1 
        gateway-status=192.168.0.1 reachable via  ether1 distance=1 scope=30 
        target-scope=10 

 2 ADC  dst-address=192.168.0.0/24 pref-src=192.168.0.200 gateway=ether1 
        gateway-status=ether1 reachable distance=0 scope=10 

 3 ADC  dst-address=192.168.1.0/24 pref-src=192.168.1.1 gateway=wlan1 
        gateway-status=wlan1 reachable distance=0 scope=10 
[admin@MikroTik] > /interface print detail 
Flags: D - dynamic, X - disabled, R - running, S - slave 
 0  R  name="ether1" type="ether" mtu=1500 l2mtu=1526 max-l2mtu=1526 

 1     name="ether2" type="ether" mtu=1500 l2mtu=1522 max-l2mtu=1522 

 2     name="ether3" type="ether" mtu=1500 l2mtu=1522 max-l2mtu=1522 

 3  R  name="wlan1" type="wlan" mtu=1500 l2mtu=2290 
[admin@MikroTik] > /ip pool print detail
 0 name="dhcp_pool2" ranges=192.168.1.0-192.168.1.254 
[admin@MikroTik] > /ip dhcp-server export
# oct/19/2012 12:56:55 by RouterOS 5.14
# software id = FW4M-101H
#
/ip dhcp-server
add address-pool=dhcp_pool2 authoritative=after-2sec-delay bootp-support=static \
    disabled=no interface=wlan1 lease-time=3d name=dhcp_server2
/ip dhcp-server config
set store-leases-disk=5m
/ip dhcp-server network
add address=192.168.1.0/24 dhcp-option="" dns-server=192.168.0.1 gateway=\
    192.168.1.1 ntp-server="" wins-server=""
[admin@MikroTik] > /ip dhcp-server print detail
Flags: X - disabled, I - invalid 
 0   name="dhcp_server2" interface=wlan1 lease-time=3d address-pool=dhcp_pool2 
     bootp-support=static authoritative=after-2sec-delay 
[admin@MikroTik] > /ip firewall export
# oct/19/2012 12:57:16 by RouterOS 5.14
# software id = FW4M-101H
#
/ip firewall connection tracking
set enabled=yes generic-timeout=10m icmp-timeout=10s tcp-close-timeout=10s \
    tcp-close-wait-timeout=10s tcp-established-timeout=1d tcp-fin-wait-timeout=\
    10s tcp-last-ack-timeout=10s tcp-syn-received-timeout=5s \
    tcp-syn-sent-timeout=5s tcp-syncookie=no tcp-time-wait-timeout=10s \
    udp-stream-timeout=3m udp-timeout=10s
/ip firewall filter
add action=passthrough chain=unused-hs-chain comment="place hotspot rules here" \
    disabled=yes
/ip firewall nat
add action=masquerade chain=srcnat disabled=no dst-address=192.168.0.1 \
    src-address=192.168.1.0/24 src-address-type=""
/ip firewall service-port
set ftp disabled=no ports=21
set tftp disabled=no ports=69
set irc disabled=no ports=6667
set h323 disabled=no
set sip disabled=no ports=5060,5061 sip-direct-media=yes
set pptp disabled=no
[admin@MikroTik] > 
 
Jeffrey06
just joined
Topic Author
Posts: 18
Joined: Sat Nov 19, 2011 1:56 am

Re: Simple Wireless AP Setup

Fri Oct 19, 2012 9:34 pm

Anybody willing to help out..

I can ping 192.168.0.1 and 192.168.1.1 while on the network from my Computer, however, I just can't access any pages. It's something to do with my DNS or probably my NAT. Any guidance with those?

Now, if I ping from the MikroTik for 192.168.0.1 it timesout. I can ping 192.168.1.1 with success
 
Jeffrey06
just joined
Topic Author
Posts: 18
Joined: Sat Nov 19, 2011 1:56 am

Re: Simple Wireless AP Setup

Fri Oct 19, 2012 9:56 pm

I got it. I needed to setup the "Bridge" and that was it. I can now browse the internet.

Who is online

Users browsing this forum: negr0, Sob, Zacharias and 55 guests