Community discussions

MUM Europe 2020
 
conquerer
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 74
Joined: Tue Dec 22, 2009 7:31 pm

Allow Internet Users to Play Counter Stike on LAN server

Sun Nov 11, 2012 11:24 am

Need to allow Internet users to play counter strike on my Lan Counter strike server.

i have a loadbalancing with bridge modem on Modems.
LAN Counter strike server IP 10.1.1.5:27015
Internet IP on WAN1 101.20.11.22

following is configuration on my server.

admin@SpeeDZone] /interface> print
Flags: D - dynamic, X - disabled, R - running, S - slave
# NAME TYPE MTU L2MTU MAX-L2MTU
0 R Wan ether 1500
1 R Wifi ether 1500
2 R Lan ether 1500
3 R Wan2 ether 1500
4 R WAN2 pppoe-out 1480
5 R WAN1 pppoe-out 1480

[admin@SpeeDZone] /ip firewall nat> print
Flags: X - disabled, I - invalid, D - dynamic
0 chain=srcnat action=masquerade out-interface=WAN1 connection-mark=conn1

1 chain=srcnat action=masquerade out-interface=WAN2 connection-mark=conn2

[admin@SpeeDZone] /ip firewall mangle> print detail
Flags: X - disabled, I - invalid, D - dynamic
0 chain=prerouting action=mark-connection new-connection-mark=conn2 passthrough=yes connection-state=new in-interface=Lan nth=2,1

1 chain=prerouting action=mark-routing new-routing-mark=conn2 passthrough=no in-interface=Lan connection-mark=conn2

2 chain=prerouting action=mark-connection new-connection-mark=conn1 passthrough=yes connection-state=new in-interface=Lan

3 chain=prerouting action=mark-routing new-routing-mark=conn1 passthrough=no in-interface=Lan connection-mark=conn1

4 chain=prerouting action=mark-connection new-connection-mark=conn2 passthrough=yes connection-state=new in-interface=Wifi nth=2,1

5 chain=prerouting action=mark-routing new-routing-mark=conn2 passthrough=no in-interface=Wifi connection-mark=conn2

6 chain=prerouting action=mark-connection new-connection-mark=conn1 passthrough=yes connection-state=new in-interface=Wifi

7 chain=prerouting action=mark-routing new-routing-mark=conn1 passthrough=no in-interface=Wifi connection-mark=conn1

8 chain=prerouting action=add-src-to-address-list connection-state=new protocol=tcp address-list=Worm-Infected-p445 address-list-timeout=1h dst-port=445
limit=5,10

[admin@SpeeDZone] /ip route> print
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit
# DST-ADDRESS PREF-SRC GATEWAY DISTANCE
0 A S 0.0.0.0/0 WAN2 1
1 A S 0.0.0.0/0 WAN1 1
2 ADS 0.0.0.0/0 111.11.1.101 0
3 DS 0.0.0.0/0 182.182.11.1 1
4 DS 0.0.0.0/0 101.157.104.251 1
5 ADC 10.1.1.0/24 10.1.1.1 Lan 0
6 ADC 11.1.1.0/24 11.1.1.1 Wifi 0
7 ADC 111.11.1.0/24 111.11.1.22 Wan 0
8 ADC 182.182.11.1/32 181.185.56.89 WAN2 0
9 ADC 101.157.104.251/32 101.20.11.22 WAN1 0
 
User avatar
leoservices
Trainer
Trainer
Posts: 140
Joined: Fri Jan 13, 2012 2:20 am
Location: Belo Horizonte - MG - Brazil
Contact:

Re: Allow Internet Users to Play Counter Stike on LAN server

Sun Nov 11, 2012 12:56 pm

see if this rule will help you

/ip firewall nat
add action=dst-nat chain=dstnat disabled=no dst-port=27015 protocol=tcp \
to-addresses=10.1.1.5 to-ports=27015
I try to help !

Leonardo Vieira
https://youtube.com/contractti
Like Facebook.com/contractti
 
conquerer
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 74
Joined: Tue Dec 22, 2009 7:31 pm

Re: Allow Internet Users to Play Counter Stike on LAN server

Sun Nov 11, 2012 1:32 pm

Not working.
 
conquerer
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 74
Joined: Tue Dec 22, 2009 7:31 pm

Re: Allow Internet Users to Play Counter Stike on LAN server

Tue Nov 13, 2012 12:28 pm

Waiting for solution from experts.
 
deejayq
Member Candidate
Member Candidate
Posts: 195
Joined: Wed Feb 23, 2011 8:33 am

Re: Allow Internet Users to Play Counter Stike on LAN server

Tue Nov 13, 2012 3:17 pm

maybe your isp is blocking incoming connections to your wan ip
 
conquerer
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 74
Joined: Tue Dec 22, 2009 7:31 pm

Re: Allow Internet Users to Play Counter Stike on LAN server

Thu Nov 15, 2012 10:33 am

When i connect ISP link directly to my PC, my friends can play with me couter strike from internet.

But after connecting ISP to WAN1 of my Mikrotik server, they cannt see my LAN server.

i think there is something wrong with filter or NAT rule.

Please provide the solution according to my configuration given above.
 
Lakis
Forum Veteran
Forum Veteran
Posts: 701
Joined: Wed Sep 23, 2009 7:52 pm

Re: Allow Internet Users to Play Counter Stike on LAN server

Fri Nov 16, 2012 10:02 pm

Ur behind NAT so ur friends cant see ur PC
Try this
In firewall filter if u have this rule
chain=srcnat action=masquerade
Disable it or better after creating second rule move it down

add this rule
/ip firewall nat add chain=dstnat dst-address=(public ip) action=dst-nat to-addresses=ur PC IP address (On ur PC add same static IP)
this rule must be at top

Who is online

Users browsing this forum: DariaBel, MSN [Bot] and 44 guests