Page 1 of 1

Management IP problem

Posted: Fri Nov 16, 2012 5:28 pm
by ununium
Hello!

I've been struggling, with perhaps, a very simple problem over the last couple of days.

I'm trying to move my current bridged network to a routed one using OSPF.
Everything is working fine in my lab tests but the real problem I'm getting is with the management IP addresses.

The backhaul links have a 192.168.10.x/24 IP and gateway 192.168.10.1, which is configured at the edge router.

In the mikrotik I tried configuring an IP on the same network on ETH1 and ETH4 were I have each of the backhaul devices connected,
but only the IP address at ETH1 is reachable from my side.

I need to mention that none of the interfaces are bridged and I wish they stayed like that.

Also I think, but most likely I'll be wrong, that its unnecessary to add the network 192.168.10.x/24 to the OSPF routes redistribution for only management ip's.

Any help would be greatly appreciated.

Thanks!

Re: Management IP problem

Posted: Sun Nov 18, 2012 6:58 pm
by CelticComms
A diagram of what you are trying to achieve would be useful but it sounds as if you are trying to configure two interfaces of the routerboard onto the same /24 network. Have you run trace routes from the core? Checked the interfaces on the routerboard?

It smells as if the routerboard has one active route to the /24 at any point - so you are having issues with traffic to the other IP - but a diagram would make the situation clearer.

Re: Management IP problem

Posted: Mon Nov 19, 2012 12:05 am
by ununium
Thanks for your reply CelticComms.

This is the diagram of what the network looks like.
The orange boxes represent the backhaul links between the routers.

Image

I ran a traceroute from the core to the backhaul device and only has one hop, which ends at the core's address (192.168.10.1).

As you mentioned I tried configuring both interfaces in the same /24 subnet, but no dice.

I've verified the interfaces on the routerboard and they are working as expected, also the mikrotik at the next hop is reachable. Its only the backhaul devices which arent responding.

Re: Management IP problem

Posted: Mon Nov 19, 2012 6:12 am
by CelticComms
Does the diagram use different interface ids compared to your original description? e.g. Eth1 is not in the diagram....

If you have a router with the same /24 on 2 different interfaces the routing is likely to be ill-defined. Why not subnet further so that each interface has (say) its own /28 or similar?

Re: Management IP problem

Posted: Mon Nov 19, 2012 3:47 pm
by ununium
You're absolutely right. I mistakenly mentioned ETH1 on my initial post when its ETH2.
I configured the /24 on ETH2 and ETH4.

**Edit**
It works now!
I configured a /29 on ETH4 and the backhauls using the Mikrotik as gateway and now I can reach both devices.

Thank you so much for your help CelticComm!