Community discussions

MUM Europe 2020
 
plisken
Forum Guru
Forum Guru
Topic Author
Posts: 2438
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

2 isp to 1 lan

Fri Jan 25, 2013 12:01 am

I have a router board 2011UAS-2HnD
wan1 eth10 = dhcp client default route distance = 2 eth9 =
wan2 eth9 =dhcp client default route distance = 1
eth1 = Lan 192.168.100.0/24 I would that if wan1 fails wan2 come to work.
how can wan2 see that when wan1 failt wan2 take over the job?
I try this but it's not working
http://wiki.mikrotik.com/wiki/Load_Bala ... e_Gateways
like to advice
 
CelticComms
Forum Guru
Forum Guru
Posts: 1766
Joined: Wed May 02, 2012 5:48 am

Re: 2 isp to 1 lan

Fri Jan 25, 2013 12:31 am

Interlynx | Networking and Information Security Consultants & Trainers | Email: routerlynx@gmail.com
BGP | EIGRP | OSPF | MPLS | Firewall | VPN | IPsec | Multicast | QOS | IPv4/6 | STP | VLAN | PON | AE | M2M | and more!

 
plisken
Forum Guru
Forum Guru
Topic Author
Posts: 2438
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: 2 isp to 1 lan

Fri Jan 25, 2013 10:03 am

See this good to you?

[admin@MikroTik] /ip> route
[admin@MikroTik] /ip route> add dst-address=206.190.36.45 gateway=192.168.0.219
[admin@MikroTik] /ip route> add dst-address=206.190.36.45 gateway=10.98.247.145
[admin@MikroTik] /ip route> add distance=1 gateway=192.168.0.219 routing-mark=isp1
[admin@MikroTik] /ip route> add distance=1 gateway=192.168.0.219 routing-mark=isp1 check-gateway=ping
[admin@MikroTik] /ip route> add distance=1 gateway=10.98.247.145 routing-mark=isp2 check-gateway=ping
[admin@MikroTik] /ip route> add distance=1 gateway=10.98.1.1 routing-mark=isp2 check-gateway=ping
[admin@MikroTik] /ip route> add distance=2 gateway=206.190.36.45 routing-mark=isp2 check-gateway=ping
[admin@MikroTik] /ip route> add dst-address=85.234.197.5 gateway=192.168.0.219 scope=10
[admin@MikroTik] /ip route> add dst-address=10.98.212.10 gateway=10.98.247.145 scope=10
[admin@MikroTik] /ip route> add dst-address=10.1.1.1 gateway=206.190.36.45 scope=10 target-scope=10 check-gateway=ping
[admin@MikroTik] /ip route> add dst-address=10.1.1.1 gateway=85.234.197.5 scope=10 target-scope=10 check-gateway=ping
[admin@MikroTik] /ip route> add dst-address=10.2.2.2. gateway=10.98.1.1 scope=10 target-scope=10 check-gateway=ping
value of dst-address must contain '/'
[admin@MikroTik] /ip route> add dst-address=10.2.2.2 gateway=10.98.1.1 scope=10 target-scope=10 check-gateway=ping
[admin@MikroTik] /ip route> add dst-address=10.2.2.2 gateway=10.98.212.10 scope=10 target-scope=10 check-gateway=ping
[admin@MikroTik] /ip route> add distance=1 gateway=10.1.1.1 routing-mark=isp1
[admin@MikroTik] /ip route> add distance=1 gateway=10.2.2.2 routing-mark=isp1
[admin@MikroTik] /ip route> add distance=1 gateway=10.2.2.2 routing-mark=isp2
[admin@MikroTik] /ip route> add distance=1 gateway=10.1.1.1 routing-mark=isp2
[admin@MikroTik] /ip route> add dst-address=206.190.36.45 type=blackhole distance20
expected end of command (line 1 column 46)
[admin@MikroTik] /ip route> add dst-address=206.190.36.45 type=blackhole distance=20
[admin@MikroTik] /ip route> add dst-address=10.98.1.1 type=blackhole distance=20

I don't understood the 10.1.1.1 and the 10.2.2.2 ip's
that really exist? should I set it somewhere
 
plisken
Forum Guru
Forum Guru
Topic Author
Posts: 2438
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: 2 isp to 1 lan

Sun Jan 27, 2013 10:41 am

It does not work,
What am I doing wrong
If both isp's online = internet reachable
If isp1 is down = internet unreachable
After reboot router is isp2 reachable

Nat rules
[admin@MikroTik] /ip firewall nat> print detail
Flags: X - disabled, I - invalid, D - dynamic
0 chain=srcnat action=masquerade src-address=192.168.100.0/24 out-interface=gw1

1 chain=srcnat action=masquerade src-address=192.168.100.0/24 out-interface=gw2
[admin@MikroTik] /ip firewall nat>


dhcp-client


[admin@MikroTik] /ip dhcp-client> print detail
Flags: X - disabled, I - invalid
0 interface=gw1 add-default-route=yes default-route-distance=1 use-peer-dns=yes use-peer-ntp=yes dhcp-options=hostname,clientid status=bound
address=192.168.0.233/24 gateway=192.168.0.1 dhcp-server=192.168.0.1 primary-dns=195.130.131.2 secondary-dns=195.130.130.130 expires-after=48m12s

1 interface=gw2 add-default-route=yes default-route-distance=2 use-peer-dns=yes use-peer-ntp=yes dhcp-options=hostname,clientid status=bound
address=10.98.247.148/28 gateway=10.98.247.145 dhcp-server=10.98.247.145 primary-dns=10.98.213.10 secondary-dns=10.98.88.1 primary-ntp=10.98.247.145
secondary-ntp=85.234.197.2 expires-after=23h39m37s
[admin@MikroTik] /ip dhcp-client>



With isp1 down

[admin@MikroTik] /ip route> print detail
Flags: X - disabled, A - active, D - dynamic,
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
B - blackhole, U - unreachable, P - prohibit
0 S dst-address=0.0.0.0/0 gateway=98.139.183.24
gateway-status=98.139.183.24 unreachable check-gateway=ping distance=1
scope=30 target-scope=10 routing-mark=isp1

1 S dst-address=0.0.0.0/0 gateway=173.194.65.94
gateway-status=173.194.65.94 unreachable check-gateway=ping distance=2
scope=30 target-scope=10 routing-mark=isp1

2 S dst-address=0.0.0.0/0 gateway=173.194.65.94
gateway-status=173.194.65.94 unreachable check-gateway=ping distance=1
scope=30 target-scope=10 routing-mark=isp2

3 S dst-address=0.0.0.0/0 gateway=98.139.183.24
gateway-status=98.139.183.24 unreachable check-gateway=ping distance=2
scope=30 target-scope=10 routing-mark=isp2

4 ADS dst-address=0.0.0.0/0 gateway=10.98.247.145
gateway-status=10.98.247.145 reachable via gw2 distance=2 scope=30
target-scope=10 vrf-interface=gw2

5 ADC dst-address=10.98.247.144/28 pref-src=10.98.247.148 gateway=gw2
gateway-status=gw2 reachable distance=0 scope=10

6 S dst-address=98.139.183.24/32 gateway=gw1 gateway-status=gw1 unreachable
distance=1 scope=10 target-scope=10

7 A SB dst-address=98.139.183.24/32 type=blackhole distance=20

8 A S dst-address=173.194.65.94/32 gateway=gw2 gateway-status=gw2 reachable
distance=1 scope=10 target-scope=10

9 SB dst-address=173.194.65.94/32 type=blackhole distance=20

10 ADC dst-address=192.168.100.0/24 pref-src=192.168.100.1 gateway=bridge-lan
gateway-status=bridge-lan reachable distance=0 scope=10

[admin@MikroTik] /ip route>



With isp1 and isp2 up

[admin@MikroTik] /ip route> print detail
Flags: X - disabled, A - active, D - dynamic,
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
B - blackhole, U - unreachable, P - prohibit
0 S dst-address=0.0.0.0/0 gateway=98.139.183.24
gateway-status=98.139.183.24 unreachable check-gateway=ping
distance=1 scope=30 target-scope=10 routing-mark=isp1

1 S dst-address=0.0.0.0/0 gateway=173.194.65.94
gateway-status=173.194.65.94 unreachable check-gateway=ping
distance=2 scope=30 target-scope=10 routing-mark=isp1

2 S dst-address=0.0.0.0/0 gateway=173.194.65.94
gateway-status=173.194.65.94 unreachable check-gateway=ping
distance=1 scope=30 target-scope=10 routing-mark=isp2

3 S dst-address=0.0.0.0/0 gateway=98.139.183.24
gateway-status=98.139.183.24 unreachable check-gateway=ping
distance=2 scope=30 target-scope=10 routing-mark=isp2

4 ADS dst-address=0.0.0.0/0 gateway=192.168.0.1
gateway-status=192.168.0.1 reachable via gw1 distance=1 scope=30
target-scope=10 vrf-interface=gw1

5 DS dst-address=0.0.0.0/0 gateway=10.98.247.145
gateway-status=10.98.247.145 reachable via gw2 distance=2 scope=30
target-scope=10 vrf-interface=gw2

6 ADC dst-address=10.98.247.144/28 pref-src=10.98.247.148 gateway=gw2
gateway-status=gw2 reachable distance=0 scope=10

7 A S dst-address=98.139.183.24/32 gateway=gw1 gateway-status=gw1 reachable
distance=1 scope=10 target-scope=10

8 SB dst-address=98.139.183.24/32 type=blackhole distance=20

9 A S dst-address=173.194.65.94/32 gateway=gw2 gateway-status=gw2 reachable
distance=1 scope=10 target-scope=10

10 SB dst-address=173.194.65.94/32 type=blackhole distance=20

11 ADC dst-address=192.168.0.0/24 pref-src=192.168.0.233 gateway=gw1
gateway-status=gw1 reachable distance=0 scope=10

12 ADC dst-address=192.168.100.0/24 pref-src=192.168.100.1 gateway=bridge-lan
gateway-status=bridge-lan reachable distance=0 scope=10

[admin@MikroTik] /ip route>
 
duxovni
newbie
Posts: 25
Joined: Sun Jan 27, 2013 10:34 am

Re: 2 isp to 1 lan

Sun Jan 27, 2013 10:43 am

I don't understood the 10.1.1.1 and the 10.2.2.2 ip's
that really exist? should I set it somewhere

It is an example
You should use yours
 
duxovni
newbie
Posts: 25
Joined: Sun Jan 27, 2013 10:34 am

Re: 2 isp to 1 lan

Sun Jan 27, 2013 11:23 am

I don't understood the 10.1.1.1 and the 10.2.2.2 ip's
that really exist? should I set it somewhere

its an example.
you should use your appropriate one
 
plisken
Forum Guru
Forum Guru
Topic Author
Posts: 2438
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: 2 isp to 1 lan

Sun Jan 27, 2013 9:24 pm

I understand that this is as an example, but I don't know which ip range in to use. This Is the lan ip range?

Thanks for your reply
 
deejayq
Member Candidate
Member Candidate
Posts: 195
Joined: Wed Feb 23, 2011 8:33 am

Re: 2 isp to 1 lan

Wed Jan 30, 2013 12:32 pm

use two ip's that should never be offline, like google dns and opendns or something like it
if it's pingable you can use it
 
plisken
Forum Guru
Forum Guru
Topic Author
Posts: 2438
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: 2 isp to 1 lan

Mon Feb 04, 2013 12:16 am

it still don't work

Who is online

Users browsing this forum: pwrusrcom and 50 guests