Community discussions

MikroTik App
 
Trekkie
newbie
Topic Author
Posts: 37
Joined: Thu Feb 07, 2013 1:48 am

R493G and DHCP client

Sat Feb 09, 2013 8:34 am

I'm learning my way through RouterOS and have been unable to get a dhcp address on my wan port.

I can plug the same cord into computer, and it gets an address from my dsl modem, but plug it into ether 1 and no address.

At the moment I only have two things set. Ether1 is set to name public, and I have a bridge with ether2-9 in it, and they are set with interface 172.16.0.1 and a dhcp server giving out 172.16.1.2 - 254

Interface public has dhcp client turned on and nothing else. Link is established.

Am I missing something silly? I can't find anything in the wiki looks very straight forward just weird that it isn't working.
 
Trekkie
newbie
Topic Author
Posts: 37
Joined: Thu Feb 07, 2013 1:48 am

Re: R493G and DHCP client

Sat Feb 09, 2013 4:47 pm

# jan/01/1970 19:05:48 by RouterOS 5.23
# software id = xxx
#
/interface bridge
add l2mtu=1520 name=Local
/interface ethernet
set 0 name=WAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m
/ip pool
add name=dhcp_pool1 ranges=172.16.0.2-172.16.0.254
/ip dhcp-server
add add-arp=yes address-pool=dhcp_pool1 authoritative=yes disabled=no \
    interface=Local name=dhcp1
/interface bridge port
add bridge=Local interface=ether2
add bridge=Local interface=ether3
add bridge=Local interface=ether4
add bridge=Local interface=ether5
add bridge=Local interface=ether6
add bridge=Local interface=ether7
add bridge=Local interface=ether8
add bridge=Local interface=ether9
/ip address
add address=192.168.88.1/24 comment="default configuration" disabled=yes \
    interface=WAN
add address=172.16.0.1/24 interface=Local
/ip dhcp-client
add default-route-distance=0 disabled=no interface=WAN use-peer-dns=no
/ip dhcp-server network
add address=172.16.0.0/24 dns-server=208.67.222.222,208.67.220.220 gateway=\
    172.16.0.1 netmask=24
/ip dns
set allow-remote-requests=yes servers=208.67.222.222,208.67.220.220
/ip dns static
add address=192.168.88.1 name=router
/ip firewall nat
add action=masquerade chain=srcnat src-address=172.16.0.0/24 to-addresses=\
    0.0.0.0
/ip service
set telnet disabled=yes
set winbox disabled=yes
/ip upnp
set enabled=yes
/ip upnp interfaces
add interface=Local type=internal
add interface=WAN type=external
/ipv6 nd
set [ find default=yes ] advertise-dns=yes managed-address-configuration=yes
/snmp
set contact=trekkie@nomorestars.com enabled=yes location="1722 Lambton Ave"
/system clock
set time-zone-name=EST5EDT
/system identity
set name=galaxy
/system ntp client
set enabled=yes mode=unicast primary-ntp=64.90.182.55 secondary-ntp=\
    216.229.0.179
IN case this helps any, here is my config. I put xx in the software license in case that is unique.
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: R493G and DHCP client

Sat Feb 09, 2013 5:05 pm

Just a thought. Have you tried powering down your modem for a few seconds while changing devices? Mine doesn't like a mac address change without a reboot, and will not issue an ip address to the new mac address.
 
Trekkie
newbie
Topic Author
Posts: 37
Joined: Thu Feb 07, 2013 1:48 am

Re: R493G and DHCP client

Sat Feb 09, 2013 5:34 pm

Yeah something weird is afoot. I built a quick dhcp server and plugged it in and iq got an address faster than I could change menu.

I've done the power dance resetting everything, even let it sit overnight. Weird
 
CelticComms
Forum Guru
Forum Guru
Posts: 1766
Joined: Wed May 02, 2012 5:48 am

Re: R493G and DHCP client

Sat Feb 09, 2013 6:03 pm

Some ISPs have delays on providing IPs to multiple MAC addresses via DHCP.

To check if that is a problem you can temporarily set the MAC address of the WAN port to be the same as the (known working) computer and see if that changes anything.
Interlynx | Networking and Information Security Consultants & Trainers | Email: routerlynx@gmail.com
BGP | EIGRP | OSPF | MPLS | Firewall | VPN | IPsec | Multicast | QOS | IPv4/6 | STP | VLAN | PON | AE | M2M | and more!

 
Trekkie
newbie
Topic Author
Posts: 37
Joined: Thu Feb 07, 2013 1:48 am

Re: R493G and DHCP client

Sat Feb 09, 2013 7:24 pm

I turned everything off for a while, and now it's working. Glad I wasn't an idiot :)

Who is online

Users browsing this forum: No registered users and 32 guests