Community discussions

 
ddff
just joined
Topic Author
Posts: 12
Joined: Sun Dec 02, 2012 9:23 pm

One router and one AP

Mon Mar 11, 2013 11:06 pm

Sorry, if this has been discussed before, I tried to search for it, but I guess I can't define my question good enough.

I got two RB951G-2HnD units and I want to buid following setup- unit 1 is connected to ISP and acts as a router, unit 2 is connected to unit 1 via ethernet cable and acts as wi-fi range extender and ethernet switch.

I've managed to set up unit 1 as expected, now I'm confused what is proper way to configure unit2.

I'd be glad if unit 2 would have same SSID as unit 1, if it could use ACL from unit 1 and also forward DHCP addresses from unit 1.

Not sure if I made myself clear, but I hope someone will point me to solution.

ddff
 
nmaton
Frequent Visitor
Frequent Visitor
Posts: 72
Joined: Fri Feb 18, 2011 12:31 am

Re: One router and one AP

Mon Mar 11, 2013 11:14 pm

Configure unit 2 as such.

Configure the wireless as ap bridge. (configure all settings as unit1)

Next create a bridge interface.

/interface bridge
add name=bridge-work protocol-mode=rstp

Then add your ethernet interfaces that you want bridged

/interface bridge port
add bridge=home-bridge interface=wlan1(your wireless interface)
add bridge=home-bridge interface=ether(your uplink)
add bridge=bridge-work interface=ether(any other port youd like to have dhcp from uplink)
Nicolas Maton
nicolasmaton@gmail.com

CCNA/ CCDA
MTCNA / MTCTCE

Available for Mikrotik Consulting
 
ddff
just joined
Topic Author
Posts: 12
Joined: Sun Dec 02, 2012 9:23 pm

Re: One router and one AP

Tue Mar 12, 2013 11:45 am

Many thanks for reply.
Wow, that sounds way too simple :)

So you mean I should bridge WAN+LAN+WLAN and that's it? What about addressing?
How will I be able to access the router afterwards? It will get IP from DHCP?
What about WLAN ACL? Will it be forwarded from unit1 ? Should I also enable ACL on unit2 ?


Sorry for so many questions in a row, just trying to believe this can work.

ddff
 
nmaton
Frequent Visitor
Frequent Visitor
Posts: 72
Joined: Fri Feb 18, 2011 12:31 am

Re: One router and one AP

Tue Mar 12, 2013 4:16 pm

yes this will work.

First step is to create the AP configuration on Router 2 this is with the ACL which you already have defined on R1.
Go to your first router and enter :

/interface wireless access-list export

you should get :

/interface wireless access-list
add mac-address=0F:0F:0F:0F:0F:0F

You can copy all of your output to R2.

Then you create a bridge interface.
In the bridge interface you put the WLAN, and all ethernet ports you want bridged.

you can put a static ip address on the bridge interface so you could manage the device.

You do need to be sure that the ethernet interfaces that you'd like to add to the bridge don't have a master port. (double click on interface ether and check the master port .. it should have none).
Nicolas Maton
nicolasmaton@gmail.com

CCNA/ CCDA
MTCNA / MTCTCE

Available for Mikrotik Consulting
 
ddff
just joined
Topic Author
Posts: 12
Joined: Sun Dec 02, 2012 9:23 pm

Re: One router and one AP

Wed Mar 13, 2013 10:45 am

Hi,

I'm glad to report the bridge thing actually works. Is there any chance that these two routers could exchange ACL between them? At the moment I have to create every new record on both.

ddff
 
nmaton
Frequent Visitor
Frequent Visitor
Posts: 72
Joined: Fri Feb 18, 2011 12:31 am

Re: One router and one AP

Wed Mar 13, 2013 11:11 am

you could export a part of the script and put it in sheduler.


/system scheduler
add interval=30m name=dyndns-update-scheduler on-event=\
"/interface wireless access-list export file=file-to-export" policy=\
ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api start-time=\
startup

Then you have an export of your acl on R1.

If you enable the ftp server on R1 then you could go to R2 and run a sheduler script that gets that part of the configuration and adds it.

You can get files with /tool fetch
Nicolas Maton
nicolasmaton@gmail.com

CCNA/ CCDA
MTCNA / MTCTCE

Available for Mikrotik Consulting

Who is online

Users browsing this forum: No registered users and 46 guests