Community discussions

 
boa
just joined
Topic Author
Posts: 4
Joined: Wed May 15, 2013 1:35 pm

Multiple profiles/subnets on PPTP

Wed May 15, 2013 4:16 pm

Hello,

Is it possible to setup two or more profiles with PPTP connection?
At this moment i need to setup two different Subnets/Radius/Domains/PPTP profiles.
Everything is working fine, except profile.
There is default profile set in PPTP server setup, and i have no clue how to force MT to choose another.
Setting by Local IP address does not work, everytime default profile is used.
It means, no matter if i'll connect to PPTP address A (10.10.10.1) or B (10.10.10.2), i'm receiving default profile IP.

Must be simple solution, i'm just not seeing it.

Using CCR1016-12G v6.0rc13.

Sample config below:
/ip pool
add name=Domain_A_clients_pool ranges=192.168.1.200-192.168.1.250
add name=Domain_B_clients_pool ranges=192.168.2.200-192.168.2.250

/ppp profile
add dns-server=192.168.1.2 local-address=10.10.10.1 name=Domain_A_remote \
    remote-address=Domain_A_clients_pool session-timeout=0s use-encryption=yes
add dns-server=192.168.2.2 local-address=10.10.10.2 name=Domain_B_remote \
    remote-address=Domain_B_clients_pool session-timeout=0s use-encryption=yes

add address=10.10.10.1/32 comment="external IP for PPTP - Domain A" \
    interface=ether2 network=255.255.255.255
add address=10.10.10.2/32 comment="External IP for PPTP - Domain B" \
    interface=ether2 network=255.255.255.255

/interface pptp-server server
set default-profile=Domain_A_remote enabled=yes

You do not have the required permissions to view the files attached to this post.
 
User avatar
nickshore
Member
Member
Posts: 473
Joined: Thu Mar 03, 2005 4:14 pm
Location: Suffolk, UK.
Contact:

Re: Multiple profiles/subnets on PPTP

Wed May 15, 2013 5:50 pm

I think you might be able to specify the local and remote address in the radius profile.

Use Framed-IP-Address for the remote IP and Framed-Route for the local address.

I've not tested it yet...

Nick.
Nick Shore MTCNA MTCWE MTCRE MTCINE MTCTCE
LinITX.com - MultiThread Consultants
Get your MikroTik RBs and Training: http://linitx.com/brand/mikrotik
Official UK MikroTik Distributor
IRC chan: #routerboard on irc.z.je (IPv4 and IPv6)
 
boa
just joined
Topic Author
Posts: 4
Joined: Wed May 15, 2013 1:35 pm

Re: Multiple profiles/subnets on PPTP

Thu May 16, 2013 9:08 am

Radius is working fine. Local and remote are in there.
Depending on PPTP external IP address it queries correct domain controler for username.
Trouble is, no matter what domain it queries i'm receiving Default profile IP address.
If i'm correct, i need to use at least 2 profiles, to get different subnets for PPTP clients.
Or find another method to achieve that.

Who is online

Users browsing this forum: Google [Bot], MSN [Bot] and 27 guests