Community discussions

MUM Europe 2020
 
class889
just joined
Topic Author
Posts: 18
Joined: Wed Sep 11, 2013 9:24 am

how can i test WAN TO LAN throughput with x86 routerOS?

Wed Sep 11, 2013 9:38 am

hello everyone.
i got my routerOS 6.3 up and running with VDSL connection.
and soon they gonna upgrade in our city from 100mbit to 1Gbit connection.

im running RouterOS x86 on Pentium 4 @3.06Ghz HT, 2GB of RAM , with 1 PCI-E 1Gbit adapter and 1 PCI 1Gbit adapter.

how should i test WAN to LAN throughput? im guessing im gonna need IPERF or such?
just connect one pc to the wan and one to the lan and set static route, thats all? or there's other way i can?

btw what speeds should i expect from such rig?


thank you in advanced :)
 
deejayq
Member Candidate
Member Candidate
Posts: 195
Joined: Wed Feb 23, 2011 8:33 am

Re: how can i test WAN TO LAN throughput with x86 routerOS?

Thu Sep 12, 2013 8:22 am

i think the bandwidth test in routeros could work
in this scenario you have to have a computer connected to the lan and download on that computer http://www.mikrotik.com/download/btest.exe .
then set it to connect to your routeros wan ip and start generating traffic.

for your second question the answer is: it depends.
 
onnoossendrijver
Member
Member
Posts: 418
Joined: Mon Jul 14, 2008 11:10 am
Location: The Netherlands

Re: how can i test WAN TO LAN throughput with x86 routerOS?

Thu Sep 12, 2013 9:53 am

hello everyone.
how should i test WAN to LAN throughput? im guessing im gonna need IPERF or such?
just connect one pc to the wan and one to the lan and set static route, thats all? or there's other way i can?
This could work.
If you do NAT you don't need to set a static route, just test from LAN to WAN IP.
I would expect 500+ mbit/s. If you change PCI NIC for PCI-express NIC it should do near gigabit speeds.
Linux/network engineer: ITIL, LPI1, CCNA R+S, CCNP R+S, JNCIA, JNCIS-SEC
 
class889
just joined
Topic Author
Posts: 18
Joined: Wed Sep 11, 2013 9:24 am

Re: how can i test WAN TO LAN throughput with x86 routerOS?

Thu Sep 12, 2013 8:17 pm

so i did few tests, please bare with me. (let me explain in short my network)

i got VDSL connection atm, this VDSL modem is connected to the wan port. the WAN IP i setup is 10.0.0.8/24 and the modem IP is 10.0.0.138.

the LAN is setup for 192.168.0.1.
here's some pictures:

Image

Image

Image

ok so before i tried what u both suggested i took a pc and set it up with 192.168.2.2 , and in the router i just made address on the WAN (see in the picture , the disable rule) and then i used IPERF to test and i got 640Mbit.

then to see if its the PCI card that is limiting i changed it to be the LAN and i used BTEST to test with it, and i got the same results only 640Mbit (i was using LAN to LAN test).
then i did with BTEST to my PCI-E card and i got 970Mbit.

so from that i understood that the PCI is limiting.

then i read what both of u wrote , to test with BTEST to the WAN IP, well it work but it uses the LAN only. which means i got 950Mbit, while it should be 640.
here u can see it uses only the LAN, while i wrote the WAN ip:
Image


so i did what u guys said and i doesnt work, but maybe i did something wrong?

and thank you for trying to help me out :)
 
class889
just joined
Topic Author
Posts: 18
Joined: Wed Sep 11, 2013 9:24 am

Re: how can i test WAN TO LAN throughput with x86 routerOS?

Tue Sep 24, 2013 8:49 am

i guess only via static route?

Who is online

Users browsing this forum: llag and 53 guests