Community discussions

MUM Europe 2020
 
infused
Member
Member
Topic Author
Posts: 308
Joined: Fri Dec 28, 2012 2:33 pm

Improve my queues :)

Wed Sep 18, 2013 12:57 am

Hi Guys,

I have two queues on a rb2011.

I am tagging sip traffic and rdp traffic to a remote provider (using address lists instead of ports), then using a queue tree to raise the priority. What I want to do is limit any non-tagged traffic to 2mb/s in both directions.

Here's my code:
/ip firewall mangle
add action=mark-packet chain=forward comment="voip mark source" \
    new-packet-mark=voip-source passthrough=no src-address-list=v
add action=mark-packet chain=forward comment="voip mark dest" \
    dst-address-list=voip new-packet-mark=voip-dest passthrough=n
add action=mark-packet chain=forward comment="cloudless source" \
    new-packet-mark=cloudless-source passthrough=no src-address=2
add action=mark-packet chain=forward comment="cloudless dest" dst
    0.0.0.0 new-packet-mark=cloudless-dest passthrough=no
/ip firewall nat
add action=masquerade chain=srcnat comment="default configuration
    out-interface=ether6-wan
(Removed IPs)
/queue tree
add name=cloudless-source packet-mark=cloudless-source parent=global priority=2 queue=default
add name=voip-source packet-mark=voip-source parent=global priority=1 queue=default
add name=voip-dest packet-mark=voip-dest parent=global priority=1 queue=default
add name=cloudless-dest packet-mark=cloudless-dest parent=global priority=2 queue=default
How would I limit all other traffic not marked to say 2mbit?
 
deejayq
Member Candidate
Member Candidate
Posts: 195
Joined: Wed Feb 23, 2011 8:33 am

Re: Improve my queues :)

Wed Sep 18, 2013 10:29 am

add this at bottom of forward list

/ip firewall mangle
add action=mark-packet chain=forward new-packet-mark=else passthrough=no

add this at queue tree

/queue tree
add name=else packet-mark=else parent=global priority=3 max-limit=2M

Who is online

Users browsing this forum: satboxbg and 49 guests