Community discussions

MUM Europe 2020
 
sum1234
just joined
Topic Author
Posts: 3
Joined: Wed Sep 18, 2013 6:10 am

Blocking access to google play store

Fri Sep 20, 2013 11:17 am

Hi all,
I am new to mikrotik and have just played with rb450g for 4 days.
Can someone tell me how to block Google Play Store so the users wont be able to download games?
Tried blocking some ports(5228), didnt work...
Thanks in advance
 
User avatar
asaleh75
Trainer
Trainer
Posts: 184
Joined: Thu Nov 17, 2011 2:51 pm
Location: Dhaka, Bangladesh
Contact:

Re: Blocking access to google play store

Fri Sep 20, 2013 11:48 pm

Hi,
Try with following filter rules
/ip firewall filter add action=drop chain=forward content=play.google.com disabled=yes dst-port=80,443 protocol=tcp
Syed Abu Saleh
( MTCNA, MTCRE, MTCWE, MTCTCE, MTCUME, MTCINE )
MikroTik Certified Trainer & Consultant

http://www.sastechbd.com
Cell:+8801713060704
 
deejayq
Member Candidate
Member Candidate
Posts: 195
Joined: Wed Feb 23, 2011 8:33 am

Re: Blocking access to google play store

Sat Sep 21, 2013 12:12 am

i would suggest a layer 7 filter with play.google.com
then add a filter rule to reject all packets going to any ip on port 53 and containing the layer 7 filter you created earlier.
the content option that user asaleh75 suggested would block any packet containing play.google.com, be it text, hyperlink etc.
 
User avatar
asaleh75
Trainer
Trainer
Posts: 184
Joined: Thu Nov 17, 2011 2:51 pm
Location: Dhaka, Bangladesh
Contact:

Re: Blocking access to google play store

Sat Sep 21, 2013 1:18 pm

i would suggest a layer 7 filter with play.google.com
then add a filter rule to reject all packets going to any ip on port 53 and containing the layer 7 filter you created earlier.
the content option that user asaleh75 suggested would block any packet containing play.google.com, be it text, hyperlink etc.
Hi, You can read http://wiki.mikrotik.com/wiki/Manual:IP/Firewall/L7 to know Layer 7.
Syed Abu Saleh
( MTCNA, MTCRE, MTCWE, MTCTCE, MTCUME, MTCINE )
MikroTik Certified Trainer & Consultant

http://www.sastechbd.com
Cell:+8801713060704
 
sum1234
just joined
Topic Author
Posts: 3
Joined: Wed Sep 18, 2013 6:10 am

Re: Blocking access to google play store

Sun Sep 22, 2013 8:37 am

Thanks for the tips,
i played around L7, with 'youtube.com' in the regexp.

HTTPS for youtube is blocked, and so is Play Store. (Weird)

Below is the filter ( Is this rule ok?)
======================================
[admin@RB450G] /ip firewall mangle> print
Flags: X - disabled, I - invalid, D - dynamic
0 X chain=prerouting action=mark-packet new-packet-mark=blockme passthrough=yes layer7-protocol=blockHTTPS

[admin@RB450G] /ip firewall> filter print
Flags: X - disabled, I - invalid, D - dynamic
0 ;;; Accept established connections
chain=input action=accept connection-state=established

1 ;;; Accept related connections
chain=input action=accept connection-state=related

2 ;;; Drop invalid connections
chain=input action=drop connection-state=invalid

3 X chain=input action=accept protocol=tcp src-port=443

4 ;;; UDP
chain=input action=accept protocol=udp

5 X ;;; L7 Block Https youtube, but PLAY STORE TOO
chain=forward action=drop packet-mark=blockme

6 ;;; From our private LAN
chain=input action=accept src-address=192.168.101.0/24

7 ;;; Log everything else
chain=input action=log log-prefix="DROP INPUT"

8 ;;; Drop everything else
chain=input action=drop


======================================
 
sum1234
just joined
Topic Author
Posts: 3
Joined: Wed Sep 18, 2013 6:10 am

Re: Blocking access to google play store

Sun Sep 22, 2013 8:46 am

Hi,
Try with following filter rules
/ip firewall filter add action=drop chain=forward content=play.google.com disabled=yes dst-port=80,443 protocol=tcp

in addition, this one not working..i can still browse and update my app
 
wardimore
just joined
Posts: 1
Joined: Sun Apr 01, 2012 9:30 am

Re: Blocking access to google play store

Sat Jul 19, 2014 4:19 pm

could try here http://bit.ly/1zxR32C

Who is online

Users browsing this forum: CZFan and 39 guests